Skip to content

Commit

Permalink
games-fps/xonotic: tweak for gcc-11
Browse files Browse the repository at this point in the history
Reported-by: Artem Ilgamov
Closes: https://bugs.gentoo.org/788616
Package-Manager: Portage-3.0.19, Repoman-3.0.3
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Jun 13, 2021
1 parent bc2ba1c commit d510b19
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 1 deletion.
41 changes: 41 additions & 0 deletions games-fps/xonotic/files/xonotic-0.8.2-gcc-11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
https://bugs.gentoo.org/788616

Attach alignment annotation to strict, not it's typedef alias.
--- a/source/darkplaces/dpsoftrast.c
+++ b/source/darkplaces/dpsoftrast.c
@@ -177,7 +177,7 @@ typedef ALIGN(struct DPSOFTRAST_State_Triangle_s
float w[3];
ALIGN(float attribs[DPSOFTRAST_ARRAY_TOTAL][3][4]);
}
-DPSOFTRAST_State_Triangle);
+) DPSOFTRAST_State_Triangle;

#define DPSOFTRAST_CALCATTRIB(triangle, span, data, slope, arrayindex) { \
slope = _mm_load_ps((triangle)->attribs[arrayindex][0]); \
@@ -209,7 +209,7 @@ typedef ALIGN(struct DPSOFTRAST_State_Span_s
int depthbase; // depthbuffer value at x (add depthslope*startx to get first pixel's depthbuffer value)
int depthslope; // depthbuffer value pixel delta
}
-DPSOFTRAST_State_Span);
+) DPSOFTRAST_State_Span;

#define DPSOFTRAST_DRAW_MAXSPANS 1024
#define DPSOFTRAST_DRAW_MAXTRIANGLES 128
@@ -300,7 +300,7 @@ typedef ALIGN(struct DPSOFTRAST_State_Thread_s
DPSOFTRAST_State_Triangle triangles[DPSOFTRAST_DRAW_MAXTRIANGLES];
unsigned char pixelmaskarray[DPSOFTRAST_DRAW_MAXSPANLENGTH+4]; // LordHavoc: padded to allow some termination bytes
}
-DPSOFTRAST_State_Thread);
+) DPSOFTRAST_State_Thread;

typedef ALIGN(struct DPSOFTRAST_State_s
{
@@ -358,7 +358,7 @@ typedef ALIGN(struct DPSOFTRAST_State_s

DPSOFTRAST_State_Command_Pool commandpool;
}
-DPSOFTRAST_State);
+) DPSOFTRAST_State;

DPSOFTRAST_State dpsoftrast;

4 changes: 3 additions & 1 deletion games-fps/xonotic/xonotic-0.8.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -45,6 +45,8 @@ DEPEND="${RDEPEND}
!dedicated? ( ${UIDEPEND} )"
BDEPEND="app-arch/unzip"

PATCHES=("${FILESDIR}"/${P}-gcc-11.patch)

DOCS="Docs/*.txt"

CHECKREQS_DISK_BUILD="1200M"
Expand Down

0 comments on commit d510b19

Please sign in to comment.