Skip to content

Commit

Permalink
dev-util/rocminfo: Add -9999
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Sep 25, 2019
1 parent ddfc453 commit d557a00
Showing 1 changed file with 32 additions and 0 deletions.
32 changes: 32 additions & 0 deletions dev-util/rocminfo/rocminfo-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
inherit git-r3
else
SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/rocminfo-roc-${PV}"
fi

DESCRIPTION="ROCm Application for Reporting System Info"
HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"

RDEPEND="dev-libs/rocr-runtime"
DEPEND="${RDEPEND}"

src_configure() {
local mycmakeargs=(
-DROCM_DIR="${ESYSROOT}/usr"
-DROCR_INC_DIR="${ESYSROOT}/usr/include"
-DROCR_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
)
cmake-utils_src_configure
}

0 comments on commit d557a00

Please sign in to comment.