Skip to content

Commit

Permalink
gnome-extra/evolution-data-server: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
pacho2 committed Jul 2, 2016
1 parent 8d1bf7d commit d574bc5
Show file tree
Hide file tree
Showing 2 changed files with 138 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/evolution-data-server/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST evolution-data-server-3.18.5.tar.xz 5414416 SHA256 a897c789925e86df31a1c78212b431cca13dc4d5a3d87e1fb3d507df3994e8e1 SHA512 10b17b771dbb55ad8320b742d96f6d720f3245bed24fdc415027df6920b0847afa89eb839cd5d4613c0ec40972634c7c695e4ea0ce819973eab0de99987c253e WHIRLPOOL 3c95f43113882409bf85b8f97d49cea74e857ce4c562b625b0936bd014b0799ea16b6c7d2d9c0c0cdbd1f6ce7daf509c15d6413b26f275050da30030a5f0d2a3
DIST evolution-data-server-3.20.3.tar.xz 5066976 SHA256 910360685d832c97f617f02aa5a8eb10a9c0d7d7d5a8758b50aa6b88a60bee48 SHA512 94ea870056c34b75a348ee480d92f368629b500b07e505de9a884ff78b5677aed584bfc2189b55cd5b23fa5ed2d1add82d2e45c83db9ebc29adca12d880a0a50 WHIRLPOOL c39b7998b0eec497ee37aefe1b860cba6bf2ee724371605bc6c1b86aca7fc1bb418c2ebbfbc87fd62df29f65bdba43a1c97273db448994b1b88608803706b8e1
137 changes: 137 additions & 0 deletions gnome-extra/evolution-data-server/evolution-data-server-3.20.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,137 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
VALA_USE_DEPEND="vapigen"

inherit db-use flag-o-matic gnome2 python-any-r1 vala virtualx

DESCRIPTION="Evolution groupware backend"
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"

# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
SLOT="0/57" # subslot = libcamel-1.2 soname version

IUSE="api-doc-extras +berkdb +gnome-online-accounts +gtk google +introspection ipv6 ldap kerberos vala +weather"
REQUIRED_USE="vala? ( introspection )"

KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"

# sys-libs/db is only required for migrating from <3.13 versions
# gdata-0.15.1 is required for google tasks
# berkdb needed only for migrating old calendar data, bug #519512
RDEPEND="
>=app-crypt/gcr-3.4
>=app-crypt/libsecret-0.5[crypt]
>=dev-db/sqlite-3.7.17:=
>=dev-libs/glib-2.40:2
>=dev-libs/libgdata-0.10:=
>=dev-libs/libical-0.43:=
>=dev-libs/libxml2-2
>=dev-libs/nspr-4.4:=
>=dev-libs/nss-3.9:=
>=net-libs/libsoup-2.42:2.4
dev-libs/icu:=
sys-libs/zlib:=
virtual/libiconv
berkdb? ( >=sys-libs/db-4:= )
gtk? (
>=app-crypt/gcr-3.4[gtk]
>=x11-libs/gtk+-3.10:3
)
google? (
>=dev-libs/json-glib-1.0.4
>=dev-libs/libgdata-0.15.1:=
>=net-libs/webkit-gtk-2.4.9:3
)
gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
kerberos? ( virtual/krb5:= )
ldap? ( >=net-nds/openldap-2:= )
weather? ( >=dev-libs/libgweather-3.10:2= )
"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-util/gdbus-codegen
dev-util/gperf
>=dev-util/gtk-doc-am-1.14
>=dev-util/intltool-0.35.5
>=sys-devel/gettext-0.17
virtual/pkgconfig
vala? ( $(vala_depend) )
"

# eautoreconf needs:
# >=gnome-base/gnome-common-2

# Some tests fail due to missings locales.
# Also, dbus tests are flacky, bugs #397975 #501834
# It looks like a nightmare to disable those for now.
RESTRICT="test"

pkg_setup() {
python-any-r1_pkg_setup
}

src_prepare() {
use vala && vala_src_prepare
gnome2_src_prepare
}

src_configure() {
# /usr/include/db.h is always db-1 on FreeBSD
# so include the right dir in CPPFLAGS
use berkdb && append-cppflags "-I$(db_includedir)"

# phonenumber does not exist in tree
gnome2_src_configure \
$(use_enable api-doc-extras gtk-doc) \
$(use_with api-doc-extras private-docs) \
$(usex berkdb --with-libdb="${EPREFIX}"/usr --with-libdb=no) \
$(use_enable gnome-online-accounts goa) \
$(use_enable gtk) \
$(use_enable google google-auth) \
$(use_enable google) \
$(use_enable introspection) \
$(use_enable ipv6) \
$(use_with kerberos krb5 "${EPREFIX}"/usr) \
$(use_with kerberos krb5-libs "${EPREFIX}"/usr/$(get_libdir)) \
$(use_with ldap openldap) \
$(use_enable vala vala-bindings) \
$(use_enable weather) \
--enable-largefile \
--enable-smime \
--without-phonenumber \
--disable-examples \
--disable-uoa
}

src_test() {
unset ORBIT_SOCKETDIR
unset SESSION_MANAGER
virtx emake check
}

src_install() {
gnome2_src_install

if use ldap; then
insinto /etc/openldap/schema
doins "${FILESDIR}"/calentry.schema
dosym /usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
fi
}

pkg_postinst() {
gnome2_pkg_postinst
if ! use berkdb; then
ewarn "You will need to enable berkdb USE for migrating old"
ewarn "(pre-3.12 evolution versions) addressbook data"
fi
}

0 comments on commit d574bc5

Please sign in to comment.