Skip to content

Commit

Permalink
dev-ruby/dalli: add 2.7.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
graaff committed Apr 10, 2018
1 parent 31113a6 commit d57bc9b
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/dalli/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dalli-2.7.6.tar.gz 48481 BLAKE2B 9f83523b75d1c6fa109aba7e288e13924d8c7677c6fa38ffe5ce21dfb22f858f8a3ab8593afceed97e980e5f0172c1f8c58cc96b42f4bde31013f5ffcbb26f8b SHA512 ee2270e719f6ff108654d20dfc560cdc6067808c211ae75304f5ca3f7772561b25a699fddb051e42db744bb202228bdbb904171faf5e1804f1f2bed4341bc258
DIST dalli-2.7.7.tar.gz 51532 BLAKE2B a625e333130f2c9ec47a9e3aec892a8e0d5f7248b71f6c666461104e2b29d4a384dd415b00dbe70d24fdd44a3b6835fdebdeb75297d4cd6d48506d146f892d4e SHA512 ed2a3f0b41451ae703060fe6197675ed6096531b91e5210a2fbded7a40a9a5717d47f5611081a488931318fd89888f00a539c67bab3dc600cea12676cab289cc
46 changes: 46 additions & 0 deletions dev-ruby/dalli/dalli-2.7.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_TASK_TEST="test"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="History.md Performance.md README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="A high performance pure Ruby client for accessing memcached servers"
HOMEPAGE="https://github.com/petergoldstein/dalli"
SRC_URI="https://github.com/petergoldstein/dalli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE=""

DEPEND+="${DEPEND} test? ( >=net-misc/memcached-1.4.0 )"

ruby_add_bdepend "test? (
dev-ruby/minitest:5
>=dev-ruby/mocha-0.13
dev-ruby/rack
>=dev-ruby/activesupport-4.2 <dev-ruby/activesupport-5.2
dev-ruby/connection_pool )"

all_ruby_prepare() {
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"

sed -i -e '/\(appraisal\|bundler\)/ s:^:#:' Rakefile || die

sed -i -e '3igem "minitest", "~> 5.0"; gem "activesupport", "< 5.2"' \
-e '/bundler/ s:^:#:' test/helper.rb || die

# Drop rails dependency which is only used to display the version
# number, so we only need to depend on activesupport and avoid
# complicated circular dependencies.
sed -i -e '/rails/I s:^:#:' \
-e '14irequire "active_support"' test/helper.rb || die
}

0 comments on commit d57bc9b

Please sign in to comment.