Skip to content

Commit

Permalink
app-i18n/uim: new upstream release
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/644898
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
hattya committed May 28, 2018
1 parent 323cb12 commit d61c9a2
Show file tree
Hide file tree
Showing 4 changed files with 293 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-i18n/uim/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST uim-1.8.6.tar.bz2 6500739 BLAKE2B 78623c015cafafa1fbaf32542535de1f0207f8452a422d929a15f4421e4c9926192d0d3b761a7865a38affdf616dc5477e083c0fd8655261ff80ca817fd37029 SHA512 26a95d3b51ef7a99108234b9af30ee7b74141cb3af13d092d4cdbf0749f630934cfd67f74b09dacc3adcdce4a390104489d68a4e2419ec07418645a9b4e5715b
DIST uim-1.8.8.tar.bz2 6228743 BLAKE2B 8fc44b61239f766ba3d9ebf3201c11471b3a844e082237f5ec97dd0fa6fbb04a0a588df5c0479a0aa4bcb4d9c4edcc93c36ec68618701c8aa88fa30732fdce28 SHA512 2257ae48f4f2b79039a5f6be0fc740e218d5609e004dad9a5a1aa5d4066587ee59d0be06bc23c7d567a48901466227fedc4778b480f7184d84b0b3b4dddac9a3
28 changes: 28 additions & 0 deletions app-i18n/uim/files/uim-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,7 @@
AC_PATH_PROGS(SED, sed gsed)
AX_PATH_QMAKE4
AX_PATH_QMAKE5
+PKG_PROG_PKG_CONFIG

AM_MAINTAINER_MODE

@@ -1618,7 +1619,7 @@
fi
AX_LANG_WNOERROR # end AC_LANG_WERROR

- QT_CONFIG_OPTS="debug"
+ QT_CONFIG_OPTS="debug nostrip"
else
CFLAGS="$CFLAGS -DNDEBUG"
CXXFLAGS="$CXXFLAGS -DNDEBUG"
@@ -1629,7 +1630,7 @@
AX_CFLAGS_GCC_OPTION([-Wno-unused-function], [UIM_SCM_CFLAGS])
AX_LANG_WNOERROR # end AC_LANG_WERROR

- QT_CONFIG_OPTS="release"
+ QT_CONFIG_OPTS="release nostrip"
fi

AC_ARG_ENABLE(warnings-into-error,
38 changes: 38 additions & 0 deletions app-i18n/uim/files/uim-tinfo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
--- a/configure.ac
+++ b/configure.ac
@@ -1180,9 +1180,13 @@

if test "x$enable_fep" != xno; then
enable_fep=yes
- AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
- [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
- AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);enable_fep=no)])
+ PKG_CHECK_MODULES(CURSES, ncurses,
+ [FEP_LIBADD="$CURSES_LIBS $FEP_LIBADD"],
+ [
+ AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
+ [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
+ AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);enable_fep=no)])
+ ])
AC_CHECK_FUNCS(forkpty)
if test "x$ac_cv_func_forkpty" = xno; then
AC_CHECK_LIB(util, forkpty,
@@ -1319,10 +1323,14 @@
saved_LDFLAGS=$LDFLAGS
CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
- with_libedit=no)])
+ PKG_CHECK_MODULES(CURSES, ncurses,
+ [LIBEDIT_LIBS="$CURSES_LIBS"],
+ [
+ AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
+ [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
+ AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
+ with_libedit=no)])
+ ])

if test "x$with_libedit" != xno; then
AC_CHECK_LIB(edit, el_init,
226 changes: 226 additions & 0 deletions app-i18n/uim/uim-1.8.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,226 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit autotools elisp-common gnome2-utils

DESCRIPTION="A multilingual input method framework"
HOMEPAGE="https://github.com/uim/uim"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"

LICENSE="BSD GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE="X +anthy canna curl eb emacs expat libffi gtk gtk2 l10n_ja l10n_ko l10n_zh-CN l10n_zh-TW libedit libnotify libressl m17n-lib ncurses nls qt5 skk sqlite ssl static-libs xft"
RESTRICT="test"
REQUIRED_USE="gtk? ( X )
gtk2? ( X )
qt5? ( X )
xft? ( X )"

CDEPEND="!dev-scheme/sigscheme
X? (
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXext
x11-libs/libXft
x11-libs/libXrender
x11-libs/libXt
)
anthy? ( app-i18n/anthy )
canna? ( app-i18n/canna )
curl? ( net-misc/curl )
eb? ( dev-libs/eb )
emacs? ( virtual/emacs )
expat? ( dev-libs/expat )
libffi? ( virtual/libffi )
gtk? ( x11-libs/gtk+:3 )
gtk2? ( x11-libs/gtk+:2 )
libedit? ( dev-libs/libedit )
libnotify? ( x11-libs/libnotify )
m17n-lib? ( dev-libs/m17n-lib )
ncurses? ( sys-libs/ncurses:0= )
nls? ( virtual/libintl )
qt5? ( dev-qt/qtx11extras:5 )
skk? ( app-i18n/skk-jisyo )
sqlite? ( dev-db/sqlite:3 )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)"
DEPEND="${CDEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
X? ( x11-base/xorg-proto )"
RDEPEND="${CDEPEND}
X? (
media-fonts/font-sony-misc
l10n_ja? (
|| (
media-fonts/font-jis-misc
media-fonts/intlfonts
)
)
l10n_ko? (
|| (
media-fonts/font-daewoo-misc
media-fonts/intlfonts
)
)
l10n_zh-CN? (
|| (
media-fonts/font-isas-misc
media-fonts/intlfonts
)
)
l10n_zh-TW? ( media-fonts/intlfonts )
)"

PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
"${FILESDIR}"/${PN}-tinfo.patch
"${FILESDIR}"/${PN}-zh-TW.patch
)
DOCS=( AUTHORS NEWS README RELNOTE doc )

AT_NO_RECURSIVE="yes"
SITEFILE="50${PN}-gentoo.el"

src_prepare() {
default
sed -i "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac

eautoreconf
}

src_configure() {
local myconf=(
$(use_with X x)
$(use_with anthy anthy-utf8)
$(use_with canna)
$(use_with curl)
$(use_with eb)
$(use_enable emacs)
$(use_with emacs lispdir "${SITELISP}")
$(use_with expat)
$(use_with libedit)
$(use_with libffi ffi)
$(use_with gtk gtk3)
$(use_with gtk2)
$(use_with m17n-lib m17nlib)
$(use_enable ncurses fep)
$(use_enable nls)
$(use_with qt5)
$(use_with qt5 qt5-immodule)
$(use_with skk)
$(use_with sqlite sqlite3)
$(use_enable ssl openssl)
$(use_enable static-libs static)
$(use_with xft)
--without-anthy
--enable-default-toolkit=$(usex gtk gtk3 $(usex gtk2 gtk $(usex qt5 qt5)))
--disable-gnome-applet
--disable-gnome3-applet
--disable-kde-applet
--disable-kde4-applet
--without-mana
--without-prime
--disable-qt4-qt3support
)

if (use gtk || use gtk2) && (use anthy || use canna); then
myconf+=( --enable-dict )
else
myconf+=( --disable-dict )
fi

if use libnotify; then
myconf+=( --enable-notify=libnotify )
fi

if use gtk || use gtk2 || use qt5; then
myconf+=( --enable-pref )
else
myconf+=( --disable-pref )
fi

econf "${myconf[@]}"
}

src_compile() {
default

if use emacs; then
cd emacs
elisp-compile *.el || die
fi
}

src_install() {
# bug #222677
emake -j1 DESTDIR="${D}" install
rm -f doc/Makefile*
einstalldocs

find "${ED}"/usr/$(get_libdir)/${PN} -name '*.la' -delete || die
use static-libs || find "${ED}" -name '*.la' -delete || die

insinto /etc/X11/xinit/xinput.d
sed \
-e "s:@EPREFIX@:${EPREFIX}:g" \
"${FILESDIR}"/xinput-${PN} > "${T}"/${PN}.conf
doins "${T}"/${PN}.conf

if use X; then
docinto xim
dodoc xim/README*
fi

if use emacs; then
elisp-install ${PN}-el emacs/*.el{,c}
elisp-site-file-install "${FILESDIR}"/${SITEFILE} ${PN}-el
docinto emacs
dodoc emacs/README*
fi

if use ncurses; then
docinto fep
dodoc fep/README*
fi
}

pkg_postinst() {
elog "New input method switcher has been introduced. You need to set"
elog
elog "% GTK_IM_MODULE=uim ; export GTK_IM_MODULE"
elog "% QT_IM_MODULE=uim ; export QT_IM_MODULE"
elog "% XMODIFIERS=@im=uim ; export XMODIFIERS"
elog
elog "If you would like to use uim-anthy as default input method, put"
elog "(define default-im-name 'anthy)"
elog "to your ~/.uim."
elog
elog "All input methods can be found by running uim-im-switcher-gtk, "
elog "uim-im-switcher-gtk3 or uim-im-switcher-qt5."

if use emacs; then
elisp-site-regen
echo
elog "uim is autoloaded with Emacs with a minimal set of features:"
elog "There is no keybinding defined to call it directly, so please"
elog "create one yourself and choose an input method."
elog "Integration with LEIM is not done with this ebuild, please have"
elog "a look at the documentation how to achieve this."
fi
use gtk && gnome2_query_immodules_gtk3
use gtk2 && gnome2_query_immodules_gtk2
}

pkg_postrm() {
use emacs && elisp-site-regen
use gtk && gnome2_query_immodules_gtk3
use gtk2 && gnome2_query_immodules_gtk2
}

0 comments on commit d61c9a2

Please sign in to comment.