Skip to content

Commit

Permalink
dev-util/artifactory-bin: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Jul 26, 2016
1 parent b8465c4 commit d640f70
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/artifactory-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST artifactory-4.10.0.zip 41178841 SHA256 949499822127506906589f88b887cc712931f95efcbc906584e1163e0976f058 SHA512 72f5665faec48701b96ccfdf46f42512a82874a636b912bec21a1738828fe5d5f6712307380ede07c787a3778064ade13b8d9cbd18442f77454539836d4a7bcd WHIRLPOOL 3afb4070946ddf83664edd98fa3c2288f359bb0f24fd8546750f4641ec4c391a84cdac9df3e383e9d4d8cf7baae48d67c4d0c8aea0a20aeae92273e4b8613d7e
DIST artifactory-4.7.6.zip 40332783 SHA256 8f2ee405e7b13ea2121a0e1c97ef3097ae54e9753d7288cc4ee95d3831cb01dd SHA512 06d102b8a17172a8f6a67e9f166278b59569ba8439c9eea02bc1a7401182f72bc00da8ea3484a30b1c96ab167d331868169edd3051f6e027d772a9c5ede50852 WHIRLPOOL 296dc74c9698058b2fc020ce0561929a7a75dc47ad48cce37be1d4e86e0c4bbddfb7ab108f58ee1175bb0fff113a4a216a11c6ddf01380d3fd8c826607712990
DIST artifactory-4.7.7.zip 40327123 SHA256 953a208daa35767ca915a9bab20310493c9abd78f238f787387c89077d377716 SHA512 2ebda9b45a819c9f060a7d789878f09ffb5e8791f9913ba5f86498ad69a01731fca9efde7c0ed9e206ea35a98d733052146c407208f28a3efc0b25423b11a894 WHIRLPOOL 57e60d9426849f140fdd67bc775c9d9e08c0c78926347dc5bd64cf0c5d0fd1ab759539756e98183e093e6e9b27301d5bb6192ca5c023c71664a49bded23b8a0e
DIST artifactory-4.8.0.zip 41084705 SHA256 2de13962ad1e6f4f1537e1fd86b6e70da6afae67a2449bf0cb369d3a84267647 SHA512 a21310a7699c63a2fe3f305f42fef0aab6a0b9d43b2b8ba89d2360e5f8364d233f6f64616271d6cd4e79c1cecd18b1a7197fbb034a5eabd77d97b257e09b2910 WHIRLPOOL e6a62c25f2927ea069fa512c40f8b7ea4cecb8625acdd8149c1f2db298b7375e362ee616562b37e9a00d5ed5451cb5861bf906d4d5c796eec9735e62b2a46e88
Expand Down
97 changes: 97 additions & 0 deletions dev-util/artifactory-bin/artifactory-bin-4.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Using a binary ebuild until a source ebuild is doable.
# This was previously blocked by two major bugs upstream:
# A lack of documented build instructions - https://www.jfrog.com/jira/browse/RTFACT-8960
# A lack of source releases - https://www.jfrog.com/jira/browse/RTFACT-8961
# Upstream now releases source and instructions (yay!), but most of artifactory's
# dependencies are not in portage yet.

EAPI=6

inherit user

MY_P="${P/-bin}"
MY_PN="${PN/-bin}"
MY_PV="${PV/-bin}"

DESCRIPTION="The world's most advanced repository manager for maven"
HOMEPAGE="http://www.jfrog.org/products.php"
SRC_URI="https://bintray.com/artifact/download/jfrog/artifactory/jfrog-artifactory-oss-${MY_PV}.zip -> ${MY_P}.zip"

LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="ssl"

RDEPEND=">=virtual/jre-1.8"
DEPEND=">=virtual/jdk-1.8
app-arch/unzip"

S="${WORKDIR}/${MY_PN}-oss-${MY_PV}"

pkg_setup() {
enewgroup artifactory
enewuser artifactory -1 /bin/sh -1 artifactory
}

src_prepare() {
default

if use ssl ; then
cp "${FILESDIR}/artifactory.xml" tomcat/conf/Catalina/localhost/artifactory.xml || die
cp "${FILESDIR}/server.xml" tomcat/conf/server.xml || die
fi

# Reverse https://www.jfrog.com/jira/browse/RTFACT-7123
sed -i -e "s%artifactory.repo.global.disabled=true%artifactory.repo.global.disabled=false%g;" \
etc/artifactory.system.properties || die

# See FIXME in src_install(), this can probably go away,
# but catalina.sh may need to be fixed for that:
sed -i -e "s%/etc/opt/jfrog/artifactory/default%/etc/conf.d/${MY_PN}%g;" \
misc/service/setenv.sh || die
}

src_install() {
local ARTIFACTORY_HOME="/opt/artifactory"
local TOMCAT_HOME="${ARTIFACTORY_HOME}/tomcat"

insinto ${ARTIFACTORY_HOME}
doins -r etc logs misc tomcat webapps

dodir /etc/opt/jfrog
dosym ${ARTIFACTORY_HOME}/etc /etc/opt/jfrog/artifactory

dosym ${ARTIFACTORY_HOME}/logs /var/log/artifactory

exeinto ${ARTIFACTORY_HOME}/bin
doexe bin/*

# FIXME: this is called by catalina.sh (it echoes the variables before starting
# artifactory, as well as makes sure log dir, etc. exists). Those directories
# could probably be moved to the ebuild and the script removed from catalina.sh
# without consequence (and quieter starts). Would need to check if CATALINA_*
# variables are actually used anywhere (from reading code don't appear to be
# actually needed)
exeinto ${TOMCAT_HOME}/bin
doexe misc/service/setenv.sh
doexe tomcat/bin/*

keepdir ${ARTIFACTORY_HOME}/backup
keepdir ${ARTIFACTORY_HOME}/data
keepdir ${ARTIFACTORY_HOME}/run
keepdir ${ARTIFACTORY_HOME}/work
keepdir ${TOMCAT_HOME}/logs/catalina
keepdir ${TOMCAT_HOME}/temp
keepdir ${TOMCAT_HOME}/work
keepdir /var/opt/jfrog/artifactory/run

newconfd "${FILESDIR}/confd" ${MY_PN}
newinitd "${FILESDIR}/initd" ${MY_PN}

fowners -R artifactory:artifactory ${ARTIFACTORY_HOME}
fperms -R u+w ${TOMCAT_HOME}/work
}

0 comments on commit d640f70

Please sign in to comment.