Skip to content

Commit

Permalink
dev-ruby/activerecord: add 6.1.4.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Dec 16, 2021
1 parent d48b9f8 commit d671340
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/activerecord/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST rails-6.0.4.3.tgz 18594602 BLAKE2B 99ee38f02ffece7972b34dc4bf8de6aece131fbd
DIST rails-6.0.4.4.tgz 18594292 BLAKE2B 8f463900db30ffd4850b270aac0ae8c160af36a606e4eddaadbd2a0c086de3438a36665586e20a4b6b8873f8b659f2ecd3e32965a36118a6e63fad2726afa0f5 SHA512 14f7d51ba407589eb4ef1db8a99c21c301198e8cb2fcdf611c76eebd1d52192eb1225bb5d45a2183fbfe103a0b987f3a95c6c5fe6d772ba101da9ed46441441f
DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a88c1019d1f7b7ba73785bc11901d7222ac04866b900c7dc35f9291ede78c0949abd979e797d07f3759179c05a SHA512 411d3fe21c7500e884edb86cc6728c4d3b7125d2e6ea913191437716f2be0d522252c55c25cb4c5221cc112b3ca5eeba690b0b0e59572fcc54ea42ba05ec4520
DIST rails-6.1.4.3.tgz 11007190 BLAKE2B 085d500407f03d8c46335d91e3ebc5cd092c801de25f7e4fd5ac4ae6f03e54c5347e720386763307e183e2f0f48aaf84142092f47b62ab395082e4068e46f883 SHA512 f47a2e155fc80c287360b1a17a0f870208c523a28b77737648b4f260dc4fec6e9ccc91861b84862828fda48c214d39dcff32430ed5a02c8b9ee59ba6efb6151c
DIST rails-6.1.4.4.tgz 11006695 BLAKE2B af5afbd1adafa259f3d58d31e8e616be5e83e73d3e7231fd62717c0a8c0012e7ecf5346f2465a61f72d96fdc71755e954069adfebc84dddddcb29cb8a215cee1 SHA512 4215be8f447e5b486a1c0d99208fbeb1f7222aa3bdff7127e31c95670a74aa315a044df0048a55fd078f42a07f17d4b7248efc09d6fac2a4b6efef8624a509ef
83 changes: 83 additions & 0 deletions dev-ruby/activerecord/activerecord-6.1.4.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby26 ruby27"

# this is not null so that the dependencies will actually be filled
RUBY_FAKEGEM_TASK_TEST="test"

RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
HOMEPAGE="https://github.com/rails/rails/"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="mysql postgres sqlite"

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
sqlite? ( >=dev-ruby/sqlite3-1.4 )
mysql? ( dev-ruby/mysql2:0.5 )
postgres? ( >=dev-ruby/pg-1.1:1 )"

ruby_add_bdepend "
test? (
dev-ruby/bundler
~dev-ruby/actionpack-${PV}
>=dev-ruby/sqlite3-1.4.0
dev-ruby/mocha
dev-ruby/minitest:5
)"

DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"

all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
rm ../Gemfile.lock || die
sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
sed -e '/bcrypt/ s/3.0.0/3.0/' \
-i ../Gemfile || die
sed -i -e '/byebug/ s:^:#:' test/cases/base_prevent_writes_test.rb || die

# Add back json in the Gemfile because we dropped some dependencies
# earlier that implicitly required it.
sed -i -e '$agem "json"' ../Gemfile || die

# Avoid single tests using mysql or postgres dependencies.
rm test/cases/invalid_connection_test.rb || die
sed -e '/test_switching_connections_with_database_url/askip "postgres"' \
-i test/cases/connection_adapters/{,legacy_}connection_handlers_multi_db_test.rb || die

# Avoid failing test that makes bad assumptions on database state.
sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
test/cases/associations/has_many_associations_test.rb

# Avoid test failing to bind limit length in favor of security release
sed -i -e '/test_too_many_binds/askip "Fails on Gentoo"' test/cases/bind_parameter_test.rb || die

# Avoid test failing related to rubygems
sed -i -e '/test_generates_absolute_path_with_given_root/askip "rubygems actiovation monitor"' test/cases/tasks/sqlite_rake_test.rb || die
}

each_ruby_test() {
if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
}

0 comments on commit d671340

Please sign in to comment.