Skip to content

Commit

Permalink
dev-ruby/domain_name: add 0.5.20180417
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
graaff committed Apr 20, 2018
1 parent b306e0b commit d69e33b
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/domain_name/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST domain_name-0.5.20170404.gem 120320 BLAKE2B c2dbb97c67e1303c272ff67f2c32314827513a5953ca3b9d49667828f6972904249ab98ee0541a380fddb7c6e3fcc3959f8e5f8746ae6b38a3915169ef6c0dc2 SHA512 3314d87ac3b04337dff047c423ded2f4b99a4b9300528c34388cbc30fbcc7e84ae884969624e046e0dcc1d856e0bb8246b1556ac2dc755a1b4917ccf975fece3
DIST domain_name-0.5.20180417.gem 124928 BLAKE2B 56c8852c09dfabc2291a08d89b4dbb6c9c9c3aecce40fab2a176e2183ebd7b793a6677256f417b0c9cb6cd61680a738038ee2d14e4d15d9ab5a952d666014d27 SHA512 e960aa4445e19ff3e71825d94f85519ec9b1600dab64d139bf21208aec6fe1dc279e9fda6c64fd518ab22783464ba9a4d43f20ceb7699daede981cbf7d5e1876
46 changes: 46 additions & 0 deletions dev-ruby/domain_name/domain_name-0.5.20180417.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

USE_RUBY="ruby21 ruby22 ruby23 ruby24"

RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="Domain Name manipulation library for Ruby"
HOMEPAGE="https://github.com/knu/ruby-domain_name"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="test"

ruby_add_rdepend ">=dev-ruby/unf-0.0.5-r1:0"

ruby_add_bdepend "
test? (
>=dev-ruby/test-unit-2.5.5
dev-ruby/shoulda
)"

all_ruby_prepare() {
sed -i -e '/bundler/,/end/ d; i gem "unf"' test/helper.rb || die
rm Gemfile* || die

# Remove development dependencies
sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rdoc\)/d' \
${RUBY_FAKEGEM_GEMSPEC} || die

# Avoid dependency on git.
sed -i -e 's/`git ls-files`/""/' ${RUBY_FAKEGEM_GEMSPEC} || die
}

each_ruby_test() {
ruby-ng_testrb-2 -Ilib:test test/test_*.rb
}

0 comments on commit d69e33b

Please sign in to comment.