forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/kile: 2.9.91 version bump (3.0 beta1)
Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kile-2.1.3.tar.bz2 4911212 SHA256 a063ec4fca1ba5a063ffdcdb538967af35ade01d71fa7db6ea691ba2cf88cea2 SHA512 820cb5e2579f243ce87409aa4d483a58b0a2cf1d86bff72dd12264570bfe72e7819c88aa4333080f8281e54e8315e2c11f961b41f13a6215913dfa4f7bd3feda WHIRLPOOL 1bc56ad82c72807fcf93ffeb4dbd4222a7660c00e852378a9007c7aa4a96a5130497ca23815a74c92f631fcb261dbf35f7d5453e849f6fb82c9f3c802058ab31 | ||
DIST kile-2.9.91.tar.bz2 3461524 SHA256 08cb54cddc54c851d98b339f386d9aa20b3d71ff98ef078242fd52f684712d93 SHA512 08075adad7d75309148016bbd7f2c4b6f1d5c67808037666deffa49ac26d76cf4329ea39288c23122dabfbb6c83d15bf4f0a2bdaf1479d41064fa63098aba947 WHIRLPOOL 4767669228f59b9b8d88e75d1f33bcb7890556326a82b86ce779407a75f559cb69277800de7fb6fbceaa8c58468ec80774a8a716993d40724fc7100a5db76166 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks" | ||
HOMEPAGE="http://kile.sourceforge.net/" | ||
[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2" | ||
|
||
LICENSE="FDL-1.2 GPL-2" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+pdf +png" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kdoctools) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kinit) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep ktexteditor) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_kdeapps_dep okular) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtscript) | ||
$(add_qt_dep qttest) | ||
$(add_qt_dep qtwidgets) | ||
pdf? ( app-text/poppler[qt5] ) | ||
" | ||
RDEPEND="${DEPEND} | ||
!app-editors/kile:4 | ||
$(add_kdeapps_dep konsole) | ||
$(add_kdeapps_dep okular 'pdf?') | ||
virtual/latex-base | ||
virtual/tex-base | ||
pdf? ( | ||
|| ( | ||
app-text/dvipdfmx | ||
>=app-text/texlive-core-2014 | ||
) | ||
app-text/ghostscript-gpl | ||
) | ||
png? ( | ||
app-text/dvipng | ||
|| ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[imagemagick,png] ) | ||
) | ||
" | ||
|
||
DOCS=( kile-remote-control.txt ) | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
|
||
# I know upstream wants to help us but it doesn't work.. | ||
sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \ | ||
-i CMakeLists.txt || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package pdf Poppler) | ||
) | ||
|
||
kde5_src_configure | ||
} |