Skip to content

Commit

Permalink
dev-libs/bemenu: 0.2.0 bump
Browse files Browse the repository at this point in the history
Fixes: https://bugs.gentoo.org/701126
Package-Manager: Portage-2.3.76, Repoman-2.3.18
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Nov 25, 2019
1 parent 5f0cb9a commit d70dca8
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/bemenu/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST bemenu-0.2.0.tar.gz 119935 BLAKE2B 8f9d1575f6ec31062df0bfe06d16722d4bc61ddcc5dabf0d6e9df8b88536eea638b7ce1e05e3b19a3cad125ecb09edeb72b6ca8d283e73e35d279ba14ebd7975 SHA512 05ddc79b2f4152fe4a3cbbec500f21f0b3e045aeb0e18bd5749acfe16ed41d7d933accf68a4793345cb20543620894847cec34236684d8cb4d42f20454d31b4e
57 changes: 57 additions & 0 deletions dev-libs/bemenu/bemenu-0.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils

DESCRIPTION="dmenu clone for wayland"
HOMEPAGE="https://github.com/Cloudef/bemenu"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Cloudef/bemenu.git"
else
SRC_URI="https://github.com/Cloudef/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="doc ncurses wayland X"

# Require at least one backend be built
REQUIRED_USE="|| ( ncurses wayland X )"

DEPEND="
ncurses? ( sys-libs/ncurses:0 )
wayland? (
dev-libs/wayland
dev-libs/wayland-protocols
x11-libs/cairo
x11-libs/pango
)
X? (
x11-libs/libxcb
x11-libs/libXext
x11-libs/libX11
x11-libs/cairo[X]
x11-libs/pango[X]
)
"
RDEPEND="${DEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"

src_configure() {
local mycmakeargs=(
-DCURSES_LIBRARY=/usr/$(get_libdir)/libncursesw.so
-DBEMENU_CURSES_RENDERER=$(usex ncurses ON OFF)
-DBEMENU_WAYLAND_RENDERER=$(usex wayland ON OFF)
-DBEMENU_X11_RENDERER=$(usex X ON OFF)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
}

0 comments on commit d70dca8

Please sign in to comment.