Skip to content

Commit

Permalink
dev-util/kbuild: Bump to version 0.1.9998.3407
Browse files Browse the repository at this point in the history
Don't depend on virtual/yacc until bug #734354 has been fixed.

Bug: https://bugs.gentoo.org/734354
Package-Manager: Portage-3.0.2, Repoman-2.3.23
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 11, 2020
1 parent 2b9bd7c commit d73a70b
Show file tree
Hide file tree
Showing 4 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/kbuild/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kbuild-0.1.9998.3149-src.tar.xz 2314792 BLAKE2B 84aa1dbbaefc64a3ecc954c383d0516d88efd1a1791180164dd7bc3b26cd82a4a8c35c4b308e9fc960f114c40e77ea4a27acd94b62883c379acefb324a7c3f72 SHA512 74808e6279c01739170535655edbbffb73809f60b18c7ee63a110af7af651628789b9e5d253821f5685f8e8c072890c4669493e64886f53587b810ea0f67826c
DIST kbuild-0.1.9998.3407-src.tar.xz 2351596 BLAKE2B ed562a739831c465ba66b2c357b1ab52cb072e61fa597d96d9e66e1b57a7f790c7e37fc82ef7ff49114b0cb4cb623e558d96864e98ca36bd42fe16e58e863dc7 SHA512 0a1fddff595f7ccfdb65a1a660c82860f132796b42149b8b40808d0df489312dcd96402236150c8ec5ec32c1cc142ce7af1150e10fdb83bf798e4d690dd64314
11 changes: 11 additions & 0 deletions dev-util/kbuild/files/kbuild-0.1.9998.3407-gold.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- kbuild-0.1.9998.3407/src/kmk/Makefile.kmk
+++ kbuild-0.1.9998.3407/src/kmk/Makefile.kmk
@@ -60,7 +60,7 @@
ifneq ($(KBUILD_TARGET),os2)
TEMPLATE_BIN-KMK_INCS += glob
endif
-TEMPLATE_BIN-KMK_LIBS = $(LIB_KUTIL) $(TEMPLATE_BIN-THREADED_LIBS) $(kmkmissing_1_TARGET) $(LIB_KUTIL)
+TEMPLATE_BIN-KMK_LIBS = $(LIB_KUTIL) $(TEMPLATE_BIN-THREADED_LIBS) $(kmkmissing_1_TARGET) $(LIB_KUTIL) pthread
ifdef ELECTRIC_HEAP # for electric heap (see electric.c).
ifeq ($(KBUILD_TARGET),win)
TEMPLATE_BIN-KMK_CFLAGS = $(TEMPLATE_BIN-THREADED_CFLAGS) /FI$(kmk_DEFPATH)/electric.h -DELECTRIC_HEAP=1
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
--- kbuild-0.1.9998.3407/bootstrap.gmk
+++ kbuild-0.1.9998.3407/bootstrap.gmk
@@ -151,7 +151,7 @@
$(OUTDIR)/kmk/ts-configured: \
$(OUTDIR)/kmk/ts-autoreconf \
$(OUTDIR)/kmk/fts.h
- cd $(OUTDIR)/kmk && $(SRCDIR)/src/kmk/configure --disable-load --without-guile
+ cd $(OUTDIR)/kmk && $(SRCDIR)/src/kmk/configure --disable-load
echo done > $@

ifeq ($(KBUILD_HOST),solaris)
@@ -182,7 +182,7 @@
echo done > $@

$(OUTDIR)/sed/ts-configured: $(OUTDIR)/sed/ts-autoreconf
- cd $(OUTDIR)/sed && $(SRCDIR)/src/sed/configure --without-libintl --disable-nls
+ cd $(OUTDIR)/sed && $(SRCDIR)/src/sed/configure --disable-nls
echo done > $@

$(OUTDIR)/sed/config.h: $(OUTDIR)/sed/ts-configured
70 changes: 70 additions & 0 deletions dev-util/kbuild/kbuild-0.1.9998.3407.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools toolchain-funcs

MY_P="${P}-src"
DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
HOMEPAGE="http://svn.netlabs.org/kbuild/wiki"
#SRC_URI="ftp://ftp.netlabs.org/pub/${PN}/${MY_P}.tar.gz"
SRC_URI="https://dev.gentoo.org/~polynomial-c/${MY_P}.tar.xz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

# We cannot depend on virtual/yacc until bug #734354 has been fixed
DEPEND="
sys-apps/texinfo
sys-devel/flex
sys-devel/gettext
|| (
dev-util/byacc
dev-util/yacc
<sys-devel/bison-3.7
)
"
RDEPEND=""

PATCHES=(
"${FILESDIR}/${PN}-0.1.9998.3407-unknown_configure_opt.patch"
"${FILESDIR}/${PN}-0.1.5-gentoo-docdir.patch"
"${FILESDIR}/${PN}-0.1.9998_pre20120806-qa.patch"
"${FILESDIR}/${PN}-0.1.9998_pre20110817-kash-link-pthread.patch"
"${FILESDIR}/${PN}-0.1.9998.3407-gold.patch"
)

pkg_setup() {
# Package fails with distcc (bug #255371)
export DISTCC_DISABLE=1
}

src_prepare() {
default

# Add a file with the svn revision this package was pulled from
printf '%s\n' "KBUILD_SVN_REV := $(ver_cut 4)" \
> SvnInfo.kmk || die

cd "${S}/src/kmk" || die
eautoreconf
cd "${S}/src/sed" || die
eautoreconf

sed -e "s@_LDFLAGS\.$(tc-arch)*.*=@& ${LDFLAGS}@g" \
-i "${S}"/Config.kmk || die #332225
tc-export CC PKG_CONFIG RANLIB #AR does not work here
}

src_compile() {
kBuild/env.sh --full emake -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" \
|| die "bootstrap failed"
}

src_install() {
kBuild/env.sh kmk NIX_INSTALL_DIR=/usr PATH_INS="${D}" install \
|| die "install failed"
}

0 comments on commit d73a70b

Please sign in to comment.