forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-system-monitor: Version bump to 3.38.0
Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
2 changed files
with
53 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-system-monitor-3.36.1.tar.xz 705024 BLAKE2B 93f0bee524797ef76a8c90c9675d12fe4a9bc8c63a48fb86e3212f8be6bcebc26d5098f163b585748ac9832fc38f8591b8fa2509e1a541ed7637aa7c47ce0bca SHA512 52443c0dbcd4fffb7451f540f0e48088a956a4e176af708d198c6ac2054f454dbf910df21925daca484a30d6c1c3526ad634c38ab01f905a08a64b11938c0c2d | ||
DIST gnome-system-monitor-3.38.0.tar.xz 712320 BLAKE2B a59fbe39a8c04793c5584f645dbe0e0bcb9747394c0b923532afc95443aadeeb17ca211248a5c61747699eb95d4f8530fcc18076753bcc6d28cf2ce47a4f6825 SHA512 9f54045fa837b85d40a80bc8b519f91513ae27ca157e07f415860e906444bf144b7a7a66e4a2a9a5b1fea4e69305414cf081bb34624c91d1476265b37b59368c |
52 changes: 52 additions & 0 deletions
52
gnome-extra/gnome-system-monitor/gnome-system-monitor-3.38.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome.org gnome2-utils meson xdg | ||
|
||
DESCRIPTION="The Gnome System Monitor" | ||
HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="systemd X" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86" | ||
|
||
RDEPEND=" | ||
>=dev-cpp/glibmm-2.46:2 | ||
>=dev-libs/glib-2.56.0:2 | ||
>=x11-libs/gtk+-3.22:3[X(+)] | ||
>=dev-cpp/gtkmm-3.3.18:3.0 | ||
>=gnome-base/libgtop-2.37.2:2= | ||
>=gnome-base/librsvg-2.35:2 | ||
>=dev-libs/libxml2-2.0:2 | ||
X? ( >=x11-libs/libwnck-2.91.0:3 ) | ||
systemd? ( >=sys-apps/systemd-44:0= ) | ||
" | ||
# eautoreconf requires gnome-base/gnome-common | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
dev-util/glib-utils | ||
dev-util/itstool | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
>=sys-auth/polkit-0.114 | ||
" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114 | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
$(meson_use X wnck) | ||
$(meson_use systemd) | ||
) | ||
meson_src_configure | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_schemas_update | ||
} |