forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-apps: Version bump KDE Applications 16.04.3
Package-Manager: portage-2.3.0
- Loading branch information
Showing
446 changed files
with
8,097 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST analitza-15.12.3.tar.xz 232928 SHA256 2b69d6692c91e3bf7c8abe053f2dd85f708ae8502a3a0559d67e12f8dd4ee543 SHA512 09b70419d4073027be426efcc9275ae4f7ffd6f431c1e7ae4b9a43bc301fe73dd4eb8d39e72f81e668af152895b282a480f17f2397bc73fdde66275fb097d548 WHIRLPOOL 5374303755461af18440331835bd4c48d544b6d81312a98c20840d5983b1d808cfa8c06fe13db1eb369781ffbfe071b1b957218ba8397bdacfae6599bf3af8c9 | ||
DIST analitza-16.04.2.tar.xz 233680 SHA256 305d8c70cce580c6f0716282667a5201a397ec088cf1043635bad91f27766199 SHA512 ac97113ba10be97df4f014c95b7c6cdbea80e921b1cd5f738ee83b0b6aad7a5b6f9415d44c805c20737ce7ccda84ba30badcb37540cea9f5a235e7e43fe3222b WHIRLPOOL 26000f605b9364b95a058ba5700a78ca5fe15736b23d2d2e877cf0e2f7152a16883d15207215defd321e7e3d4ce7888513555a459dbc8e1bb1b800b25076d056 | ||
DIST analitza-16.04.3.tar.xz 233784 SHA256 b20d944fe54d9b19d87af4c2d9c8529f503346496b7f19619e676101337b6262 SHA512 4c6fda270b0230c20fa215643d444ea775e9354d6002f9bca76329f7e3e2dbe57427e4068c77a9e0acc84a8678b5a4d44db19d5748a74b208c21d62a75c53e8f WHIRLPOOL 08c1a4336ae76eb773f906cfc20fc17310b941b72cd4151b7969c6143667d2435dc2dead488db23f8b79136a9acd20b8b324db1907b9d80506f391de0ac3b32c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_TEST="forceoptional" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="KDE library for mathematical features" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="eigen opengl" | ||
|
||
DEPEND=" | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtsvg) | ||
$(add_qt_dep qtwidgets) | ||
$(add_qt_dep qtxml) | ||
eigen? ( dev-cpp/eigen:3 ) | ||
opengl? ( | ||
$(add_qt_dep qtopengl) | ||
virtual/opengl | ||
) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
# Nothing is installed | ||
sed -i \ | ||
-e "/add_subdirectory(examples)/ s/^/#DONT/" \ | ||
analitzaplot/CMakeLists.txt || die | ||
|
||
if ! use test ; then | ||
sed -i \ | ||
-e "/add_subdirectory(tests)/ s/^/#DONT/" \ | ||
analitza{,gui,plot}/CMakeLists.txt || die | ||
fi | ||
|
||
kde5_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package eigen Eigen3) | ||
$(cmake-utils_use_find_package opengl OpenGL) | ||
) | ||
|
||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ark-15.12.3.tar.xz 253632 SHA256 eecf4372f7bbd2a88dcc478bd70b6aedc6c7bc522e7413d84be1fd33e125f48e SHA512 968278bb500e8b39bbcd4b55e09f95358c680eb20200d6e58e9f0948ef46d36637e66da6939f5c417d3f7b162d04f1a35b83908cca055cdc4b01237522d2b225 WHIRLPOOL dc20d42c7ae369f75d7ebbc98fbdfd6f7d42d87f0260e0faee59d9503919bddc842e1b86c9b15db8e35e4d176d6483e2d3f7eef33e180919a27dabab43de6dc0 | ||
DIST ark-16.04.2.tar.xz 976268 SHA256 0fd62e27f3a810cc9609f62ab29982cecf5ab791d1d4558a1aae63562ce4ae0a SHA512 32e5a48f30bcee92e314179ba0a2790bbee36703f5a4d65d7e68c922b7d24394e2c2c5c9a6f766a783399d035b6aba47a284a59fa1ef678f721f0093319149af WHIRLPOOL 723cea7305f82fc882d24399e5a5021788c549e2c2264d2e260541376e410ef4c53c8e58a5276f4a5cea515047fd6e8e3cf26aa3b14fc1a68c33e1bb5f145fd7 | ||
DIST ark-16.04.3.tar.xz 976200 SHA256 799c2272ddb66439a04ebae5d24fe6113aa67678eb296225b20168a2e0c42b10 SHA512 87d80073cb8f387763bb8a6f5a716ffba455b09fb437531eb435d192d270d9321e7a3c9c9106c3c076586856ecc05a85f08c5984535b8660d11b7259512c09cb WHIRLPOOL dfec7f1219179801e92ba134ec4ca601bd57773cf60118fd12814bbaf8a02363de4d189c8a6e3a60d9eff0fea9302dbcaf2c6c5a07072c2f519a5bfb7aa55f26 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
KDE_TEST="optional" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="KDE Archiving tool" | ||
HOMEPAGE="https://www.kde.org/applications/utilities/ark | ||
https://utils.kde.org/projects/ark" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="bzip2 lzma zlib" | ||
|
||
RDEPEND=" | ||
$(add_frameworks_dep karchive) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kjobwidgets) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep kpty) | ||
$(add_frameworks_dep kservice) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
>=app-arch/libarchive-3.0.0[bzip2?,lzma?,zlib?] | ||
" | ||
DEPEND="${RDEPEND} | ||
sys-devel/gettext | ||
" | ||
|
||
# bug #560548, last checked with 16.04.1 | ||
RESTRICT="test" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package bzip2 BZip2) | ||
$(cmake-utils_use_find_package lzma LibLZMA) | ||
$(cmake-utils_use_find_package zlib ZLIB) | ||
) | ||
|
||
kde5_src_configure | ||
} | ||
|
||
pkg_postinst() { | ||
kde5_pkg_postinst | ||
|
||
if ! has_version app-arch/unar ; then | ||
elog "For handling rar archives, install app-arch/unar" | ||
fi | ||
|
||
if ! has_version app-arch/p7zip ; then | ||
elog "For handling 7-Zip archives, install app-arch/p7zip" | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST artikulate-15.12.3.tar.xz 3743640 SHA256 a12293fd319f51e37fdf716f88e1cf0f907b11454d5431cd531237f9e77db001 SHA512 5e5af44e18a6ad6270af8ed5236df0bd4df39017609c4a5ce9c5e091abe7cc6c11f45bf42e33b712f6665ea1ec264645e0522a89d2404c2f68e622786ead888d WHIRLPOOL 538482e8f4a49d7c2fec4fe7cb56f5e5f88ca1eab715669a2aaf41ab16d4932fae78052b20234cdcb6296a13a1cfcc373d812a0acbb90260ff1e8bc090b8dec4 | ||
DIST artikulate-16.04.2.tar.xz 3752264 SHA256 160759baab4a88c5b6c2197f0eae042e87f75c642427caa10b29cab985323476 SHA512 40577fc6d584a6157ef7ef33754799e300d105694e2ec784066878e36f7bcff39d574f37014e79cdb86d08933786e21c5a6e9befc26d5b95e259b909d4e33eba WHIRLPOOL 2a2044780e7ea2a389a8d6708308baf923ec62d81790cab7fbd761a81ae089cc077e48026dedd7d6699a8b822746e41de9350518c9510ac3ffe11dcc3e2a38d3 | ||
DIST artikulate-16.04.3.tar.xz 3752284 SHA256 d6c38c8d8ed1180a56b9581d6b0df9481396d47899d09d25af7669322eb5cd98 SHA512 57e315890a14b673e3cbb07bb8a9d5038ea54bdcf9dd8e635b3c60f2c157a505d6fef8b607d39189542658f06b10f3c94504a3f4f0099d260a2934745b5b925b WHIRLPOOL 1554593735e780166eef430ce9d98a55edb960a7d3be6077c37f493612cae7d5b5bbf26b500eedf7cf7f0cd0b9bc70406734da2d8a92eec2bf8c0a9de89eb5bd |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="true" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Language learning application that helps improving pronunciation skills" | ||
HOMEPAGE="https://edu.kde.org/applications/language/artikulate" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+gstreamer qtmedia" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep karchive) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtsql) | ||
$(add_qt_dep qtwidgets) | ||
$(add_qt_dep qtxml) | ||
$(add_qt_dep qtxmlpatterns) | ||
gstreamer? ( >=media-libs/qt-gstreamer-1.2.0[qt5] ) | ||
qtmedia? ( $(add_qt_dep qtmultimedia) ) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
REQUIRED_USE="|| ( gstreamer qtmedia )" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_GSTREAMER_PLUGIN=$(usex gstreamer) | ||
-DBUILD_QTMULTIMEDIA_PLUGIN=$(usex qtmedia) | ||
) | ||
|
||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kde-runtime-15.12.3.tar.xz 7903988 SHA256 b261a37a5fbb4e0c589c5304ddbfe16a2b08521670726d64c724cf88e54cf024 SHA512 9ccf0317292c6fb3ee9305531b13915ce16a1c985c9fef79292abddf5c0508ff61ac61b54697417e2073871088aa83772ed8528898c07424ebc68152c307641f WHIRLPOOL 935926262cfe8a79c87569ff10a748fbbf49b9476e64cb418e687846aa1652ad08a6f40810b30801eb7af0704cfd21dfd74e6658cd78814f0e373721bed80566 | ||
DIST kde-runtime-16.04.2.tar.xz 7904184 SHA256 6915a71ddeb2df8e9a46c39482da4ef01be90365cb7886ed1d079cb4403f151c SHA512 be67dbd3b8e90cbab4b56fe2bd9733d952c331fff05d7aab1bb37039e9fe3ebbe5ce72d60c64d5881fe721992ad9b3d14d08d63e13764caade2e9d5f698cc056 WHIRLPOOL 4c44f5564b3c8ddaa7bd542b78f22401795f981b724a63f2b94b21fb6aa374409aeb54b9da53aedba55bf68f8a9026cfc59e12f88fb8381c7e9d3a3961e63a34 | ||
DIST kde-runtime-16.04.3.tar.xz 7903920 SHA256 690e0f848b305b8a2491dbcd01b6e511d64c98d991226cd8a1dc35f23372505d SHA512 df52cd4c423030d3457bb907eb0bef0cdd3c8bce283d9f181b7ae6b7b4ce9c59a34f874f9ac6d2bd59597647a3c6315d772b2551c739423378186d4debbb53ae WHIRLPOOL e4a4a6c3ab315517f757dce952db14e154d4674cf555e1315f018f10cc2a443deede74cf3d370f0c92ab839b35bce8bd360a958cd7edf1ae56720c5ec7d029b5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KMNAME="kde-runtime" | ||
inherit kde4-meta | ||
|
||
DESCRIPTION="Open Collaboration Services provider management" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="debug" | ||
|
||
DEPEND=" | ||
dev-libs/libattica | ||
" | ||
RDEPEND="${DEPEND}" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST audiocd-kio-15.12.3.tar.xz 52060 SHA256 321317c2d8b9b6c77f56a2cd59d595d632eeebbf0865e5e6ebd02d2cafd56a45 SHA512 0a9e80b5b2f544519e37075e4c5d344b473c4830f19c9ac53ced2db6554ebd7b2f4969f8bff4a9792e928a0ed634bb1739167844662887c4d1e95e2b197d2331 WHIRLPOOL 4922ce178df35d4b5a2e68db1439266b76067b41848ae2b8a0e26e7988194780c4c3be4b790bc61f5d287dff2f86a103220986ca58010aad7d3b1fff05e978c1 | ||
DIST audiocd-kio-16.04.2.tar.xz 52072 SHA256 680e30ce3b7f8ac4669001585709741b60fe0b1c163aa3369ad97cf5f1a9f1b8 SHA512 3158ab262ae58a784d8654718c2df5b7dd7ddbcfea396db2d30403f43be05fa1d662150e457d9fd9dd8c913313397d6babdac42d9cc1058f5639c667b69396a7 WHIRLPOOL c1c97991491538c3d18c83b94ebf310360e8bc1fcac72f5e67a65c68184151d4002887a6396ecd2dc176bc378de753c49b7d5358dfb2e184d0bc215f4199477a | ||
DIST audiocd-kio-16.04.3.tar.xz 52064 SHA256 6b03ec356458a80869fc0c2f669c1aee0159bbd2f06e1b454f6e7450873bbac9 SHA512 afc9c184bf4115605eb581aaf2c13a67c22527915552b34bc47e3ffdcd0301d1c4cfff89f88764cbf9a2271d94d03db000903a252c630ed796013880765fa1bc WHIRLPOOL 37f259ed351bc418f975ea0b9f5640b216fdd7be8b3ebda7b5918d3a2e6cdc3944f533f9e76c9123469e8bd30369d1a4faa10c71ce763778c6c108476799792a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="optional" | ||
inherit kde4-base | ||
|
||
DESCRIPTION="KDE kioslaves from the kdemultimedia package" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="debug flac vorbis" | ||
|
||
DEPEND=" | ||
$(add_kdeapps_dep libkcddb) | ||
$(add_kdeapps_dep libkcompactdisc) | ||
media-sound/cdparanoia | ||
flac? ( >=media-libs/flac-1.1.2 ) | ||
vorbis? ( | ||
media-libs/libogg | ||
media-libs/libvorbis | ||
) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_Flac=$(usex flac) | ||
-DWITH_OggVorbis=$(usex vorbis) | ||
) | ||
|
||
kde4-base_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST baloo-widgets-15.12.3.tar.xz 56880 SHA256 2f370fa304410dc109d917153e04b596035aeb486eca1f4fc3bedb272d61dda7 SHA512 9eea66dc1a9d1f2b6c1dad21eb3344fa90dc12361c563209269cd53661e0709832612f34f000cb15f4f0383ec0aa8ed041c3400147512a5c58d71d81fda265f2 WHIRLPOOL 4b75663106b48da96d327bab40f7d54c5b932b570b4452a83b7175c32053bf92f7650badc710edc0e6934d0551aa00770023bde9a291a9e118b869aff349a631 | ||
DIST baloo-widgets-16.04.2.tar.xz 57040 SHA256 da1acdea08e56d8543da2d10f1c69c2fd1aa0957401705f7c44def501822ce41 SHA512 cc3ccd2b6855cb46f79f4159aa7f9b818fc7f9412537a6223fdfdf1a5e57114c15a32eabf24bb72ea995da7086ef23b09e63028b7c668f645bb449a8ea98d004 WHIRLPOOL 7a5b4bf8a2baecb8542346f46fd77d3c44ae7fce291c089f26e29c93353bd02a276c70ae4700722f2f9b4284f73ab43d94fb1d14563f4b7d084e3c653821b3d8 | ||
DIST baloo-widgets-16.04.3.tar.xz 57056 SHA256 f717b88dc1510b530cdb2c1deea18bd22382906542e37d36c37868d6c864d11a SHA512 bae40737702ec24817f8bff8833e5890b3945c7f7303c2cbb416874259142418f12998d5c3815556b4b0086a6063fdfe0b0156832f9d72c6dccf6aa944f0db99 WHIRLPOOL f7c589e4b8ac857f9b452501e4132657e28e769e8f4ced7dfd2b592a746def529f0c0596c9d9a325c9faa36caac5a0c8e9c9942c23a06b8fea2f4a0229f2e5e5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_TEST="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Widget library for baloo" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep baloo) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kfilemetadata) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
" | ||
RDEPEND="${DEPEND} | ||
!kde-base/baloo-widgets | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST blinken-15.12.3.tar.xz 567496 SHA256 a1cb720a21f2c870ad60b2afa1e4f5cdd02db6bfc33e588d83cf1c039f715312 SHA512 28b5d84e265c8ef10a390555f11a39222a73c1d8158ac95bba6411f0ed9d402d13bf93720389d8cef3723efc96a81825f74ac82e88bbb2f9e604f089138c31a2 WHIRLPOOL c3707b7c22e9e59689f0ccdb098de446af552d616cf65a39ab5f5aa1c0f356ee018a896066cf638709f4f562d7c840b5a3e5efca9d18fb30fe3f297cbafd7b38 | ||
DIST blinken-16.04.2.tar.xz 567556 SHA256 4f0f41dfd5f46f168035b6e5cf463fc8253d19e8bb360d89dd0be8ae129adb04 SHA512 651fbb8262a3c514a33db445fcda1dc212c2904ac4616335e6e50c2c0e7b5ade305fafb43b11332f461a080501288424767d263d3fc74f9e1b7efb9c881ee686 WHIRLPOOL b85b4195d25c6d5eaa76a0faae1033ae9c28d4b95320b0cf55458911ec3fe0c953a94b4e1dc19b59a7645a16687dbde74f8fbdfbd57f4233ec5262c277e97be6 | ||
DIST blinken-16.04.3.tar.xz 567612 SHA256 f7739e85bbbb6b8e4c5bbaf4a073a568388fec82c0cff9b61c0d0b0e753e71d9 SHA512 8794d32ba28d262e42129aee309984ee67339f092d36be75c5783579d1dbfd99b74576d2299de7612c4c9d78bf84a0bd250ea4e7383b5cda14ab52726dc5f349 WHIRLPOOL 1361aa5b6ac3ae3c2680c1449f97b2ddc8b8482bfafad4cc566e20f9c583a7c05f81bba7af4cd23e550e3f16232bc66d17ceb264556e4bf44ae3f5a7e23aa9a4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="KDE version of the Simon Says game" | ||
HOMEPAGE="https://www.kde.org/applications/education/blinken | ||
https://edu.kde.org/blinken" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtsvg) | ||
$(add_qt_dep qtwidgets) | ||
media-libs/phonon[qt5] | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_install() { | ||
kde5_src_install | ||
|
||
rm "${ED}"usr/share/${PN}/README.packagers || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST bomber-15.12.3.tar.xz 393960 SHA256 9a47a37610385db3e3d18b4659d5f4c2c2f38f16a14036eca46abfc51adccd0f SHA512 3dafc253657d60b711f368fe35007d64406237d225bc5190b05ce2548bafdeb9c1e7d564350122e18fb4e040e27dbf8b018ee8ea1c3c551dff015776e8fd0cf5 WHIRLPOOL 8ebda528e2d19682629a0f9ecdf24864e5baab56fe7a22c8512a52e0f66ed42fab4ce1861c8a03ea732c9f771532826b7abe5443f24ac883d65c5a4e82f0c570 | ||
DIST bomber-16.04.2.tar.xz 393900 SHA256 c6a54f1f8d2c2898d7c1c043062230433eb0263c6a4af596b3d62b7c9b7ff867 SHA512 388a9c439da0d8bc60c5e1cc7cf80d37915af1454da670904932499a9e817b3f613e3d8ba373b072ad14dce195e7c2983a673159572e7c3b85d4c2e6fbd63851 WHIRLPOOL 71a17973b0a45ab9e0f8470b81617943b6c5172cc8a416a2d5d4e467b16422804aea52d5fbc243a242f3c9c2270f47b62e828db03940346ed404402e4a3cacb3 | ||
DIST bomber-16.04.3.tar.xz 393952 SHA256 7bff65c8d3c81f106c5215e10a878da87f2329ae4512fbc64932a559f56364d1 SHA512 aa979c8c26b5b546805589c09b1c04e83b33199903e50ff555222c0c584ae2a98cc1138b7558081acb091ce4a77d8d968d48d927dbd0fcb1f3f6fae87ec6a39e WHIRLPOOL 394be19f2887357d41ddc5a94af1dcc0cdbdc940087a13923c07ea8a399728e81063d6352aa24691ab446b2138bdf833b6d017508a7e7d728b821407f52ce150 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="KDE arcade bombing game" | ||
HOMEPAGE="https://www.kde.org/applications/games/bomber/" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_kdeapps_dep libkdegames) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
media-libs/phonon[qt5] | ||
" | ||
RDEPEND="${DEPEND}" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST bovo-15.12.3.tar.xz 106192 SHA256 4e89daa151ca8d8aea7093c20f5535bb5b12d5b13495d34bac4f9e41dbebd620 SHA512 357040ff1dba8ba70e1f566b4d89e0d0d757aeb66742d0ecfb06aac2022796b9e81b3399d517a89749be328049692a640d4726749bbd96dae8d92c8b3eda0bd8 WHIRLPOOL 9ad474d898374e9fe001bca236ad5f3d903a83d10824154a811b9b26aa0a724fd7995ff65823065077a07675903daff7645fbc00621773be7730bde516a577a0 | ||
DIST bovo-16.04.2.tar.xz 106264 SHA256 0537418ac0cf2939711d92761f1edc0bd08265338ed283194ac60b6894c53c46 SHA512 3b1090b0c5e593e36fea44be702931c856f1bc513f11dc45dbd254b4eb9b0f9c0df93ba680ee02e3b511aecb70c1a3a977a66407744e4ac792859344029cbb7c WHIRLPOOL 620e7202a70898f9fa3c2bb1bf9d1e628907303330e9e7892403c11c270ded765b60be680864e3ca21cc383566af921fee72778ba2db38da643b287bb73ab02a | ||
DIST bovo-16.04.3.tar.xz 106252 SHA256 5167e9bfbaf450db0c47549072e9ffdab79e1771c5dd114b516ed2fb29f61231 SHA512 70a0005795898474eae51be9014bd8f8ec96b4b02412818249c3e7ec0cbdff3a19bc039371cd2e10bad1d090bae37cc453a81273cb83067915128f447f069ed5 WHIRLPOOL b7f758993e24dd273e5f29962073c4432adb567008987b81cf073659477198346da041f0c752a5a89e37c6d6856b2a94951bb3e4f26b343128f92b3d99251f55 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Five-in-a-row Board Game" | ||
HOMEPAGE="https://www.kde.org/applications/games/bovo/" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_kdeapps_dep libkdegames) | ||
$(add_qt_dep qtconcurrent) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtsvg) | ||
$(add_qt_dep qtwidgets) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
DOCS=( AUTHORS HISTORY TODO ) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST cantor-15.12.3.tar.xz 350924 SHA256 0c67d99038cc7b2f59de6f001337267131e3d420035dd10a05b860859afe423b SHA512 0544574803085fdad61eb2a6896fa7b5b7fc8bd96ebb251f3b3c5efafcb9dc0e30cf8a8719c3bd8e77bcbf140e7798b8cce498ccb92db415e4e816dd19ecd0d8 WHIRLPOOL 62e637230e997bd65c098f9f92245e50c0c67d790d4b6138133188ddbedbc102254701626b9e7828c7ad8dc25602e39c00fd3a42429c580dd5ba9eeffd01aa00 | ||
DIST cantor-16.04.2.tar.xz 350848 SHA256 37d7ea72d52366911a701c22e51262049794c4bd526ea15d7e7d1368e39d5050 SHA512 779f92384a2ce6e7b00275df44ab672dbb8e425f1ec2f0075d0e43a7e41f9366699f5a6919013ae23280da82e4f458f49d0b1444b5c338f76adb2817e7f39764 WHIRLPOOL b8e52c6bcc8d94537da67b3172931288d44882caddac51e0bfdc8de33a50a122fdd1c6d77a41291afe45de036bc0910622d3fbf27d0635ae9ed7add69113ff44 | ||
DIST cantor-16.04.3.tar.xz 351024 SHA256 eae03b97912a193ebe2207f45dcd581ab537ef6c5feb849492fb95dec2aa0cd7 SHA512 01f8cd1ed1209a182ad798dbdaaebf5fd8cf4a29459b8bcb605108cf44382c49757ab94189080ebdca0c9c1de6036f7c9bfd4ba68c2171aff245124cf0074a5c WHIRLPOOL 7ff4ce453762885d4dca27e272e9082f45897a94b1fe11b3c844d27f9a07ae703e867d28ea665a8212218d79a91b37f34c19465b82cb31e9ea8a1f3a7b80448b |
Oops, something went wrong.