forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/android-studio: bump to 2.1.1 and 1.5.2 for security fix
Announcement at: https://plus.sandbox.google.com/103342515830390186255/posts/5TGKhcwtip5 Package-Manager: portage-2.2.28
- Loading branch information
Showing
3 changed files
with
126 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,6 @@ | ||
DIST android-studio-ide-141.1980579-linux.zip 258628239 SHA256 46a1b492360f873f7b99f53b535ce79503f4127a8ee5d06afbe0f53ec5f56a21 SHA512 54a83e6a54cd07ade1bfd3756bdff9c3431594412a01809ac3d2b1b5b2fb1719b8dd4f980516eeba5f7016c7757950c93a1d368ad1034d1300b9fe44577a1bcd WHIRLPOOL 567bcc5ae38015a586224e7c5870d7766f18b4241b46aa53eb7459a7f26d859d9855632cdcf54d3b35bca1b7c39b15cfc1141d11a4d017d9b3e199b72f088b56 | ||
DIST android-studio-ide-141.2456560-linux.zip 380943097 SHA256 466e01ac99c44685f218cf8dfc621fcc6b1d2c18256d97dbefa377d06410d05c SHA512 08644adea21f50a0dacb1f6153fe4fa65be27b3a3b6c202e694177ca53040c6e28cff44a671a55c0b39210d5d8f10be178bab1e406696dd7650000a3b44ea9ef WHIRLPOOL 917231385f121c671f11cf083849301746a5a074d900e555ccd7d115b7f7ebc7ee13efc31e5ce95ece3aa2d20bd7fcc37a96dfb5e3fb1b3bae5c74200925b38c | ||
DIST android-studio-ide-141.2836215-linux.zip 380946919 SHA256 146c23112ceef9c08463b3501573ce674ed1fbac7f00dadaa807daeb93698115 SHA512 7206da5841bc1931f14d10b61bca36f74446952348839a9b033ca9fb28036513d96a2fceb32d4b7d4389a4d91aeeb06676ecd379e7c79cacace7acf4619493a0 WHIRLPOOL 567d97e7f9f68473f34c6094b70b6b277f5de8895ead4f9174cf3f365165e26a6d439928aa5420d1603a92e0c3a2c77d996ea0460d3f25ce42a0e062a622402f | ||
DIST android-studio-ide-143.2739321-linux.zip 292106971 SHA256 f9fe60df5fedc345b8403000b7d73bf53bea5ddf71a38d2a2f01208314246b91 SHA512 8149f91d448b24cf0f30b215f371e371862e620f1ef5785bd2ff6f917d365e2830694861ff804157fb6452ed1a356c4cc968cfad29af6d2ade22a80a0a1ee9b0 WHIRLPOOL 780df70a7192a0230475404320d357cf57e18e081883c17b84cebf3b75204a8e8b10c72a3dabef0335a983b9f83ead6e8595890b7bd48c6b6e1e44e68cb660b0 | ||
DIST android-studio-ide-143.2790544-linux.zip 298122012 SHA256 1f2b1c1d1675d019e27848c2c7d75a2b06452e2a62ee2a109b9e914c66843afb SHA512 22d2253f4e3abb9e708c586d5ca94274c126a732f67116521695a205f86b7ef14274c9ee6c44f2437414dd2bb65249fee698c354f5fb6005051793171cddd640 WHIRLPOOL 3106343eb42548c8d737bf66a1a18f2f03fe2f40ecfd036f840656979a70bc30299aeea0087f0509a6cd790f98a13ade1ee7f58bc65a54c0b3ae4e0fc02edbe7 | ||
DIST android-studio-ide-143.2821654-linux.zip 298125051 SHA256 01843a2428b9a33e59716cc24a10adec238adef81ce6e6e9df441e6fa1ffbdff SHA512 9822e9b1b30f1af9cd06af5628fb7419de35a341f5366647922d91a76083ef50ac4b6059dc77e4598ea92eb517002be51c7c0de42c2bec3d51565318d14077a0 WHIRLPOOL 2e581d3522df511f7f5c68f06380485041fe31b7f867e1fe37f9362ea2ba630f9d1f72dc97e4482b0e1a6de77eabd8689cb87f0aff1be618003f07f4e8e9e14c |
62 changes: 62 additions & 0 deletions
62
dev-util/android-studio/android-studio-1.5.2.0.141.2836215.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit eutils versionator | ||
|
||
RESTRICT="strip" | ||
QA_PREBUILT="opt/${PN}/bin/libbreakgen.so" | ||
if [[ $(get_version_component_count) -eq 6 ]]; then | ||
STUDIO_V=$(get_version_component_range 1-4) | ||
BUILD_V=$(get_version_component_range 5-6) | ||
else | ||
STUDIO_V=$(get_version_component_range 1-3) | ||
BUILD_V=$(get_version_component_range 4-5) | ||
fi | ||
|
||
DESCRIPTION="A new Android development environment based on IntelliJ IDEA" | ||
HOMEPAGE="http://developer.android.com/sdk/installing/studio.html" | ||
SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="selinux" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
DEPEND="app-arch/zip" | ||
RDEPEND=">=virtual/jdk-1.7 | ||
selinux? ( sec-policy/selinux-android ) | ||
>=app-arch/bzip2-1.0.6-r4[abi_x86_32(-)] | ||
>=dev-libs/expat-2.1.0-r3[abi_x86_32(-)] | ||
>=dev-libs/libffi-3.0.13-r1[abi_x86_32(-)] | ||
>=media-libs/fontconfig-2.10.92[abi_x86_32(-)] | ||
>=media-libs/freetype-2.5.5[abi_x86_32(-)] | ||
>=media-libs/libpng-1.2.51[abi_x86_32(-)] | ||
>=media-libs/mesa-10.2.8[abi_x86_32(-)] | ||
|| ( >=sys-libs/ncurses-5.9-r3:5/5[abi_x86_32(-)] >=sys-libs/ncurses-5.9-r3:0/5[abi_x86_32(-)] ) | ||
>=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)] | ||
>=x11-libs/libX11-1.6.2[abi_x86_32(-)] | ||
>=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)] | ||
>=x11-libs/libXdamage-1.1.4-r1[abi_x86_32(-)] | ||
>=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)] | ||
>=x11-libs/libXext-1.3.2[abi_x86_32(-)] | ||
>=x11-libs/libXfixes-5.0.1[abi_x86_32(-)] | ||
>=x11-libs/libXrender-0.9.8[abi_x86_32(-)] | ||
>=x11-libs/libXxf86vm-1.1.3[abi_x86_32(-)] | ||
>=x11-libs/libdrm-2.4.46[abi_x86_32(-)] | ||
>=x11-libs/libxcb-1.9.1[abi_x86_32(-)] | ||
>=x11-libs/libxshmfence-1.1[abi_x86_32(-)]" | ||
S=${WORKDIR}/${PN} | ||
|
||
src_install() { | ||
local dir="/opt/${PN}" | ||
|
||
insinto "${dir}" | ||
doins -r * | ||
fperms 755 "${dir}/bin/studio.sh" "${dir}/bin/fsnotifier" "${dir}/bin/fsnotifier64" | ||
|
||
newicon "bin/studio.png" "${PN}.png" | ||
make_wrapper ${PN} ${dir}/bin/studio.sh | ||
make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" | ||
} |
62 changes: 62 additions & 0 deletions
62
dev-util/android-studio/android-studio-2.1.1.0.143.2821654.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit eutils versionator | ||
|
||
RESTRICT="strip" | ||
QA_PREBUILT="opt/${PN}/bin/libbreakgen.so" | ||
if [[ $(get_version_component_count) -eq 6 ]]; then | ||
STUDIO_V=$(get_version_component_range 1-4) | ||
BUILD_V=$(get_version_component_range 5-6) | ||
else | ||
STUDIO_V=$(get_version_component_range 1-3) | ||
BUILD_V=$(get_version_component_range 4-5) | ||
fi | ||
|
||
DESCRIPTION="A new Android development environment based on IntelliJ IDEA" | ||
HOMEPAGE="http://developer.android.com/sdk/installing/studio.html" | ||
SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="selinux" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
DEPEND="app-arch/zip" | ||
RDEPEND=">=virtual/jdk-1.7 | ||
selinux? ( sec-policy/selinux-android ) | ||
>=app-arch/bzip2-1.0.6-r4[abi_x86_32(-)] | ||
>=dev-libs/expat-2.1.0-r3[abi_x86_32(-)] | ||
>=dev-libs/libffi-3.0.13-r1[abi_x86_32(-)] | ||
>=media-libs/fontconfig-2.10.92[abi_x86_32(-)] | ||
>=media-libs/freetype-2.5.5[abi_x86_32(-)] | ||
>=media-libs/libpng-1.2.51[abi_x86_32(-)] | ||
>=media-libs/mesa-10.2.8[abi_x86_32(-)] | ||
|| ( >=sys-libs/ncurses-5.9-r3:5/5[abi_x86_32(-)] >=sys-libs/ncurses-5.9-r3:0/5[abi_x86_32(-)] ) | ||
>=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)] | ||
>=x11-libs/libX11-1.6.2[abi_x86_32(-)] | ||
>=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)] | ||
>=x11-libs/libXdamage-1.1.4-r1[abi_x86_32(-)] | ||
>=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)] | ||
>=x11-libs/libXext-1.3.2[abi_x86_32(-)] | ||
>=x11-libs/libXfixes-5.0.1[abi_x86_32(-)] | ||
>=x11-libs/libXrender-0.9.8[abi_x86_32(-)] | ||
>=x11-libs/libXxf86vm-1.1.3[abi_x86_32(-)] | ||
>=x11-libs/libdrm-2.4.46[abi_x86_32(-)] | ||
>=x11-libs/libxcb-1.9.1[abi_x86_32(-)] | ||
>=x11-libs/libxshmfence-1.1[abi_x86_32(-)]" | ||
S=${WORKDIR}/${PN} | ||
|
||
src_install() { | ||
local dir="/opt/${PN}" | ||
|
||
insinto "${dir}" | ||
doins -r * | ||
fperms 755 "${dir}/bin/studio.sh" "${dir}/bin/fsnotifier" "${dir}/bin/fsnotifier64" | ||
|
||
newicon "bin/studio.png" "${PN}.png" | ||
make_wrapper ${PN} ${dir}/bin/studio.sh | ||
make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" | ||
} |