Skip to content

Commit

Permalink
dev-ruby/factory_girl: add 4.8.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
graaff committed Dec 19, 2016
1 parent d20ac3b commit d782b8e
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/factory_girl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST factory_girl-4.7.0.tar.gz 64403 SHA256 8218e063479aa2dd64b0868d4f3afa0ba9c079b3d4c279de6ca07f9c78bb3c18 SHA512 0ac67c03880697933f46c9f2abe18e5335c536a89c400248fd61d41049c9eb8697c1f1bec004103d330e9b7427a9e436c34500489bf2128e5d11377361ffe172 WHIRLPOOL f686ab69e6f638f31edb9ec944027d7505a7411b7aad982cd21bff7bd93e5d793cd361869376be3ba80bb1b18d0d3c3fba7a9aacf34238ca0eaa32594bc37718
DIST factory_girl-4.8.0.tar.gz 66025 SHA256 81149a7466ead3f3ecd5e9a4cecd19ca20646901669b2892a62413f54a24036b SHA512 c1e89b25c0dc3292b647179c3cfb487ae235d8049f936beb926c3799e0348ee66e4e6a5d3904fd1a11660477f4c2c993e5d2640a8f54f7cfc5779027d76cca61 WHIRLPOOL 075e04007a9e98c62ca09c4798cfd3dc3e1ebe7025d5b2ae1a2510f9d1a2d34ae9f9fbd56730c09757461d5c546f36517fb914c6c375bebb494409c8db268a4b
50 changes: 50 additions & 0 deletions dev-ruby/factory_girl/factory_girl-4.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_DOC="yard"

# Tests depend on unpackaged appraisal, for now we just run the specs
# with the version of Rails that is installed.
RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRADOC="GETTING_STARTED.md NEWS README.md"

RUBY_FAKEGEM_EXTRAINSTALL="features"

inherit ruby-fakegem

DESCRIPTION="factory_girl provides a framework and DSL for defining and using factories"
HOMEPAGE="https://github.com/thoughtbot/factory_girl"
SRC_URI="https://github.com/thoughtbot/factory_girl/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm"
IUSE=""

ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"

ruby_add_bdepend "
test? (
>=dev-ruby/activerecord-3.1[sqlite]
dev-ruby/bourne
>=dev-ruby/mocha-0.12.8
dev-ruby/rspec-its
dev-ruby/timecop
)
"

all_ruby_prepare() {
# Avoid unneeded test dependencies
sed -i -e '/simplecov/ s:^:#:' \
-e '1irequire "fileutils"' spec/spec_helper.rb || die

# Avoid specs that may fail due to more strict rspec 2.99
# interpretation.
sed -i -e '/callbacks using syntax methods without referencing FactoryGirl explicitly/,/^end/ s:^:#:' spec/acceptance/callbacks_spec.rb || die
}

0 comments on commit d782b8e

Please sign in to comment.