Skip to content

Commit

Permalink
games-arcade/asteroid: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 15, 2018
1 parent 7204eac commit d7a7cf3
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-arcade/asteroid/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST 1.2.1.tar.gz 307596 BLAKE2B c3f5363a0939cc4644425adfa9c3f2ca47ec04ae1beb9dd381fba912ee5e9d3330727fa82d4749b4f6402254988feaaaaef10f7f72aeea691656a1dd188ad5e2 SHA512 a88e0b85264d72bd40add0f3fc8b2b727b1acc0c190de6a60d4e1c79adcc484b17d0ed3537309b704667a6617f387219144cbec93df4fbff585d1237a9823b37
DIST asteroid-1.1.tar.bz2 386177 BLAKE2B c06470f16df0a534a3418b2f5730479f5f1a9ef7b05bbf91539d31b1eaf8ec578f81f6fc0c45a6372bf9fc873065e58c87d53413b09d2faa970e967a8543c442 SHA512 f3acae27a7c3296b6b9e9fc9aabf8c101cd020bfbf2065d2b4f5fabf14f7555c70b2e4543c2c661f0e4410b8128936eb1e0db930d7376c3a3bb3a898ce4ed4e4
26 changes: 26 additions & 0 deletions games-arcade/asteroid/asteroid-1.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit cmake-utils

DESCRIPTION="A modern version of the arcade classic that uses OpenGL"
HOMEPAGE="https://chazomaticus.github.io/asteroid/"
SRC_URI="https://github.com/chazomaticus/${PN}/archive/${PV}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE=""

RDEPEND="
virtual/opengl
media-libs/freeglut
virtual/glu
media-libs/libsdl
media-libs/sdl-mixer
x11-libs/gtk+:2
"
DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}"/${P}-libm.patch )
24 changes: 24 additions & 0 deletions games-arcade/asteroid/files/asteroid-1.2.1-libm.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From 4efc7fc0a1246f023d6f96b94081678e302ab430 Mon Sep 17 00:00:00 2001
From: Charles Lindsay <[email protected]>
Date: Mon, 23 May 2016 18:50:34 -0700
Subject: [PATCH] Add libm to link command

Without it, some systems (and now mine!) would give a linker error about
missing libm.
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29fd714..ab9a7ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,7 @@ include_directories("${PROJECT_BINARY_DIR}/include")
file(GLOB asteroid_SRCS "src/*.c")
add_executable(asteroid ${asteroid_SRCS})
include_directories(${OPENGL_INCLUDE_DIR} ${GLUT_INCLUDE_DIR})
-target_link_libraries(asteroid ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES})
+target_link_libraries(asteroid m ${OPENGL_LIBRARIES} ${GLUT_LIBRARIES})
if(Asteroid_BUILD_GTK)
include_directories(${GTK2_INCLUDE_DIRS})
target_link_libraries(asteroid ${GTK2_LIBRARIES})

0 comments on commit d7a7cf3

Please sign in to comment.