forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/gnote: version bump 3.24.0 → 3.24.1
Fix a typo in help. Fix a crash in notebook delete. Package-Manager: Portage-2.3.8, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
72 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gnote-3.22.1.tar.xz 3309984 SHA256 fa9434c2ba11bea73bd63436e5fd76949aca4f66dfd902295629c66ef27cd5eb SHA512 0bbf89b39699294fe5a373decf10bcd7f3a86a20c49b9d82699fb758c7cd27b6939764236a1a7ffe21964a2ae196780d0861123776b1568344935e0b649e2f5f WHIRLPOOL b36307a24800078843a1cf6217aa7f2a88f2c2f2cc6707ac0b93a7c735e8e820b3ed3f07132647cb47273286771006150a4fe05c425f63554e4da0dee0d100ae | ||
DIST gnote-3.24.0.tar.xz 3307940 SHA256 62e38c19ce7dfcd895729adabd72f654f31e03f28dbf4cbca68279e745c79cd4 SHA512 640f24d1829a546e53eb2d269f965daafa651e141566fd2f7a4572245b309c06259f548fa38c86c55954f2d0f8f98c48b7da2ed982864ae6ffbcac4b5d64aecb WHIRLPOOL b866cde708f9950fe4b4a9af4e97bcc06336e61cfcbf649162323162daf7ef7a1c536ffec9460dc580d54e3cc3a03606967a6ff5aad79b5b847e20c4234ab707 | ||
DIST gnote-3.24.1.tar.xz 3310012 SHA256 1da5887c6d4221de292bd9fd310525bd05d60b9483bb1596e0cfb41f39995a7f SHA512 759fb2984312a3e3d5aed9b79f2309021b69df57b820d34814a5d3d9b5c9201abc6e50d83bf64f30974991d779b0b85e599435a24ee1326b867a2a4be8e0f37e WHIRLPOOL a9fba05fce773cd83f4615475f52137f4b82d4622c95a5500838e580dfc5b6d9b58f548206f71e260b955fe66a6f1a74d016e811af3a67dd0ca052b6230ef5e2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit gnome2 readme.gentoo-r1 | ||
|
||
DESCRIPTION="Desktop note-taking application" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Gnote" | ||
|
||
LICENSE="GPL-3+ FDL-1.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug" | ||
|
||
# Automagic: | ||
# glib-2.32 dep | ||
# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc) | ||
COMMON_DEPEND=" | ||
>=app-crypt/libsecret-0.8 | ||
>=app-text/gtkspell-3.0:3 | ||
>=dev-cpp/glibmm-2.32:2 | ||
>=dev-cpp/gtkmm-3.18:3.0 | ||
>=dev-libs/glib-2.32:2[dbus] | ||
>=dev-libs/libxml2-2:2 | ||
dev-libs/libxslt | ||
>=sys-apps/util-linux-2.16:= | ||
>=x11-libs/gtk+-3.20:3 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
gnome-base/gsettings-desktop-schemas | ||
" | ||
DEPEND="${DEPEND} | ||
app-text/docbook-xml-dtd:4.1.2 | ||
>=dev-util/intltool-0.35.0 | ||
dev-util/itstool | ||
virtual/pkgconfig | ||
" | ||
|
||
src_prepare() { | ||
# Do not alter CFLAGS | ||
sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die | ||
|
||
gnome2_src_prepare | ||
|
||
if has_version net-fs/wdfs; then | ||
DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to | ||
synchronize notes." | ||
else | ||
DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes. | ||
If you want to use that functionality just emerge net-fs/wdfs. | ||
Gnote will automatically detect that you did and let you use it." | ||
fi | ||
} | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
--disable-static \ | ||
$(use_enable debug) | ||
} | ||
|
||
src_install() { | ||
gnome2_src_install | ||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
readme.gentoo_print_elog | ||
} |