Skip to content

Commit

Permalink
sys-fs/squashfs-tools-ng: Version bump to 1.1.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed May 9, 2021
1 parent 6c73252 commit d829527
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/squashfs-tools-ng/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST squashfs-tools-ng-1.1.0.tar.xz 1169556 BLAKE2B 87222e87176a69aef39130af9e6d9b23d9e2f81e10680eb26236260ebe50dedcfbba33785d739a98a152825e535d0d166f7ce08262157341a6ef48d1d2ef33e0 SHA512 06b76fb8bb4295ac451bc98cbe757b272ac831c2ec146803b4813b9792486372691864fcaaa1a3cac6628608ac62cf081f1aa331c0802ea1a9858461fef33923
DIST squashfs-tools-ng-1.1.1.tar.xz 1170232 BLAKE2B 8224b59f70c3c02df3762024510c75a038f8d9f1853575ccfa527173a528f17bd68ae4ec1d2448563aa504f683f5d9152cb07545db6b965f36a224dc95841f17 SHA512 2a7aa689b49fe06ec77e9b9c3bdcf264d05a478aa08543d8e8bc22ef45f10f351b49706485ed93cbd5adc537cd066f94e70952867838ec51859e8f6ce34607f4
51 changes: 51 additions & 0 deletions sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="A new set of tools for working with SquashFS images"
HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi

LICENSE="LGPL-3+ tools? ( GPL-3+ )"
SLOT="0"
IUSE="lz4 lzo selinux +tools +xz zstd"

DEPEND="
sys-libs/zlib:=
lz4? ( app-arch/lz4:= )
lzo? ( dev-libs/lzo:= )
xz? ( app-arch/xz-utils:= )
selinux? ( sys-libs/libselinux:= )
zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
local myconf=(
--disable-static
$(use_with lz4)
$(use_with lzo)
$(use_with selinux)
$(use_with tools)
$(use_with xz)
$(use_with zstd)
)
econf "${myconf[@]}"
}

src_install() {
default
find "${D}" -name "*.la" -delete || die
}

0 comments on commit d829527

Please sign in to comment.