Skip to content

Commit

Permalink
app-doc/doxygen: version bump to 1.8.13
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.0, Repoman-2.3.1
  • Loading branch information
tamiko committed Jan 17, 2017
1 parent a3b422b commit d837e06
Show file tree
Hide file tree
Showing 2 changed files with 152 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/doxygen/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST doxygen-1.8.10.src.tar.gz 4818276 SHA256 cedf78f6d213226464784ecb999b54515c97eab8a2f9b82514292f837cf88b93 SHA512 a7f29b5f7b9f55b7e5382b7b7dc7212247a27869bc265433c0ee51480645b3f5f0732d1f5aefd54952204c8a1c98b96ec1ecc22c1ff7a072db5b2356b5981074 WHIRLPOOL 5607e1da5cf8e653ec895a7601a3a6585790a555207928bde6d154ab06173c68e088a61c1963da8d8cdc1a571b66eeaa102acc2a2e4291e0be87634d8e554962
DIST doxygen-1.8.11.src.tar.gz 4834291 SHA256 65d08b46e48bd97186aef562dc366681045b119e00f83c5b61d05d37ea154049 SHA512 44f3f9d2715c4cfe628b988809a6264681c43634dfa830f604b6cc853fa6679eca112cc9c01cee5b019f7f01f0a0acdf4f7d3aaec0848783399d17904caf1a3e WHIRLPOOL 240c84bd02ea3ab747e59bb8db434e40e743ed24cbb8ca78b8846d3bb4f7672497106fd620c14851c06d80e474301811978def5d85db5b01df97b40a4ec74813
DIST doxygen-1.8.12.src.tar.gz 4880613 SHA256 792d4091cbdf228549ff2033dd71ff7ea5029c6b436317cc5ec866e71302df6c SHA512 12fb5f19d0de382c7510b7c517d7c781a1e6e11720c7d9ecfd81d29d5ed030984e8d55ffcc25cc52703020e880edad341136e2795a2a36a842fc275b31ae203d WHIRLPOOL 4bd12f16ce9dba73f5bf836032d8ce25d5be7e6b3cbe3c11ce7c662a8059fa30ef2f75c008fb2050fd4eb99d80ba134d068b452dfd577a651291dba5315c0726
DIST doxygen-1.8.13.src.tar.gz 4893912 SHA256 af667887bd7a87dc0dbf9ac8d86c96b552dfb8ca9c790ed1cbffaa6131573f6b SHA512 85da5bd28ad9f33a8e50fa92796817d31e59c024127cb647cb967e4321dd51378feaacdf099d578b7e6020fd646a3c63e99c77420e49e3894fc18ca89ba3e0a2 WHIRLPOOL fb26f85c22ae2197b52bb7fb4a46ee840c3af700bedfce41d3fed84e5ac62408abcfc3e2a147a8e15c290f7bbc2e4cf3efabbe490ea1a78504680b9b299fa93f
DIST doxywizard.png 4231 SHA256 eb648ebd3a194a56d9ed6e47cc8dbf1af2e124d83c2c42af9bf86bd837984209 SHA512 5e2d26e7427b86866ebe75ec2c66c0f1100d230f3f3e4d66bac424a8dd0d42f0831d936ff03318dfa1bf73cbd9fb53717636d0c91ae3eea0f4e24641479d25d5 WHIRLPOOL bb0c13b382c4069ca310ff53a03b36499a2bf6e0e8c0647efc032530f429f483b5d6f2925b7e996d4f84c8f2b77eb883533f4b7abc88745a2cfa596d3dd4f3fb
151 changes: 151 additions & 0 deletions app-doc/doxygen/doxygen-1.8.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,151 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit cmake-utils eutils fdo-mime flag-o-matic python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/doxygen/doxygen.git"
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi
SRC_URI+=" https://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"

DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="http://www.doxygen.org/"

LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"

RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
virtual/libiconv
clang? ( sys-devel/clang )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( =dev-libs/xapian-1.2* )
latex? ( app-text/texlive[extra] )
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)
sqlite? ( dev-db/sqlite:3 )
"

REQUIRED_USE="doc? ( latex )"

DEPEND="sys-devel/flex
sys-devel/bison
doc? ( ${PYTHON_DEPS} )
${RDEPEND}"

# src_test() defaults to make -C testing but there is no such directory (bug #504448)
RESTRICT="test"

PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch"
)

DOCS=( LANGUAGE.HOWTO README.md )

pkg_setup() {
use doc && python-any-r1_pkg_setup
}

src_prepare() {
default

# Ensure we link to -liconv
if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
local pro
for pro in */*.pro.in */*/*.pro.in; do
echo "unix:LIBS += -liconv" >> "${pro}" || die
done
fi

# Call dot with -Teps instead of -Tps for EPS generation - bug #282150
sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die

# fix pdf doc
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die

if is-flagq "-O3" ; then
echo
ewarn "Compiling with -O3 is known to produce incorrectly"
ewarn "optimized code which breaks doxygen."
echo
elog "Continuing with -O2 instead ..."
echo
replace-flags "-O3" "-O2"
fi
}

src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="share/doc/${P}"
-Duse_libclang=$(usex clang)
-Dbuild_doc=$(usex doc)
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile

if use doc; then
export VARTEXFONTS="${T}/fonts" # bug #564944

if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
|| die "disabling dot failed"
fi
emake -C "${BUILD_DIR}" docs
fi
}

src_install() {
cmake-utils_src_install

if use qt5; then
doicon "${DISTDIR}/doxywizard.png"
make_desktop_entry doxywizard "DoxyWizard ${PV}" \
"/usr/share/pixmaps/doxywizard.png" \
"Development"
fi
}

pkg_postinst() {
fdo-mime_desktop_database_update

elog
elog "For examples and other goodies, see the source tarball. For some"
elog "example output, run doxygen on the doxygen source using the"
elog "Doxyfile provided in the top-level source dir."
elog
elog "Disabling the dot USE flag will remove the GraphViz dependency,"
elog "along with Doxygen's ability to generate diagrams in the docs."
elog "See the Doxygen homepage for additional helper tools to parse"
elog "more languages."
elog
}

pkg_postrm() {
fdo-mime_desktop_database_update
}

0 comments on commit d837e06

Please sign in to comment.