Skip to content

Commit

Permalink
dev-php/pecl-apcu_bc: Revbump adding php7-3, drop php7-0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Jan 16, 2019
1 parent ea2197a commit d86bca3
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_INI_NAME="bc_apc"
PHP_EXT_NAME="apc"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_EXT_EXTRA_ECONF=""
DOCS=( README.md )

USE_PHP="php7-1 php7-2 php7-3"

inherit php-ext-pecl-r3 multilib

KEYWORDS="~amd64 ~x86"

DESCRIPTION="Provides APC backwards compatibility functions via APCu"
LICENSE="PHP-3.01"
SLOT="0"
IUSE=""

DEPEND="dev-php/pecl-apcu:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]"
RDEPEND="${DEPEND}"

src_test() {
# This fixed version is necessary to have apcu load
# from the install before the tested apc.
# It is intentional to specify phpoptions twice.
# This mimics the Makefile.
local slot phpoptions
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
ln -s "${EXT_DIR}/apcu$(get_libname)" \
"modules/" || die
phpoptions=( -n -d extension_dir="${PHP_EXT_S}/modules"
-d extension=apcu$(get_libname)
-d extension=apc$(get_libname) )
NO_INTERACTION="yes" TEST_PHP_EXECUTABLE="${PHPCLI}" \
"${PHPCLI}" "${phpoptions[@]}" \
run-tests.php "${phpoptions[@]}" || die
done
}

0 comments on commit d86bca3

Please sign in to comment.