Skip to content

Commit

Permalink
app-office/texmaker: Remove qt4 support
Browse files Browse the repository at this point in the history
Dropping ppc keywords to satisfy dependencies

Gentoo-Bug: 620686

Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
krifisk committed Jun 4, 2017
1 parent 5d1a9d1 commit d8b906c
Showing 1 changed file with 84 additions and 0 deletions.
84 changes: 84 additions & 0 deletions app-office/texmaker/texmaker-4.5-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils qmake-utils readme.gentoo

DESCRIPTION="A nice LaTeX-IDE"
HOMEPAGE="http://www.xm1math.net/texmaker/"
SRC_URI="http://www.xm1math.net/texmaker/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""

COMMON_DEPEND="
app-text/hunspell
sys-libs/zlib
x11-libs/libX11
x11-libs/libXext
app-text/poppler:=[qt5]
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtscript:5
dev-qt/qtsingleapplication[X,qt5]
dev-qt/qtwebkit:5[printsupport]
dev-qt/qtwidgets:5
dev-qt/qtxml:5
"
RDEPEND="${COMMON_DEPEND}
app-text/ghostscript-gpl
app-text/psutils
media-libs/netpbm
virtual/latex-base"

DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${P}-unbundle.patch
"${FILESDIR}"/${P}-modern-styles.patch
)

DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
HTML_DOCS=( doc/. )

src_prepare() {
find singleapp hunspell -delete || die

epatch "${PATCHES[@]}"

cat >> ${PN}.pro <<- EOF
exists(texmakerx_my.pri):include(texmakerx_my.pri)
EOF

cp "${FILESDIR}"/texmakerx_my.pri . || die

sed \
-e '/^#include/s:hunspell/::g' \
-e '/^#include/s:singleapp/::g' \
-i *.cpp *.h || die

DOC_CONTENTS="A user manual with many screenshots is available at:
${EPREFIX}/usr/share/${PN}/usermanual_en.html"
}

src_configure() {
local myeqmakeargs=(
${PN}.pro
PREFIX="${EPREFIX}/usr"
DESKTOPDIR="${EPREFIX}/usr/share/applications"
ICONDIR="${EPREFIX}/usr/share/pixmaps"
)
eqmake5 ${myeqmakeargs[@]}
}

src_install() {
emake INSTALL_ROOT="${D}" install
einstalldocs
readme.gentoo_create_doc
}

0 comments on commit d8b906c

Please sign in to comment.