Skip to content

Commit

Permalink
dev-qt/qtscript: 5.15.3 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 21, 2022
1 parent 5457758 commit d8ee397
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtscript/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qtscript-everywhere-opensource-src-5.15.3.tar.xz 2663512 BLAKE2B 742c35cb037378d3379e0311daea5d051f448832e470a7d1a7ede9e3e685472804c84d2432e7974030d7469023f5f8e7868bb2e24a854d4f41929c2fabddc9b3 SHA512 ce35799a5625226fd62b394ecdc9d6826ef386a4b2d1a085a3def927ff3cf4808542a7e06be313baf12838fa0d2c1dbe6496a4e34818e3d035734305e60c24d9
DIST qtscript-everywhere-src-5.15.2.tar.xz 2663016 BLAKE2B f3cf09396fbcd9c386de9628042d2b70263343fec3e1fa49e53e705f56802a244373a37e5daafe6d90252ad67a8b1d3e0446aa4520ff8ff4a8bd010951a5d86e SHA512 71c70b34f7d4a0742df64d20d7e9a685cc640b9cc6a3d22847c04f45a437b3f5537f40225a522ed82787c2744d9a4949dea5b43c2ee81961d5ed175cf10deb32
37 changes: 37 additions & 0 deletions dev-qt/qtscript/qtscript-5.15.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit qt5-build

DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi

IUSE="+jit scripttools"

DEPEND="
=dev-qt/qtcore-${QT5_PV}*
scripttools? (
=dev-qt/qtgui-${QT5_PV}*
=dev-qt/qtwidgets-${QT5_PV}*
)
"
RDEPEND="${DEPEND}"

src_prepare() {
qt_use_disable_mod scripttools widgets \
src/src.pro

qt5-build_src_prepare
}

src_configure() {
local myqmakeargs=(
JAVASCRIPTCORE_JIT=$(usex jit)
)
qt5-build_src_configure
}

0 comments on commit d8ee397

Please sign in to comment.