Skip to content

Commit

Permalink
app-crypt/hashcat: bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
ZeroChaos- committed Dec 7, 2017
1 parent 24cd72c commit d8f8f5b
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 1 deletion.
3 changes: 2 additions & 1 deletion app-crypt/hashcat/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST hashcat-3.5.0.tar.gz 4103461 SHA256 af764698f48145ac96cf01c65cf76bcb88e205aeb4614025ae32d847571c4390 SHA512 7efc860461894a550fbacc406a40fec400232a120818180abba3d53f26bd3a503f58e7d189e4afad0f871c2244ff68371b145af58ab097478fe2d73f39c9a6b3 WHIRLPOOL 927ac7bfe902fcc9ead971f785f8231656335c1c190ffda1bb40b5affb8d7a3fb67d084102513a44e457a9d5ba1fba3969aa0e954669a33071fc65fba0b2424f
DIST hashcat-3.5.0.tar.gz 4103461 BLAKE2B 821280182641ceadab7d712395a0a33cd7bfde8fcc8c133a2c12d089dc76b43edbee632f724083f29e9ec924991cda94e6f17b53f1b3155537d41286d3886832 SHA512 7efc860461894a550fbacc406a40fec400232a120818180abba3d53f26bd3a503f58e7d189e4afad0f871c2244ff68371b145af58ab097478fe2d73f39c9a6b3
DIST hashcat-4.0.1.tar.gz 3905127 BLAKE2B 534270c7409f5a3dc4995a81fab63e6bfcd6b2bd4bb549f96b44e9c6bf24ce67505eb82803ace29fba69526c7c0703c66de9cc68cefcca79ef58040165041756 SHA512 7300b16ebd601fdbdbfd66adeba072c6f4f4dd5898dd85824513b97cc7848f4c2ae0fe523cfe7803fdba7954966ea289275fa5d49ff792706f73394e2bd95e77
49 changes: 49 additions & 0 deletions app-crypt/hashcat/hashcat-4.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils pax-utils multilib

DESCRIPTION="World's fastest and most advanced password recovery utility"
HOMEPAGE="https://github.com/hashcat/hashcat"
SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~amd64"

IUSE="custom-cflags video_cards_nvidia"
DEPEND="virtual/opencl"
RDEPEND="${DEPEND}"

src_prepare() {
#do not strip
sed -i "/LFLAGS += -s/d" src/Makefile
#do not add random CFLAGS
sed -i "s/-O2//" src/Makefile || die
export PREFIX=/usr
export LIBRARY_FOLDER="/usr/$(get_libdir)"
eapply_user
}

src_compile() {
default
pax-mark -mr hashcat
}

src_test() {
if use video_cards_nvidia; then
addwrite /dev/nvidia0
addwrite /dev/nvidiactl
addwrite /dev/nvidia-uvm
if [ ! -w /dev/nvidia0 ]; then
einfo "To run these tests, portage likely must be in the video group."
einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
fi
#elif use vidia_cards_fglrx; then
# addwrite /dev/ati
fi
#this always exits with 255 despite success
#./hashcat -b -m 2500 || die "Test failed"
./hashcat -a 3 -m 1500 nQCk49SiErOgk || die "Test failed"
}

0 comments on commit d8f8f5b

Please sign in to comment.