forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Eray Aslan <[email protected]>
- Loading branch information
Showing
2 changed files
with
166 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST krb5-1.17.1.tar.gz 8765399 BLAKE2B 46be864e2db9c70d164532d82776195bf57342ce4f1fd7dfcf3cf6bd72a3639a69954f742607a2b8950b4dea8acfac5d633aa379d669de20bafe54b407bab94b SHA512 e0c3dc0a6554ab3105ac32f3f01519f56064500213aa743816235d83250abc1db9a9ca38a2ba93a938d562b4af135a013017ce96346d6742bca0c812b842ceef | ||
DIST krb5-1.17.tar.gz 8761763 BLAKE2B 76f636836c67e9eefca91c9417118efdcf4437c1220691f43f3d246daf3eabd53b40a30956f0e57703c3fde5d7193b1d86b68becf3ae1c0c803d2462e79d3014 SHA512 7462a578b936bd17f155a362dbb5d388e157a80a096549028be6c55400b11361c7f8a28e424fd5674801873651df4e694d536cae66728b7ae5e840e532358c52 | ||
DIST krb5-1.18.1.tar.gz 8711772 BLAKE2B 98ea02b686760d1e080e1b038601fedcb85ceb4c61dbbba717c300f54a784e8494ff0fc7c0139e95fffd6b1cbe2a65158c9a3af71ea76c1b86905642c29cd93a SHA512 c96c9ed676c8ccb9b65d17bb1d982c266228c75030a2d8fd5d7952ee8cdf362a22d202e93018d1011a5e7bd9a9fabe69aa1578d1d2e4839a78b9916d8b8019ce | ||
DIST krb5-1.18.tar.gz 8706395 BLAKE2B d2b700c2f869733a7fc9ac735ec27e3973868efcf62c6b130fb5ff33aaaed0571816af519123e9077fc0bc240ee71a6179e87a4f724ae06dba8a70fd1d594b9a SHA512 36a01ea310b4b3d0a3d209b641739575239e1ca5e93b3de99cb1fec83e82f9a70ad0761dd6eb77cda5c18c53044ab80168b00725642a0c2dfde0e492c42af6a9 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,165 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
inherit autotools flag-o-matic multilib-minimal python-any-r1 systemd | ||
|
||
MY_P="${P/mit-}" | ||
P_DIR=$(ver_cut 1-2) | ||
DESCRIPTION="MIT Kerberos V" | ||
HOMEPAGE="https://web.mit.edu/kerberos/www/" | ||
SRC_URI="https://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}.tar.gz" | ||
|
||
LICENSE="openafs-krb5-a BSD MIT OPENLDAP BSD-2 HPND BSD-4 ISC RSA CC-BY-SA-3.0 || ( BSD-2 GPL-2+ )" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86" | ||
IUSE="cpu_flags_x86_aes doc +keyutils libressl lmdb nls openldap +pkinit selinux +threads test xinetd" | ||
|
||
# Test suite requires network access | ||
RESTRICT="test" | ||
|
||
DEPEND=" | ||
!!app-crypt/heimdal | ||
>=sys-libs/e2fsprogs-libs-1.42.9[${MULTILIB_USEDEP}] | ||
|| ( | ||
>=dev-libs/libverto-0.2.5[libev,${MULTILIB_USEDEP}] | ||
>=dev-libs/libverto-0.2.5[libevent,${MULTILIB_USEDEP}] | ||
>=dev-libs/libverto-0.2.5[tevent,${MULTILIB_USEDEP}] | ||
) | ||
keyutils? ( >=sys-apps/keyutils-1.5.8:=[${MULTILIB_USEDEP}] ) | ||
lmdb? ( dev-db/lmdb ) | ||
nls? ( sys-devel/gettext[${MULTILIB_USEDEP}] ) | ||
openldap? ( >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}] ) | ||
pkinit? ( | ||
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] ) | ||
libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] ) | ||
) | ||
xinetd? ( sys-apps/xinetd ) | ||
" | ||
BDEPEND=" | ||
${PYTHON_DEPS} | ||
virtual/yacc | ||
cpu_flags_x86_aes? ( | ||
amd64? ( dev-lang/yasm ) | ||
x86? ( dev-lang/yasm ) | ||
) | ||
doc? ( virtual/latex-base ) | ||
test? ( | ||
${PYTHON_DEPS} | ||
dev-lang/tcl:0 | ||
dev-util/dejagnu | ||
dev-util/cmocka | ||
)" | ||
RDEPEND="${DEPEND} | ||
selinux? ( sec-policy/selinux-kerberos )" | ||
|
||
S=${WORKDIR}/${MY_P}/src | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-1.12_warn_cflags.patch" | ||
"${FILESDIR}/${PN}-config_LDFLAGS-r1.patch" | ||
"${FILESDIR}/${PN}-1.16.3-libressl-r1.patch" | ||
"${FILESDIR}/${PN}_dont_create_run.patch" | ||
"${FILESDIR}/${PN}-1.18-libressl.patch" | ||
) | ||
|
||
MULTILIB_CHOST_TOOLS=( | ||
/usr/bin/krb5-config | ||
) | ||
|
||
src_prepare() { | ||
default | ||
# Make sure we always use the system copies. | ||
rm -rf util/{et,ss,verto} | ||
sed -i 's:^[[:space:]]*util/verto$::' configure.ac || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
# QA | ||
append-flags -fno-strict-aliasing | ||
append-flags -fno-strict-overflow | ||
|
||
multilib-minimal_src_configure | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE=${S} \ | ||
WARN_CFLAGS="set" \ | ||
econf \ | ||
$(use_with openldap ldap) \ | ||
"$(multilib_native_use_with test tcl "${EPREFIX}/usr")" \ | ||
$(use_enable nls) \ | ||
$(use_enable pkinit) \ | ||
$(use_enable threads thread-support) \ | ||
$(use_with lmdb) \ | ||
$(use_with keyutils) \ | ||
--without-hesiod \ | ||
--enable-shared \ | ||
--with-system-et \ | ||
--with-system-ss \ | ||
--enable-dns-for-realm \ | ||
--enable-kdc-lookaside-cache \ | ||
--with-system-verto \ | ||
--disable-rpath | ||
} | ||
|
||
multilib_src_compile() { | ||
emake -j1 | ||
} | ||
|
||
multilib_src_test() { | ||
multilib_is_native_abi && emake -j1 check | ||
} | ||
|
||
multilib_src_install() { | ||
emake \ | ||
DESTDIR="${D}" \ | ||
EXAMPLEDIR="${EPREFIX}/usr/share/doc/${PF}/examples" \ | ||
install | ||
} | ||
|
||
multilib_src_install_all() { | ||
# default database dir | ||
keepdir /var/lib/krb5kdc | ||
|
||
cd .. | ||
dodoc README | ||
|
||
if use doc; then | ||
dodoc -r doc/html | ||
docinto pdf | ||
dodoc doc/pdf/*.pdf | ||
fi | ||
|
||
newinitd "${FILESDIR}"/mit-krb5kadmind.initd-r2 mit-krb5kadmind | ||
newinitd "${FILESDIR}"/mit-krb5kdc.initd-r2 mit-krb5kdc | ||
newinitd "${FILESDIR}"/mit-krb5kpropd.initd-r2 mit-krb5kpropd | ||
newconfd "${FILESDIR}"/mit-krb5kadmind.confd mit-krb5kadmind | ||
newconfd "${FILESDIR}"/mit-krb5kdc.confd mit-krb5kdc | ||
newconfd "${FILESDIR}"/mit-krb5kpropd.confd mit-krb5kpropd | ||
|
||
systemd_newunit "${FILESDIR}"/mit-krb5kadmind.service mit-krb5kadmind.service | ||
systemd_newunit "${FILESDIR}"/mit-krb5kdc.service mit-krb5kdc.service | ||
systemd_newunit "${FILESDIR}"/mit-krb5kpropd.service mit-krb5kpropd.service | ||
systemd_newunit "${FILESDIR}"/mit-krb5kpropd_at.service "[email protected]" | ||
systemd_newunit "${FILESDIR}"/mit-krb5kpropd.socket mit-krb5kpropd.socket | ||
|
||
insinto /etc | ||
newins "${ED}/usr/share/doc/${PF}/examples/krb5.conf" krb5.conf.example | ||
insinto /var/lib/krb5kdc | ||
newins "${ED}/usr/share/doc/${PF}/examples/kdc.conf" kdc.conf.example | ||
|
||
if use openldap ; then | ||
insinto /etc/openldap/schema | ||
doins "${S}/plugins/kdb/ldap/libkdb_ldap/kerberos.schema" | ||
fi | ||
|
||
if use xinetd ; then | ||
insinto /etc/xinetd.d | ||
newins "${FILESDIR}/kpropd.xinetd" kpropd | ||
fi | ||
} |