Skip to content

Commit

Permalink
dev-python/flask-restful: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
patricklauer committed Jan 3, 2016
1 parent 6a5e287 commit d91666e
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/flask-restful/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST flask-restful-0.3.1.tar.gz 103801 SHA256 b2171bb730511e2fc54d071a5b8d9f5e85
DIST flask-restful-0.3.2.tar.gz 106082 SHA256 0b91c5ac2fdfa3cebb25c2110ab24636833e5209eb186a8bd109f563a355ae1f SHA512 e35901f297ed9ec76f4be94c9511a12b7370f00ed959a22fab6804e739a13bf885023f00baf3fad29a59cc873c9d5d0b2e85b7e4657d3203983dc6775d71c89a WHIRLPOOL 7403fafbc37e8080731c7ad71076e986f2a06d30a216257bb10c08c5d230a88a4bde043af13e590be976e8c1953a829fe76827bb5a10db638dddf8b28282f9da
DIST flask-restful-0.3.3.tar.gz 109947 SHA256 0aeb8f00c96335f90df304a57f36caecd12befccd333a39708f8929f0a528042 SHA512 f8e48048a25b38a09321efc98649970d959d41bf5cc15f5111e1326396ff305b2dbca757a3198a4ed8cf59a6d0144a981178926c1fecc462132888198b4dd8e6 WHIRLPOOL d4db2f013fb92a593731ea19eba6f0daf0f498ebc9fca17f1da8d23b75e243323004e8fe7425813740dc6bcd9c80780a1836a1f37d403a35a94667ecf8fa8a93
DIST flask-restful-0.3.4.tar.gz 110669 SHA256 c991d85187e1e0e3e58713d62fc8543fe51d7479ee04151061cf9e452e1e2161 SHA512 3f4debac812ddb511f77802e184e24d1ebf023fd282ba37375484260118cafbad479033deed4e5cf9d2681880059fecf9ac34aafad230186f3e3e1cca2f2033b WHIRLPOOL 96e2a0d007fd8042d2e0d344c7042abf24cc3649b11a36330965a1ffaeeb8a21a04651cbdd486757e704b39773a5b8f8146e6d4ddb4477ad462b1ae7edc74567
DIST flask-restful-0.3.5.tar.gz 113214 SHA256 30f3433c32d3251b83779034513994df93635db81bf5cd5122a4e0415dd3f5c1 SHA512 a541e6739644b4db6ae97cf529bfc43f3136c97fc19a8538277d1f9be033b7c6dc3e39e1c4b2f313e099efbe750dbdc85c67b527224df557567ecac668e5969a WHIRLPOOL d8d0673380263c25e84ed3e86a83b04bae88761c8f3456dcab7d6d58b9884b1b984c28c861bc091c9693b080c15f2f47f99ff6a3003a7f89dd50df851a7d3af5
51 changes: 51 additions & 0 deletions dev-python/flask-restful/flask-restful-0.3.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1

DESCRIPTION="Simple framework for creating REST APIs"
HOMEPAGE="http://flask-restful.readthedocs.org/ https://github.com/twilio/flask-restful/"
SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples paging test"

RDEPEND="
>=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
>=dev-python/flask-0.8[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
dev-python/sphinx[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
)
"

python_test() {
nosetests -v || die "Tests fail with ${EPYTHON}"
}

python_compile_all() {
cd docs || die
emake man $(usex doc html "")
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
use examples && local EXAMPLES=( examples/. )
local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )

doman docs/_build/man/*
distutils-r1_python_install_all
}

0 comments on commit d91666e

Please sign in to comment.