Skip to content

Commit

Permalink
gnome-base/gnome-keyring: bump to 3.31.91
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/683674
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <[email protected]>
  • Loading branch information
leio committed Sep 23, 2019
1 parent 3c2339f commit d91ec7b
Show file tree
Hide file tree
Showing 3 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/gnome-keyring/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gnome-keyring-3.20.0.tar.xz 1215324 BLAKE2B 97a4663fac7d3e854a742ac2f160fda2b40c5ff9f7316b52197955aa1970732ef323252325a021469d4944e962b1f1b868d300476b854f21cc5636961e3972da SHA512 f7e6195b4be52edaee3bc3181f006ec31ebd54f8000c98220520f4158f66580b60950e4f55247aefae6aa9320f6589c8a09c1e32853165915ae5ff1b40627c5b
DIST gnome-keyring-3.20.1.tar.xz 1219800 BLAKE2B b0c633575ee35a733bbf04322e4413675bc40d4de256b66183138483f50c1d399a450cd4d06a3d76707948a7c541ef129a3385044f109a37677af6a7fc01e9af SHA512 a60d8a4b17a9c6d8c581578881abaf7d79de43045a314b401e3bfd3974edb4ab94117dd430203b721058f432b24bf6296e0b7c4fba1e66cccd2c2e9441787177
DIST gnome-keyring-3.28.2.tar.xz 1322108 BLAKE2B 416697befb7670c3b854ff8d70626d495f5ba77691a062f854360e25a76766f5023e998b86114d36965023a5efefc2eb0ab1dca9aa03d73351eafebaa4920784 SHA512 a51bc9d6bc9203b86febe99bdbf893d3ba0eeaad976ece2bd49efc3869bd1d15f440a01999ce969f845f8336538de22e9f1161da990d707cbadb99d5cc3549bc
DIST gnome-keyring-3.31.91.tar.xz 1365052 BLAKE2B fed6ac7bb5a509e268180d047cd5df1564d5a90672f5240fa98773f43d9ca7eb63c598d81c4a9de8e988ee5886679bceeb4be1c43acce876680aeb3df4385856 SHA512 c66ad13fd84764f01e75de2d6142ecb42954d6111f86738c27e7b5b94e702be2af5af7f83ba4e4b9aae58cfa04f3973e272c8177179d1f8a54f63c037aea0210
27 changes: 27 additions & 0 deletions gnome-base/gnome-keyring/files/3.31.91-fix-musl.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 7a8b7d2ebfbb831840e6d58dbb1109f4c31d6ba4 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <[email protected]>
Date: Fri, 10 May 2019 15:47:33 +0200
Subject: [PATCH] rpc-layer: fix build with musl-libc

The recent POSIX suggests to include <sys/select.h> for select().

Reported by Anthony G. Basile.
---
pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c | 1 +
1 file changed, 1 insertion(+)

diff --git a/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c b/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
index 5024e1e1..b3fb6707 100644
--- a/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
+++ b/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
@@ -34,6 +34,7 @@

#include <dlfcn.h>
#include <pthread.h>
+#include <sys/select.h>

#define SOCKET_PATH "/tmp/gkm-rpc-daemon.sock"

--
2.20.1

82 changes: 82 additions & 0 deletions gnome-base/gnome-keyring/gnome-keyring-3.31.91.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 )

inherit fcaps gnome2 pam python-any-r1 virtualx

DESCRIPTION="Password and keyring managing daemon"
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring"

LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
IUSE="+caps pam selinux +ssh-agent test"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"

# Replace gkd gpg-agent with pinentry[gnome-keyring] one, bug #547456
RDEPEND="
>=app-crypt/gcr-3.27.90:=[gtk]
>=dev-libs/glib-2.44:2
app-misc/ca-certificates
>=dev-libs/libgcrypt-1.2.2:0=
caps? ( sys-libs/libcap-ng )
pam? ( virtual/pam )
selinux? ( sec-policy/selinux-gnome )
>=app-crypt/gnupg-2.0.28:=
ssh-agent? ( net-misc/openssh )
"
DEPEND="${RDEPEND}
>=app-eselect/eselect-pinentry-0.5
app-text/docbook-xml-dtd:4.3
dev-libs/libxslt
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
test? ( ${PYTHON_DEPS} )
"
PDEPEND="app-crypt/pinentry[gnome-keyring]" #570512

PATCHES=(
"${FILESDIR}"/${PV}-fix-musl.patch
)

pkg_setup() {
use test && python-any-r1_pkg_setup
}

src_prepare() {
# Disable stupid CFLAGS with debug enabled
sed -e 's/CFLAGS="$CFLAGS -g"//' \
-e 's/CFLAGS="$CFLAGS -O0"//' \
-i configure.ac configure || die

gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
$(use_with caps libcap-ng) \
$(use_enable pam) \
$(use_with pam pam-dir $(getpam_mod_dir)) \
$(use_enable selinux) \
$(use_enable ssh-agent) \
--enable-doc
}

src_test() {
"${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
GSETTINGS_SCHEMA_DIR="${S}/schema" virtx emake check
}

pkg_postinst() {
# cap_ipc_lock only needed if building --with-libcap-ng
# Never install as suid root, this breaks dbus activation, see bug #513870
use caps && fcaps -m 755 cap_ipc_lock usr/bin/gnome-keyring-daemon
gnome2_pkg_postinst

if ! [[ $(eselect pinentry show | grep "pinentry-gnome3") ]] ; then
ewarn "Please select pinentry-gnome3 as default pinentry provider:"
ewarn " # eselect pinentry set pinentry-gnome3"
fi
}

0 comments on commit d91ec7b

Please sign in to comment.