Skip to content

Commit

Permalink
dev-libs/boehm-gc: bump up to 8.0.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Mar 2, 2019
1 parent 18b904b commit d922bc6
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/boehm-gc/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST gc-7.4.2.tar.gz 1082597 BLAKE2B 5ca30e786a995941fdf2d803d201e7263bdd7d9974a
DIST gc-7.6.10.tar.gz 1143650 BLAKE2B 5dce84de2e842c98dc552b4a6fc28311e241f419a792523be2e5cb0f7d5b34a57608f8c40e1d85cf06fb3f9c6212855438a0d20c23e2b2d9ba37485d91d78a3e SHA512 6952ff38ed39203c8ff9aae516d81cf5210f3f17fac030325ba58b89c266d2d6ffa281b996c481b9d821638a0334da68f00c15dc4774759ff1f7b57b4678f08f
DIST gc-7.6.4.tar.gz 1120784 BLAKE2B e7cad27d2144fd37aebad44093e1a0814fe9a1cc887701e485681cdd01f3ea4477150697d535d0873a1255abff0765084119096c7ed61d3caeda439cf2a7644f SHA512 2c85be3e24b85732b3dc6f08fe98cf1a82b6fb2a22ec73090f80920721c737ef92cee8f0cd7ea7228d686005d164e7da54ce3907c3a1ba5eefa43355a472085e
DIST gc-8.0.2.tar.gz 1159207 BLAKE2B f3dfcecbc9ba59c2abac868278eb6fdca4bda46a5303393a8fb63717f01bc19fa007b6530a536c32600db30f3a45d8d5558fe72adefecd9b97075dfadb3eddc2 SHA512 b1401abb2e82b143b9a2a9013f5b2efa4015b256e7ea8ef2c897ef3c0d2d41fc893413bf6a49efc1845018e8ab823adb485fb3358eb47715982259ace9ffd7c6
DIST gc-8.0.4.tar.gz 1160528 BLAKE2B ec42378c964fc573e53f6f58aa22fa63a0b421c91b81336acfeb2e2afdb5c89514edace3a9500699e13ff1cadc4205ea245af4f0dfa5e439ed9b78cabf6058f7 SHA512 57ccca15c6e50048d306a30de06c1a844f36103a84c2d1c17cbccbbc0001e17915488baec79737449982da99ce5d14ce527176afae9ae153cbbb5a19d986366e
53 changes: 53 additions & 0 deletions dev-libs/boehm-gc/boehm-gc-8.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit multilib-minimal libtool

MY_P="gc-${PV}"

DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
HOMEPAGE="http://www.hboehm.info/gc/ https://github.com/ivmai/bdwgc/"
SRC_URI="https://github.com/ivmai/bdwgc/releases/download/v${PV}/${MY_P}.tar.gz"

LICENSE="boehm-gc"
# SONAME: libgc.so.1 libgccpp.so.1
# We've been using subslot 0 for these instead of "1.1".
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="cxx static-libs +threads"

DEPEND="
>=dev-libs/libatomic_ops-7.4[${MULTILIB_USEDEP}]
virtual/pkgconfig"

S="${WORKDIR}/${MY_P}"

src_prepare() {
default
elibtoolize #594754
}

multilib_src_configure() {
local config=(
--disable-docs
--with-libatomic-ops
$(use_enable cxx cplusplus)
$(use_enable static-libs static)
$(use threads || echo --disable-threads)
)

ECONF_SOURCE=${S} econf "${config[@]}"
}

multilib_src_install_all() {
local HTML_DOCS=( doc/*.md )
einstalldocs
dodoc doc/README{.environment,.linux,.macros}

# package provides .pc files
find "${ED}" -name '*.la' -delete || die

newman doc/gc.man GC_malloc.1
}

0 comments on commit d922bc6

Please sign in to comment.