forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/botocore: add new version 1.13.2
Cloned from 9999 ebuild verbatim. Version caps on few deps, which have been added by Whissi in botocore-1.12.251.ebuild, are thus abandoned, which has been agreed with Whissi. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <[email protected]>
- Loading branch information
Andrey Utkin
committed
Oct 25, 2019
1 parent
7438045
commit d9275b8
Showing
2 changed files
with
59 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Low-level, data-driven core of boto 3." | ||
HOMEPAGE="https://github.com/boto/botocore" | ||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="doc test" | ||
|
||
if [[ "${PV}" == "9999" ]]; then | ||
EGIT_REPO_URI="https://github.com/boto/botocore" | ||
inherit git-r3 | ||
else | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
fi | ||
|
||
RDEPEND=" | ||
dev-python/docutils[${PYTHON_USEDEP}] | ||
dev-python/jmespath[${PYTHON_USEDEP}] | ||
dev-python/python-dateutil[${PYTHON_USEDEP}] | ||
dev-python/urllib3[${PYTHON_USEDEP}] | ||
" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
doc? ( | ||
dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}] | ||
dev-python/sphinx[${PYTHON_USEDEP}] | ||
) | ||
test? ( | ||
${RDEPEND} | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
dev-python/jsonschema[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" ) | ||
|
||
python_compile_all() { | ||
use doc && emake -C docs html | ||
} | ||
|
||
python_test() { | ||
PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}" | ||
PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}" | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( docs/build/html/. ) | ||
|
||
distutils-r1_python_install_all | ||
} |