Skip to content

Commit

Permalink
dev-db/percona-server: Bump to v5.6.35-80.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Whissi committed Feb 14, 2017
1 parent dad68b3 commit d9398c8
Show file tree
Hide file tree
Showing 2 changed files with 221 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/percona-server/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mysql-extras-20161130-2354Z.tar.bz2 303863 SHA256 b18ce4ccfd023106a802bcb2e
DIST percona-server-5.6.32-78.1.tar.gz 55115483 SHA256 d94d73bf12459c57fcc8fa8018d7a08775d45ba718999a4ef0a09f543c654778 SHA512 77788932e83c3e3e4bbaa143844a11c809e0cbd87afbdc0f76ea12c462581d7438246d61984f82fe5174c2a099ea38274aa61957b05c6fc5a101a52028477b41 WHIRLPOOL 87561c8ce13809518b0a4fb2429cac9ef6667eedf0dad742f349e8f15736cf8249e4955eb1f49f579ab7cac550409603171b9003bf523c87603b3a2f38fd4ac0
DIST percona-server-5.6.33-79.0.tar.gz 55184504 SHA256 ed8372340740faca1f58735938823eaf65ffbda64a5c65b18d187b959afbd34e SHA512 5a31f9aecf9ec4515e46dcddc614989fbbbd7b23af9c5b351eac30ede3399358413b6f9b204628a12e3260a5e1d6ed94e70769ae487728c27796c81ea0282c85 WHIRLPOOL c341746eb053a74c02df47ea24a3e941bbdc89b840abadf68668e403dc50e071a9f96d429a8bead17b269d2a602bff35b8588179714d99372e068c0494db93c2
DIST percona-server-5.6.34-79.1.tar.gz 55763384 SHA256 8db1906e8fae2ac10faa23f44663f083762edd954a8efae2c798bc671b9d12d6 SHA512 3691daf14042cb35ab8cfe487c760e3da8f0758384224511ef84f388f895a5e15cbbf1a5ae1022d8a9d8ff7ee8ae7651ec8f39381cefce14b4f0fe3f2de2608b WHIRLPOOL 03911d171699ecf2c07e27fbdc82baa19a1fb72e2f0cbe17b107b49594e1c7755ae4ace5c2b74576517c262d6a812d0aa376c776e5f87f67c7f57bae37c6f4fd
DIST percona-server-5.6.35-80.0.tar.gz 55839147 SHA256 259b5aa2c6218958c8cc55170b9381955ea60445127bf46e02aa09903af7f26b SHA512 78b0b9cd69f26dc3ac13e4c6165590736d723b0f07d18a8ac1056281522de22b67d9fd931b035962bc278c97775fe7f98c46791328ece286268c7d31a484b69d WHIRLPOOL a6a6f78f41b1f8b5c26d0899efa6b043256749f4082ae9bffafe9210c3a326f33fe512a4c6578984892797e4f2c94de88ceca4c8c983cde7096cf01e88dec9b7
220 changes: 220 additions & 0 deletions dev-db/percona-server/percona-server-5.6.35.80.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,220 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"
MY_EXTRAS_VER="20161130-2354Z"
SUBSLOT="18"
PYTHON_COMPAT=( python2_7 )
inherit linux-info python-any-r1 mysql-multilib-r1

IUSE="numa pam tokudb tokudb-backup-plugin"

# REMEMBER: also update eclass/mysql*.eclass before committing!
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux"
HOMEPAGE="http://www.percona.com/software/percona-server"
DESCRIPTION="An enhanced, drop-in replacement for MySQL from the Percona team"

# When MY_EXTRAS is bumped, the index should be revised to exclude these.
EPATCH_EXCLUDE=''

COMMON_DEPEND="numa? ( sys-process/numactl:= )
server? ( pam? ( virtual/pam:0= ) )
tokudb? ( app-arch/snappy )
tokudb-backup-plugin? ( dev-util/valgrind )
"

DEPEND="${COMMON_DEPEND}
|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )
test? ( $(python_gen_any_dep 'dev-python/mysql-python[${PYTHON_USEDEP}]') )"
RDEPEND="${COMMON_DEPEND}"

REQUIRED_USE="tokudb? ( jemalloc ) tokudb-backup-plugin? ( tokudb )"

MY_PATCH_DIR="${WORKDIR}/mysql-extras-${MY_EXTRAS_VER}"

PATCHES=(
"${MY_PATCH_DIR}"/01050_all_mysql_config_cleanup-5.6.patch
"${MY_PATCH_DIR}"/02040_all_embedded-library-shared-5.5.10.patch
"${MY_PATCH_DIR}"/20001_all_fix-minimal-build-cmake-mysql-5.6.20.patch
"${MY_PATCH_DIR}"/20006_all_cmake_elib-percona-5.6.34.patch
"${MY_PATCH_DIR}"/20007_all_cmake-debug-werror-5.6.22.patch
"${MY_PATCH_DIR}"/20008_all_mysql-tzinfo-symlink.patch
"${MY_PATCH_DIR}"/20009_all_mysql_myodbc_symbol_fix-5.6.patch
"${MY_PATCH_DIR}"/20018_all_percona-server-5.6.25-without-clientlibs-tools.patch
)

# Please do not add a naive src_unpack to this ebuild
# If you want to add a single patch, copy the ebuild to an overlay
# and create your own mysql-extras tarball, looking at 000_index.txt

pkg_pretend() {
mysql-multilib-r1_pkg_pretend

if use numa; then
local CONFIG_CHECK="~NUMA"

local WARNING_NUMA="This package expects NUMA support in kernel which this system does not have at the moment;"
WARNING_NUMA+=" Either expect runtime errors, enable NUMA support in kernel or rebuild the package without NUMA support"

check_extra_config
fi
}

python_check_deps() {
has_version "dev-python/mysql-python[${PYTHON_USEDEP}]"
}

src_prepare() {
mysql-multilib-r1_src_prepare
if use libressl ; then
sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
"${S}/cmake/ssl.cmake" || die
fi
}

src_configure() {
local MYSQL_CMAKE_NATIVE_DEFINES=( -DWITH_NUMA=$(usex numa)
-DWITH_PAM=$(usex pam)
$(mysql-cmake_use_plugin tokudb TOKUDB)
)
if use tokudb ; then
# TokuDB Backup plugin requires valgrind unconditionally
MYSQL_CMAKE_NATIVE_DEFINES+=(
$(usex tokudb-backup-plugin '' -DTOKUDB_BACKUP_DISABLED=1)
)
fi
mysql-multilib-r1_src_configure
}

# Official test instructions:
# USE='extraengine perl openssl static-libs' \
# FEATURES='test userpriv -usersandbox' \
# ebuild percona-server-X.X.XX.ebuild \
# digest clean package
multilib_src_test() {

if ! multilib_is_native_abi ; then
einfo "Server tests not available on non-native abi".
return 0;
fi

if ! use server ; then
einfo "Skipping server tests due to minimal build."
return 0
fi

local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test"
local retstatus_unit
local retstatus_tests

# Bug #213475 - MySQL _will_ object strenously if your machine is named
# localhost. Also causes weird failures.
[[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"

if [[ $UID -eq 0 ]]; then
die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
fi

einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"

# Run CTest (test-units)
cmake-utils_src_test
retstatus_unit=$?
[[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"

# Ensure that parallel runs don't die
export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
# Enable parallel testing, auto will try to detect number of cores
# You may set this by hand.
# The default maximum is 8 unless MTR_MAX_PARALLEL is increased
export MTR_PARALLEL="${MTR_PARALLEL:-auto}"

# create directories because mysqladmin might right out of order
mkdir -p "${T}"/var-tests{,/log}

# These are failing in Percona 5.6 for now and are believed to be
# false positives:
#
# main.information_schema, binlog.binlog_statement_insert_delayed,
# main.mysqld--help-notwin, binlog.binlog_mysqlbinlog_filter
# perfschema.binlog_edge_mix, perfschema.binlog_edge_stmt
# funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers
# engines/funcs.db_alter_character_set engines/funcs.db_alter_character_set_collate
# engines/funcs.db_alter_collate_ascii engines/funcs.db_alter_collate_utf8
# engines/funcs.db_create_character_set engines/funcs.db_create_character_set_collate
# fails due to USE=-latin1 / utf8 default
#
# main.mysql_client_test:
# segfaults at random under Portage only, suspect resource limits.
#
# main.percona_bug1289599
# Looks to be a syntax error in the test file itself
#
# main.variables main.myisam main.merge_recover
# fails due to ulimit not able to open enough files (needs 5000)
#
# main.mysqlhotcopy_archive main.mysqlhotcopy_myisam
# Called with bad parameters should be reported upstream
#

local t

for t in main.mysql_client_test \
binlog.binlog_statement_insert_delayed main.information_schema \
main.mysqld--help-notwin binlog.binlog_mysqlbinlog_filter \
perfschema.binlog_edge_mix perfschema.binlog_edge_stmt \
funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers \
main.variables main.myisam main.merge_recover \
engines/funcs.db_alter_character_set engines/funcs.db_alter_character_set_collate \
engines/funcs.db_alter_collate_ascii engines/funcs.db_alter_collate_utf8 \
engines/funcs.db_create_character_set engines/funcs.db_create_character_set_collate \
main.percona_bug1289599 main.mysqlhotcopy_archive main.mysqlhotcopy_myisam ; do
mysql-multilib-r1_disable_test "$t" "False positives in Gentoo"
done

if use numa && use kernel_linux ; then
# bug 584880
if ! linux_config_exists || ! linux_chkconfig_present NUMA ; then
for t in sys_vars.innodb_buffer_pool_populate_basic ; do
mysql-multilib-r1_disable_test "$t" "Test $t requires system with NUMA support"
done
fi
fi

if ! use extraengine ; then
# bug 401673, 530766
for t in federated.federated_plugin ; do
mysql-multilib-r1_disable_test "$t" "Test $t requires USE=extraengine (Need federated engine)"
done
fi

# Run mysql tests
pushd "${TESTDIR}" || die

# Set file limits higher so tests run
ulimit -n 3000
python_setup
# run mysql-test tests
perl mysql-test-run.pl --force --vardir="${T}/var-tests" \
--testcase-timeout=30 --reorder
retstatus_tests=$?
[[ $retstatus_tests -eq 0 ]] || eerror "tests failed"

popd || die

# Cleanup is important for these testcases.
pkill -9 -f "${S}/ndb" 2>/dev/null
pkill -9 -f "${S}/sql" 2>/dev/null

failures=""
[[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
[[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"

if [[ -n "$failures" ]]; then
has usersandbox $FEATURES && eerror "Some tests may have failed due to FEATURES=usersandbox"
die "Test failures: $failures"
fi

einfo "Tests successfully completed"
}

0 comments on commit d9398c8

Please sign in to comment.