Skip to content

Commit

Permalink
dev-util/checkbashisms: Bump to version 2.16.7
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Aug 23, 2016
1 parent 68708fe commit d945e5a
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/checkbashisms/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST devscripts_2.16.5.tar.xz 688204 SHA256 02b813f3565683f1ba6d1381b247a2342030279ae4ff56ff609964e5963acf4b SHA512 e0f645e3680da32b4216e81a0d7f2701501a0c0d7f1b107f02260ce39311a331825053cfb1ee2445b5fda27d0722d659f46f82125402d7b8a053ce294406a503 WHIRLPOOL 41fd777e2992b68e78db87d5794720eff91f895a96b9b969689e528df647afa22496cc2d856adcd3a6cf9e519471ca6662afa7827a0e5bdd47b820dd5a1861d4
DIST devscripts_2.16.6.tar.xz 664576 SHA256 90841ee460acce9aef06e02b0d9f427470a0d1a1797212309a56bfb0388d7052 SHA512 f16c2196a45504f0ef1a4697721271e51ca6fe156d2938817b89ae584233b9baef4d92e5c6ba141606cc415f09fdd8651498678ba9d074b1fb3d39d2dcf4ae03 WHIRLPOOL 719a4ac23dbc53540521d8d0cb3133df7b703f528fd66e7456693bf7065c216e0cd493c13a865f0f696d391b6820aae0145da3f217329933ff6991c5f08a6f2c
DIST devscripts_2.16.7.tar.xz 666244 SHA256 027ac99f4ceddb9a916752971d2e394cf74c3145be18d0d4278f692a41d816de SHA512 47ed856bb5b8978a92b764f0fda04f0dd69f17f0e810e9d6e6045ffff8f1e52ad8a6ebc4984b5058bbbfdea79127af4a3ebc95c0c1770d1b3b4910c228c20d89 WHIRLPOOL abe27bc203d9f5936df0c736a9d43b001953098aab4929c0bcf9b24a258ce588b9d76e27d44207c98e09530094222cb241d35595f2fb90731539b418b0fc4cab
43 changes: 43 additions & 0 deletions dev-util/checkbashisms/checkbashisms-2.16.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

MY_PN="devscripts"
MY_P="${MY_PN}-${PV}"

inherit eutils

DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

# Requires python packages to check tools we don't need anyway
RESTRICT="test"

RDEPEND="dev-lang/perl
virtual/perl-Getopt-Long
!<dev-util/rpmdevtools-8.3-r1"

S="${WORKDIR}/${MY_P}/scripts"

PATCHES=(
"${FILESDIR}"/${PN}-2.15.9-command-vV.patch
)

src_prepare() {
epatch "${PATCHES[@]}"
}

src_compile() { :; }

src_install() {
newbin ${PN}.pl ${PN}
doman ${PN}.1
}

0 comments on commit d945e5a

Please sign in to comment.