Skip to content

Commit

Permalink
dev-db/mongodb: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
ultrabug committed Feb 8, 2017
1 parent d429763 commit d95a150
Show file tree
Hide file tree
Showing 2 changed files with 191 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/mongodb/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST mongodb-src-r3.0.14.tar.gz 28093922 SHA256 ebbb758ca7ee53e8d25e2410bb7ef616
DIST mongodb-src-r3.2.11.tar.gz 29113706 SHA256 625eb28fd47b2af63b30343a064de7f42e5265f4c642874ec766ba3643fd80d7 SHA512 8cb63f878d573e2fb2bace57a10d036aebe0cc06e46a3cd5480fb4a8bcd51ac5219c729b5ea85213e0c905906a93780080332fa01dbcd29e01358f5e9051824c WHIRLPOOL fca825400e9ab16e53dfbbd400a9bd87b9a866d56b2a5839ece25b8dbfe55074fa04d40f47c337f67cb3bd3e547b99b4349eeb15a87a9b9659ea0f1a0cc2c526
DIST mongodb-src-r3.2.12.tar.gz 29178424 SHA256 406ced873a9abe8a3f0f92939bf5374663bac86c72181c80bec144aedf6cd306 SHA512 0c4ddaaddf15d97957faff46dc4a3f79c545cacc8a56dbe1d063778117ba9b645323b0cb7fd054fae805d092b8372c411a82e3370244b7939bda20a65fdb951c WHIRLPOOL 67673788859ea99752f2e0d1d8c7feb40b004efc344a2a589553675be7f9020ed384cb4a9000bb7eee0059105af364a722f17890ea3f0d38508b8d045db7da75
DIST mongodb-src-r3.4.1.tar.gz 40161375 SHA256 54f475e553827733fb351ee4b03b470297f0d08e0434fbf7e6661705124da97b SHA512 48400f00ed84922b1e734ad915c376a567af2cd32e9cdcc40819fdfbc0a5c2444e4f325b1a541fc21cf87f4d95f9bdcc64bd59eab9d25e75b28732978feda031 WHIRLPOOL 1dce39c7b36b2c1d3760c7c560c1fefde9ea6d780ef1ef8b5db38f3ed8f0aff9a4ae51ab26381d9330c5b3ad3182ed998ae8e2a0ecc85e9347714ffa853d7734
DIST mongodb-src-r3.4.2.tar.gz 39796167 SHA256 29b60f6c5331fd2ff5242171a65c03e3b47c1ff957fa317bfaa2ddccd8d51b59 SHA512 42f1b946e4be22670a3d79ec5ea359c2c43f0cff6f6329486b2cc797fd57981982544fbce53412ab91eafa3a1fbecb30bc95316cc9405d778b20a270f77df777 WHIRLPOOL 25e512f455661c0e49bde559fb1662e98643e2078c3c1dd7f675524de467741db3091d3868e34c4e470232e1be7e37cf6f032a76d39afee2b673cb8a4c188798
190 changes: 190 additions & 0 deletions dev-db/mongodb/mongodb-3.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,190 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
SCONS_MIN_VERSION="2.3.0"
CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit eutils flag-o-matic multilib pax-utils scons-utils systemd toolchain-funcs user versionator check-reqs

MY_P=${PN}-src-r${PV/_rc/-rc}

DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
HOMEPAGE="http://www.mongodb.org"
SRC_URI="https://fastdl.mongodb.org/src/${MY_P}.tar.gz"

LICENSE="AGPL-3 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug kerberos libressl mms-agent ssl test +tools"

RDEPEND=">=app-arch/snappy-1.1.3
>=dev-cpp/yaml-cpp-0.5.3
>=dev-libs/boost-1.60[threads(+)]
>=dev-libs/libpcre-8.39[cxx]
dev-libs/snowball-stemmer
net-libs/libpcap
>=sys-libs/zlib-1.2.8
mms-agent? ( app-admin/mms-agent )
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.1g:0= )
libressl? ( dev-libs/libressl:0= )
)"
DEPEND="${RDEPEND}
>=sys-devel/gcc-5.3.0:*
sys-libs/ncurses
sys-libs/readline
debug? ( dev-util/valgrind )
kerberos? ( dev-libs/cyrus-sasl[kerberos] )
test? (
dev-python/pymongo
dev-python/pyyaml
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

S=${WORKDIR}/${MY_P}

pkg_pretend() {
if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
ewarn "To upgrade from a version earlier than the 3.0-series, you must"
ewarn "successively upgrade major releases until you have upgraded"
ewarn "to 3.2-series. Then upgrade to 3.4 series."
fi
}

pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

# Maintainer notes
#
# --use-system-tcmalloc is strongly NOT recommended:
# https://www.mongodb.org/about/contributors/tutorial/build-mongodb-from-source/

scons_opts=(
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"

--disable-warnings-as-errors
--use-system-boost
--use-system-pcre
--use-system-snappy
--use-system-stemmer
--use-system-yaml
--use-system-zlib
)

# wiredtiger not supported on 32bit platforms #572166
use x86 && scons_opts+=( --wiredtiger=off )

if use debug; then
scons_opts+=( --dbg=on )
fi

if use prefix; then
scons_opts+=(
--cpppath="${EPREFIX}/usr/include"
--libpath="${EPREFIX}/usr/$(get_libdir)"
)
fi

if use kerberos; then
scons_opts+=( --use-sasl-client )
fi

if use ssl; then
scons_opts+=( --ssl )
fi
}

src_prepare() {
epatch \
"${FILESDIR}/${PN}-3.4.0-fix-scons.patch"
if has_version ">=dev-libs/boost-1.62"; then
epatch "${FILESDIR}/${PN}-3.2.10-boost-1.62.patch"
fi
epatch_user
}

src_compile() {
# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
if ! use debug; then
filter-flags '-m*'
filter-flags '-O?'
fi
escons "${scons_opts[@]}" core tools
}

src_install() {
escons "${scons_opts[@]}" --nostrip install --prefix="${ED}"/usr

for x in /var/{lib,log}/${PN}; do
keepdir "${x}"
fowners mongodb:mongodb "${x}"
done

doman debian/mongo*.1
dodoc README docs/building.md

newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
newconfd "${FILESDIR}/${PN}.confd-r2" ${PN}
newinitd "${FILESDIR}/${PN/db/s}.initd-r2" ${PN/db/s}
newconfd "${FILESDIR}/${PN/db/s}.confd-r2" ${PN/db/s}

insinto /etc
newins "${FILESDIR}/${PN}.conf-r3" ${PN}.conf
newins "${FILESDIR}/${PN/db/s}.conf-r2" ${PN/db/s}.conf

systemd_dounit "${FILESDIR}/${PN}.service"

insinto /etc/logrotate.d/
newins "${FILESDIR}/${PN}.logrotate" ${PN}

# see bug #526114
pax-mark emr "${ED}"/usr/bin/{mongo,mongod,mongos}
}

pkg_preinst() {
# wrt bug #461466
if [[ "$(get_libdir)" == "lib64" ]]; then
rmdir "${ED}"/usr/lib/ &>/dev/null
fi
}

src_test() {
# this one test fails
rm jstests/core/repl_write_threads_start_param.js

./buildscripts/resmoke.py --dbpathPrefix=test --suites core || die "Tests failed"
}

pkg_postinst() {
local v
for v in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 3.0 ${v}; then
ewarn "!! IMPORTANT !!"
ewarn " "
ewarn "${PN} configuration files have changed !"
ewarn " "
ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
ewarn " "
ewarn "Make sure you also follow the upgrading process :"
ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
ewarn " "
ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
break
fi
done

ewarn "Make sure to read the release notes and follow the upgrade process:"
ewarn " https://docs.mongodb.org/manual/release-notes/3.4/"
ewarn " https://docs.mongodb.com/manual/release-notes/3.4/#upgrade-procedures"
}

0 comments on commit d95a150

Please sign in to comment.