Skip to content

Commit

Permalink
dev-python/google-apputils: fix tests
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6_p7, Repoman-2.3.2_p75
  • Loading branch information
floppym committed Jun 12, 2017
1 parent cebdfe3 commit d9618cc
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 0 deletions.
21 changes: 21 additions & 0 deletions dev-python/google-apputils/files/0.4.2-sh_test-env.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
Prevent the environment from being clobbered during sh_test

diff --git a/tests/sh_test.py b/tests/sh_test.py
index ab41055..d1b08c6 100644
--- a/tests/sh_test.py
+++ b/tests/sh_test.py
@@ -29,12 +29,8 @@ class ShellScriptTests(basetest.TestCase):
path_with_python = ':'.join((
os.path.dirname(sys.executable), os.environ.get('PATH')))

- env = {
- 'PATH': path_with_python,
- # Setuptools puts dependency eggs in our path, so propagate that.
- 'PYTHONPATH': os.pathsep.join(sys.path),
- 'TEST_TMPDIR': FLAGS.test_tmpdir,
- }
+ env = os.environ.copy()
+ env['TEST_TMPDIR'] = FLAGS.test_tmpdir
p = subprocess.Popen(sh_test_path, cwd=tests_path, env=env)
self.assertEqual(0, p.wait())

4 changes: 4 additions & 0 deletions dev-python/google-apputils/google-apputils-0.4.2-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -25,6 +25,10 @@ RDEPEND="
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"

PATCHES=(
"${FILESDIR}/0.4.2-sh_test-env.patch"
)

src_unpack() {
default
chmod -R a+rX,u+w,g-w,o-w ${P} || die
Expand Down

0 comments on commit d9618cc

Please sign in to comment.