forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/ranger: version bump to 1.8.1
- Loading branch information
Showing
3 changed files
with
40 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ranger-1.7.2.tar.gz 269713 SHA256 94f6e342daee4445f15db5a7440a11138487c49cc25da0c473bbf1b8978f5b79 SHA512 4815831bceb76bf15a68cdb09d3276192095b211ba06f0abeeec9529b0cb054341666c607f11b2c0acd1ff7de6fa3b71c9aab59db6bd5d1f0137e07619b522bd WHIRLPOOL 7985c470a789cd58a64d2e5e8eb7675ea4df8f71f0cac0bae7e49af599ab07d30a3ebe567e938649e69c812e8e2a4043e10004c708459a9a58b7c523fc34c6f3 | ||
DIST ranger-1.8.0.tar.gz 227368 SHA256 ce02476cb93d51b901eb6f5f0fc9675c58bd0a2f11d2ce0cdb667e15ec314092 SHA512 dd630c8aaca479925bc48982a2fab7c6f8999512985e37f0d7c5906ec1f8ed4b7b59fb0320dee5abf8ab7513a6f58528cdf64eaf8ca8d4528260cfba5916af40 WHIRLPOOL 54d8e9e0efaec5feae5c7d34adeb5d6880076ae2dfedb2cd26e5cdd2c593e7b3cc6e6089436ef44fd39fd4574a0d79a45661621bce0d508bbe317ec718c562cd | ||
DIST ranger-1.8.1.tar.gz 227415 SHA256 1433f9f9958b104c97d4b23ab77a2ac37d3f98b826437b941052a55c01c721b4 SHA512 40450d4e80017ac62d60ea6de231c10496fec1680f15a14006d3b87aae7f34cb2dbb6b810ced89527a4cba2975dcd6c037217e86fa806a0ba3cd39dc7dee8f04 WHIRLPOOL 29c6613befff82e883b9dcdf04f789338992d79a5cd6dcee46b19c21e80bd61b6de89567794d60c42696a4e7ed599e3606dfa9460558432a10169a2201a4e937 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
PYTHON_REQ_USE="ncurses" | ||
|
||
inherit distutils-r1 | ||
|
||
if [[ ${PV} == "9999" ]] ; then | ||
EGIT_REPO_URI="git://git.savannah.nongnu.org/ranger.git" | ||
inherit git-r3 | ||
else | ||
SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
fi | ||
|
||
DESCRIPTION="A vim-inspired file manager for the console" | ||
HOMEPAGE="http://ranger.nongnu.org/" | ||
LICENSE="GPL-3" | ||
SLOT="0" | ||
|
||
RDEPEND="virtual/pager" | ||
|
||
src_prepare() { | ||
# use versioned doc path | ||
sed -i "s|share/doc/ranger|share/doc/${PF}|" setup.py doc/ranger.1 || die | ||
|
||
distutils-r1_src_prepare | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ -z ${REPLACING_VERSIONS} ]]; then | ||
elog "Ranger has many optional dependencies to support enhanced file previews." | ||
elog "See the README or homepage for more details." | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters