Skip to content

Commit

Permalink
Merge remote-tracking branch 'remotes/Coacher/mccabe-fixes'
Browse files Browse the repository at this point in the history
Pull request: gentoo#886
  • Loading branch information
Ian Delaney committed Feb 20, 2016
2 parents e2d3f36 + c14ae8b commit d989528
Show file tree
Hide file tree
Showing 2 changed files with 12 additions and 10 deletions.
20 changes: 11 additions & 9 deletions dev-python/mccabe/mccabe-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,29 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} )

RESTRICT="test"

inherit distutils-r1

DESCRIPTION="a plugin for flake8"
HOMEPAGE="https://github.com/flintwork/mccabe"
DESCRIPTION="flake8 plugin: McCabe complexity checker"
HOMEPAGE="https://github.com/PyCQA/mccabe"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
LICENSE="MIT"
SLOT="0"

RDEPEND=">=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]
dev-python/flake8[${PYTHON_USEDEP}]"
RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]"
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

src_prepare() {
sed -i -e '/pytest-runner/d' setup.py || die
distutils-r1_src_prepare
}

python_test() {
${EPYTHON} test_mccabe.py || die
py.test -v || die "Testing failed with ${EPYTHON}"
}
2 changes: 1 addition & 1 deletion dev-python/mccabe/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">mccabe</remote-id>
<remote-id type="github">flintwork/mccabe</remote-id>
<remote-id type="github">PyCQA/mccabe</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit d989528

Please sign in to comment.