forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/sdl-gfx: Bump to version 2.0.26
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Lars Wendler
committed
Feb 24, 2017
1 parent
4d17eb2
commit d98a497
Showing
2 changed files
with
51 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST SDL_gfx-2.0.25.tar.gz 1760656 SHA256 556eedc06b6cf29eb495b6d27f2dcc51bf909ad82389ba2fa7bdc4dec89059c0 SHA512 42a5d78fe1a9b644d329fb688ed6c98558f8dd0aa029a1a0d99b1c59f94859269e0aef8f9e420b8018b687d8eae151652890be3994775644e1d3a80ba7b6fe8c WHIRLPOOL f3cac6a16c1fe1bcc8a09d5438cca8737ee571030524381804969c89d97ee4fd78e36625616932d4985504fc7689d765455d90a47692c9097119094612f72c9c | ||
DIST SDL_gfx-2.0.26.tar.gz 1771164 SHA256 7ceb4ffb6fc63ffba5f1290572db43d74386cd0781c123bc912da50d34945446 SHA512 e571caa0d7575683efd4cf8f0a41ab10f4acf913f9ece216ac823af11da22c8734fc2c0ea049009a3e1a53715e49622f5bfcfdbdafb95e5151990d0a4eb69c01 WHIRLPOOL 774cb98be5ed3b144cb843b6b6afaab7ad30ba20edfb3523be9ef03247ce2dd9e6de47a2e9615b4977920597468cdb95fdf79a6016467582697e5500a775a64f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit autotools multilib-minimal | ||
|
||
MY_P="${P/sdl-/SDL_}" | ||
DESCRIPTION="Graphics drawing primitives library for SDL" | ||
HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/" | ||
SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz" | ||
|
||
LICENSE="ZLIB" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris" | ||
IUSE="doc cpu_flags_x86_mmx static-libs" | ||
|
||
RDEPEND=">=media-libs/libsdl-1.2.15-r4[video,${MULTILIB_USEDEP}]" | ||
DEPEND="${RDEPEND}" | ||
|
||
DOCS=( AUTHORS ChangeLog README ) | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e 's/-O //' configure.in || die | ||
mv configure.in configure.ac || die | ||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" econf \ | ||
--disable-dependency-tracking \ | ||
$(use_enable cpu_flags_x86_mmx mmx) \ | ||
$(use_enable static-libs static) | ||
} | ||
|
||
#multilib_src_install() { | ||
# emake DESTDIR="${D}" install | ||
#} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
if use doc ; then | ||
docinto html | ||
dodoc -r Docs/* | ||
fi | ||
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die | ||
} |