Skip to content

Commit

Permalink
dev-python/warlock: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Mar 2, 2016
1 parent 8345177 commit d9a1530
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/warlock/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST warlock-1.0.1.tar.gz 4192 SHA256 986ccfd647f89c1c8e7ebe40d159e5633818a58754b3ffdf51c4816927977791 SHA512 7ca4b512efa9f3b112682b5120618b14616d3d7307891004aedbe6b88d66d5baaff5c02b9dfe78ea845cdc2498668f81c9dfc6a22fedab7916f49947dd3706c6 WHIRLPOOL a1e556668ca5a2589832fa177ea3260c50efc3a07924ad6ba830318985be8f8e6e70a6f24ed130e7d7d181b3060720f54eeff22bf709aee537c028d6a1d03f83
DIST warlock-1.1.0.tar.gz 7879 SHA256 bbfb4279034ccc402723e38d2a2e67cd619988bf4802fda7ba3e8fab15762651 SHA512 57353cb21ee7245cb27f29193d8c0987971535f1bc9f7a8914738ec15cd5712cf7001eae379041c0188e489365f23b0190dc13799b57a117b0bd3ed62cc2e30a WHIRLPOOL e2e258a38770c2c2f823d343ffe8b8a75bb7e89c0bc2b5dbe1e174cd06527eaca84e3e1c90ace11acd766c87408f448c563f2cfed8740239dd0bfeac66740698
DIST warlock-1.2.0.tar.gz 8210 SHA256 7c0d17891e14cf77e13a598edecc9f4682a5bc8a219dc84c139c5ba02789ef5a SHA512 775362a80be7ab37d3a856947cc930e6be74d2b86e59ce44c9e24e54e111288dddae17f7d8b8885ea3d4cfa5674d327149d725a3acf4fc7bb48b2f63f5db63dd WHIRLPOOL d6be7dce7de0e60042600bbd1f3faec0180fa57f14e4eb3d3c218563ca2099c87831bf29ac456b627abd2da91b5c1198061a1568f3a0a781fdfad42ce10c0275
33 changes: 33 additions & 0 deletions dev-python/warlock/warlock-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python{3_3,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="Python object model built on JSON schema and JSON patch"
HOMEPAGE="https://github.com/bcwaldon/warlock"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/six[${PYTHON_USEDEP}]
>=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
<dev-python/jsonpatch-2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
<dev-python/jsonschema-3[${PYTHON_USEDEP}] )"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]
>=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
<dev-python/jsonpatch-2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
<dev-python/jsonschema-3[${PYTHON_USEDEP}]"

python_test() {
"${PYTHON}" test/test_core.py || die
}

0 comments on commit d9a1530

Please sign in to comment.