Skip to content

Commit

Permalink
dev-php/composer: bump to v1.10.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Aug 6, 2020
1 parent 9388c6e commit d9abd0e
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/composer/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST composer-1.10.1.tar.gz 421852 BLAKE2B a40f59ab0af5eba777f1926bab78e55fd1973e53b324eec73fdca70678fc1cfe6f892790a61a66dbdbe07caa03343bfd109318daec99c2c18707785c6bf149e0 SHA512 ebc3ee48bf0d2597e7221e9ac0ab7188e7a99096d5dacdee4176b4c7b4d252d079c117b5bd9131ff38d8963f95930fa9c83fa51ed542d4f7d58276561de1f2b8
DIST composer-1.10.10.tar.gz 426836 BLAKE2B 46266e0338e4bad201d6f025ffb3ae6a4441543cb6aeec27502e43127cb6e109a2824960f774d2996b231e469639a6fa6f58f831e82f6a7313364049ddb626e7 SHA512 a859026dc2b6dc5f3bf8a03f305b7eb59339bc13148036c3b23c24a1136cc53c50217277d8877987e441e3de80d97d771d014f2a60e76bb09513827be2ce71e7
DIST composer-1.10.5.tar.gz 423065 BLAKE2B 0c8595f3583a692f89294455984aeff2ad9cbf2a39541355cbb736e717baacae8245fa81e6b9fde11dd5bb56ad3a074262f6f8ecb65b4bef9c782ef39887deec SHA512 cdadb2d146afcc140316b83d3b4f4c018d79e8222f6a6207cdd52db75ae9c78e787a509d88a3fe113f8218df2ace56ba2dd043e1b6e6c3dbb5129fd51d8e9925
DIST composer-1.10.6.tar.gz 423789 BLAKE2B 74d93e769c660f2c74e0ad5dd3ed5e5279c217552eb6d342ffd43d7fba10647865ade7b284c811f63504e0335e5655eae681cf14ae4d876eb56ff6a306c61268 SHA512 fdc209a82d3adda2728190282327b02d2b71bb9b1a80cbcda3699a826ee56451c997edac13d76e2784ebd4297d413bd46dd47b9538accd4bfe6c569464696779
DIST composer-1.10.7.tar.gz 424264 BLAKE2B 9939e4d1f29071ca4467076c13e0ceab32d10282876ebb0a76f41dd3efbd9c40a50dbf278dd0a12b2119d40ff9424c171f07381fbaadb94218b1fdf69f403fdb SHA512 81ece3314cddced101b0be491e40b60d42ef503cef4b1d5598c32f3378f10524004a7a8ef4360453a4cdaaf9d3b986ce07696de075dc424deae7703945f6d577
Expand Down
48 changes: 48 additions & 0 deletions dev-php/composer/composer-1.10.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Dependency Manager for PHP"
HOMEPAGE="https://github.com/composer/composer"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-lang/php:*[curl]
>=dev-php/ca-bundle-1.1.3
>=dev-php/psr-log-1.1.0
dev-php/fedora-autoloader
>=dev-php/json-schema-5.2.7
>=dev-php/jsonlint-1.7.1
>=dev-php/phar-utils-1.0.1
>=dev-php/semver-1.4.2
>=dev-php/spdx-licenses-1.5.0
>=dev-php/symfony-console-2.8.48
>=dev-php/symfony-filesystem-2.8.48
>=dev-php/symfony-finder-2.8.49
>=dev-php/symfony-process-2.8.48
>=dev-php/xdebug-handler-1.3.1"

src_install() {
insinto "/usr/share/${PN}"

# Composer expects the LICENSE file to be there, and the
# easiest thing to do is to give it what it wants.
doins -r src res LICENSE

insinto "/usr/share/${PN}/vendor"
newins "${FILESDIR}"/autoload-r1.php autoload.php

exeinto "/usr/share/${PN}/bin"
doexe "bin/${PN}"
dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"

dodoc CHANGELOG.md README.md doc/*.md
dodoc -r doc/articles doc/faqs
}

0 comments on commit d9abd0e

Please sign in to comment.