Skip to content

Commit

Permalink
dev-ml/ocaml-cstruct: bump to 1.8.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Feb 10, 2016
1 parent 2ef6bb2 commit d9b5872
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/ocaml-cstruct/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ocaml-cstruct-1.7.1.tar.gz 245894 SHA256 7869d096fe7c6231bbceefe3b2205417b28b6c10f4174b7e2cfdfa46956eaaa5 SHA512 67dd276ab2f895ef80cc7ba5b48d51bcfcf52ac49aa29cd4b17aa00be109198347a50229b81fbe506d831ace753d72f3b4bb80f19e8e57fa29d9ba65da472f19 WHIRLPOOL 8145930a1dcadbcf48c1da0dcba10a45f3d52c8ae2565aee7e609bd3eeb5eead9cee9ef423332a580ab77ceabb2f301917226d1a73e1b7f6efc7a3096c4112d6
DIST ocaml-cstruct-1.8.0.tar.gz 250696 SHA256 e1635072283ae5db7889966ce92e916749bcd192012a0c46285827beba1263d7 SHA512 38ea6301b48603f8b63c73a7aa42312d25bbd16fb8524e1de2b69a54e45e9e1c1326201e19fcf2953d2719607139c903d76296a32fb7058998c079ac112adc9c WHIRLPOOL 6fdabfc1143331662757826de11c62c3947fb59155ba68e866a2f9939963deacd52d5832417997833deff9a9ff902675d266a98b41e0d2cf9f29c4d4c628601e
1 change: 1 addition & 0 deletions dev-ml/ocaml-cstruct/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,7 @@
<flag name="async">Support for asynchronous execution</flag>
<flag name="camlp4">Enable support for camlp4</flag>
<flag name="lwt">Enable threads via lwt</flag>
<flag name="ppx">Enable the ppx syntax extension</flag>
</use>
<upstream>
<remote-id type="github">mirage/ocaml-cstruct</remote-id>
Expand Down
45 changes: 45 additions & 0 deletions dev-ml/ocaml-cstruct/ocaml-cstruct-1.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
OASIS_BUILD_DOCS=1
OASIS_BUILD_TESTS=1

inherit oasis

DESCRIPTION="Map OCaml arrays onto C-like structs"
HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="async +camlp4 +lwt +ppx"

RDEPEND="
async? ( dev-ml/async:= )
camlp4? ( dev-ml/camlp4:= )
lwt? ( dev-ml/lwt:= )
ppx? ( dev-ml/ppx_tools:= )
>=dev-lang/ocaml-4.01:=
dev-ml/ocplib-endian:=
dev-ml/sexplib:=
dev-ml/type-conv:=
"
DEPEND="
test? ( dev-ml/ounit )
${RDEPEND}
"

src_configure() {
oasis_configure_opts="
$(use_enable lwt)
$(use_enable camlp4)
$(use_enable async)
$(use_enable ppx)
--enable-unix
" oasis_src_configure
}

DOCS=( CHANGES README.md TODO.md )

0 comments on commit d9b5872

Please sign in to comment.