Skip to content

Commit

Permalink
x11-libs/libva: bump to 1.7.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
aballier committed Sep 6, 2016
1 parent 58fd5dc commit d9ca312
Show file tree
Hide file tree
Showing 2 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-libs/libva/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libva-1.6.2.tar.bz2 787002 SHA256 c417f09cdeef549e54f4be5f9876026513afeac395c5be28750b431d848c8bd0 SHA512 7e69c44cc1aaa94f0a9e8662ac10974b9e5ab2b29cb2b230370ef1449d8926ea4d4571593c6fa78c6601da4322716c7ab3d1ff42e889252c4769cc267bdc04be WHIRLPOOL e74193d0d31c1be4229b58058064e2e743aeb729e3daef045c7882e8f317c9ccccad9d74bbbea8144c6706a8793052f77acb1d3fcd6488e679be1e97a4a113f4
DIST libva-1.7.0.tar.bz2 788519 SHA256 a689bccbcc81a66b458e448377f108c057d3eee44a2e21a23c92c549dc8bc95f SHA512 b6b5317e875c9a4e17ec4f8d37383edf83a479aa4d9fa85bcf7debecae40efc56506905a0eefcc695364543436b3d80ed007eb45c6161fae01ee979ed82a3ca0 WHIRLPOOL 6d92c658c72575150f05bf30070a5af75ee6aed6804939c888062ac245cbefc51cf099c04ab45794ad2b1e8eb52b4ca35a9b89513c27bbf03310cdd9f5d46311
DIST libva-1.7.1.tar.bz2 801086 SHA256 480023cc55f254f371eb8683ea0563fe6f3ab36db6ce91c1b8d0a999ee5815c9 SHA512 6d0a1b3f7e23e2ab3dcd1e255d82912cce60bc29a58df4ce7c1e53dfbcd33cc8236f7185369ab31f181995ae8b5d706112c908efbc9eba4c3201e529d4379dbe WHIRLPOOL 5ee21e2ac603bb1675f6d22abb7223da4a1cbc43dc4ee6d720cfccfa2e69751d84983368eaacaa56e992c9e550fa85ecfbb054580a1a6038df8adc1fc614a633
DIST libva-1.7.2.tar.bz2 803515 SHA256 5dd61cf16a5648b680e6146a58064e93be11bf4e65a9e4e30f1e9cb8ecfa2c13 SHA512 4a1da09416361b69813a6fa77ee1de3d546eb1bb0d8beb7933f2c00cf9fbb8ab4e74019fa432239ee618282fdc42cb1f7f1ae2781c1d851e461994288b888a10 WHIRLPOOL eba4ec3f2c5a2eff26f39787bcdf27fea655f910360629f00c7d36690669307c4a7bbbb98a338f4ceb6a4c0aa6b8c4b3105724544af1c36d6d31468c4d1541e7
86 changes: 86 additions & 0 deletions x11-libs/libva/libva-1.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

SCM=""
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SCM=git-2
EGIT_BRANCH=master
EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/libva"
fi

AUTOTOOLS_AUTORECONF="yes"
inherit autotools-multilib ${SCM} multilib

DESCRIPTION="Video Acceleration (VA) API for Linux"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/vaapi"
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SRC_URI=""
S="${WORKDIR}/${PN}"
else
SRC_URI="https://www.freedesktop.org/software/vaapi/releases/libva/${P}.tar.bz2"
fi

LICENSE="MIT"
SLOT="0"
if [ "${PV%9999}" = "${PV}" ] ; then
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
else
KEYWORDS=""
fi
IUSE="+drm egl opengl vdpau wayland X"

VIDEO_CARDS="dummy nvidia intel fglrx nouveau"
for x in ${VIDEO_CARDS}; do
IUSE+=" video_cards_${x}"
done

RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
X? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
)
egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )"

DEPEND="${RDEPEND}
virtual/pkgconfig"
PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
video_cards_nouveau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r3[${MULTILIB_USEDEP}] )
vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
video_cards_fglrx? (
|| ( >=x11-drivers/ati-drivers-14.12-r3[${MULTILIB_USEDEP}]
>=x11-libs/xvba-video-0.8.0-r1[${MULTILIB_USEDEP}] )
)
video_cards_intel? ( >=x11-libs/libva-intel-driver-1.2.2-r1[${MULTILIB_USEDEP}] )
"

REQUIRED_USE="|| ( drm wayland X )
opengl? ( X )"

DOCS=( NEWS )

MULTILIB_WRAPPED_HEADERS=(
/usr/include/va/va_backend_glx.h
/usr/include/va/va_x11.h
/usr/include/va/va_dri2.h
/usr/include/va/va_dricommon.h
/usr/include/va/va_glx.h
)

multilib_src_configure() {
local myeconfargs=(
--with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
$(use_enable video_cards_dummy dummy-driver)
$(use_enable opengl glx)
$(use_enable X x11)
$(use_enable wayland)
$(use_enable egl)
$(use_enable drm)
)
autotools-utils_src_configure
}

0 comments on commit d9ca312

Please sign in to comment.