forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/oneVPL-intel-gpu: add 23.1.3
Signed-off-by: Andrew Ammerlaan <[email protected]>
- Loading branch information
1 parent
40a69c1
commit da00636
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST oneVPL-intel-gpu-22.6.5.tar.gz 6836805 BLAKE2B 73c2f0a7ec0f0712db737cbaee7c62d9801ebca3b75185bc35156922d04da1076015fcf9491be4ebe4cd2d5c87c90903d818a012d4af5c5393f298bd06fad200 SHA512 505bfc0235748fc4a3ee9229e5ffdb815212427266238dbaf0463565ec415c9c767247b6a1c6c10e479da186b834e5df114798a8e84d7b97873d1d97748e9bb5 | ||
DIST oneVPL-intel-gpu-23.1.2.tar.gz 6974931 BLAKE2B 82c3b0cf92f57d7dd4c46f51d27450b53bd9816786f45999bca41ac628c7f293708772580c4a01467519b02f67181203a28eba03e4e85846f993886898b75af9 SHA512 2053e5ec0560a93ae0bcf3d5d0269807d7925eb5b76cc32fc34d157b900c227a74584cd6f84bdcd653f70e0d3f068f5cb6e891a892e71caef5bb9b146a5571cd | ||
DIST oneVPL-intel-gpu-23.1.3.tar.gz 6976927 BLAKE2B a338ca7a088c8171a8b0c8fd4de09fb07c5272f9c50c8389aa6442f5368e88f9e012bf9f4c6d49e6a094f615366c84dcddca760cc144ea99204627198e0d4a6f SHA512 c01a32a4aa3988d105cee463e40bb59f834d926f8e67a3fff83dfb4e6f0e2690e845ad179e6bbc31e12528c35d422403706064152a387d36af8939b7168ab7be |
46 changes: 46 additions & 0 deletions
46
media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-23.1.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 2022-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="oneAPI Video Processing Library Intel GPU implementation" | ||
HOMEPAGE="https://github.com/oneapi-src/oneVPL-intel-gpu" | ||
SRC_URI="https://github.com/oneapi-src/oneVPL-intel-gpu/archive/refs/tags/intel-onevpl-${PV}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/${PN}-intel-onevpl-${PV}" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
DEPEND=" | ||
media-libs/libva | ||
x11-libs/libdrm[video_cards_intel] | ||
" | ||
# At runtime we need a dispatcher, oneVPL is preferred but mediasdk also works | ||
RDEPEND="${DEPEND} | ||
>=media-libs/libva-intel-media-driver-${PV} | ||
|| ( | ||
media-libs/oneVPL[drm,vaapi] | ||
media-libs/intel-mediasdk | ||
) | ||
" | ||
BDEPEND="virtual/pkgconfig" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_RUNTIME=ON | ||
# To build the kernels we need to package the cm-compiler, use pre-built instead | ||
-DBUILD_KERNELS=OFF | ||
-DBUILD_TESTS="$(usex test)" | ||
# This only seems to do something if we BUILD_KERNELS=ON | ||
#-DBUILD_TOOLS="$(usex tools)" | ||
# OpenCL only has an effect if we build kernels | ||
-DENABLE_OPENCL=OFF | ||
) | ||
cmake_src_configure | ||
} |