Skip to content

Commit

Permalink
dev-libs/ell: Install docs.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/662080
Package-Manager: Portage-2.3.43, Repoman-2.3.10
  • Loading branch information
Lars Wendler committed Jul 25, 2018
1 parent 5c9f1cb commit da01c64
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions dev-libs/ell/ell-0.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit multilib-minimal

DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
HOMEPAGE="https://01.org/ell"
SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"

KEYWORDS="~amd64 ~x86"
IUSE="glib pie"

RDEPEND="
glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"

multilib_src_configure() {
local myeconfargs=(
$(use_enable glib)
$(use_enable pie)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_install_all() {
local DOCS=( ChangeLog README )
einstalldocs

find "${ED}" -name "*.la" -delete || die
}

0 comments on commit da01c64

Please sign in to comment.