Skip to content

Commit

Permalink
dev-db/timescaledb: add 2.10.3
Browse files Browse the repository at this point in the history
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Apr 29, 2023
1 parent 4c831f9 commit da03123
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/timescaledb/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST timescaledb-2.10.0.tar.gz 7410903 BLAKE2B e93117f41b918e315f1d867ef65a608ec4021d365e3854750ee788233d64435d37b6ff5e7b1a014c8bf095857c745978daece3dc5ff149ba0b869afa6e7d8e7c SHA512 6028146a421de91a356539d8027cfee8dc38dd03cf02fe04887ddaf134fa057c953cf6b6179a9160d797271943a8fe35ffe2f4d8959fe3be8e7bf527a3fe7d41
DIST timescaledb-2.10.1.tar.gz 7417084 BLAKE2B 506da755d164fd82bbea0267a24f6db438b895402c29bb88b5f48178b018c003f251427b5fa9befcfe801db496181819ef18249e537bd89b72a085f51291ce19 SHA512 573369d85f40a4176beaf5862bd0d20966fbdff83ec8573ba185bcfd90a03ef8de09aad3ed8dce7ee47bc123f967224bae2899c22ed023ab73260c3bd0548fed
DIST timescaledb-2.10.3.tar.gz 7465897 BLAKE2B 2a70e281738fac63cd3b5c753f82a7e8faf162c015ad87b1cb3b24558d70e042bb16281b32a931fbb4daae280bede40bc239de8e8b3228c2571da33d4e5975ec SHA512 c94227d9aa1df36634bbf2626f580165860cab543efbfeb448f9799cf70ef6c1891af0077c2280ae22dbfb2360cf2b6012e7f05c26b0cf7aef6eb217c583b444
DIST timescaledb-2.9.2.tar.gz 7265748 BLAKE2B 6d821f3e93e5a4c8cb871e436b00f81befbc82b171c95c50f93d278c2dd87c44255c4fc7b6e09e7463eeb8b3ba6719ad95d07d76d2234a52f7f0ca015a1ed727 SHA512 2f8153e37e3fd1488f89398dfb6b4501267c0d4bae4b796738d0b25e26f9720c7d6388b41fd952b4760f9e85adfbf6d3b37f4f5b7cc9ec3e68825dbd9868e870
DIST timescaledb-2.9.3.tar.gz 7269123 BLAKE2B 009f3b9787e4dce49abb50a446b88f5a37ab9b1a3abb040fe5d332ab10d5a40e13fae7985fca6f6d412f7e555ab1833f83ce0c43bbda7054f668fa12288eac18 SHA512 0664ccc6e6846500757466646e2c8a9bdbdca079bd931cc95ad8ea687f37b099d846cf8cc8311f928a33d9228592e460b6fe331a639046bc845a25b4a7d914c6
67 changes: 67 additions & 0 deletions dev-db/timescaledb/timescaledb-2.10.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

POSTGRES_COMPAT=( 12 13 14 15 )
POSTGRES_USEDEP="ssl"

inherit postgres-multi cmake

DESCRIPTION="Open-source time-series SQL database"
HOMEPAGE="https://www.timescale.com/"
SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

IUSE="proprietary-extensions"
LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"

KEYWORDS="~amd64"

SLOT=0

RESTRICT="test"

DEPEND="${POSTGRES_DEP}"
RDEPEND="${DEPEND}"

CMAKE_IN_SOURCE_BUILD=yes
CMAKE_BUILD_TYPE="RelWithDebInfo"
BUILD_DIR=${WORKDIR}/${P}

src_prepare() {
postgres-multi_src_prepare
postgres-multi_foreach cmake_src_prepare
}

timescale_configure() {
local CMAKE_USE_DIR=$BUILD_DIR
local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )

# licensing is tied to features, this useflag disables the non-apache2 licensed bits
if ! use proprietary-extensions ; then
mycmakeargs+=("-DAPACHE_ONLY=ON")
fi
cmake_src_configure
}

src_configure() {
postgres-multi_foreach timescale_configure
}

timescale_src_compile() {
local CMAKE_USE_DIR=$BUILD_DIR
cmake_src_compile
}

src_compile() {
postgres-multi_foreach timescale_src_compile
}

timescale_src_install() {
local CMAKE_USE_DIR=$BUILD_DIR
cmake_src_install
}

src_install() {
postgres-multi_foreach timescale_src_install
}

0 comments on commit da03123

Please sign in to comment.