Skip to content

Commit

Permalink
dev-lisp/clozurecl: bump to 1.12.2
Browse files Browse the repository at this point in the history
Signed-off-by: Andrey Grozin <[email protected]>
  • Loading branch information
Andrey Grozin committed Aug 9, 2023
1 parent 92bc45e commit da1753a
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 1 deletion.
4 changes: 3 additions & 1 deletion dev-lisp/clozurecl/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,4 +7,6 @@ DIST ccl-1.12-linuxx86.tar.gz 20878539 BLAKE2B 474b8ff10131ba50b208060aa8f822361
DIST ccl-1.12-solarisx86.tar.gz 16902471 BLAKE2B 640eeb6f4673d3d2e824c0726e935c391961d70be4360476cba41af79864a60dbcf9769a6ef2938c5363fd7107c5f058e85b31cca5deb45c9c134f48540816ba SHA512 aa5ce2186ebd8093d21e71907ee0b4d33fc6d4ced456fbec4aa2f3434943df1ad5b3d5473a5d626e26b24607b9c6cfe03cb1c0ec14eeb1347df79f9136c756b5
DIST ccl-1.12.1-darwinx86.tar.gz 23931965 BLAKE2B e7d010ccce860fef9508e6d0f389ab0cdb805045f380366d1384a0714c1c49ce829c97be5b1c2c6c6cfbc912799fc955b12cfd3b851982b06f4708c2da49dabb SHA512 b601d7503808589ea05edc196c5e6b14521b1e8afa3aaf8dd9955c5bc30f796a2a07ba3321a326612efa99715a230109c9748524cf68778391ca9b16679b51d7
DIST ccl-1.12.1-linuxx86.tar.gz 20872508 BLAKE2B b8f582334a7a7654666388061c2952a51a2b94dd3885b35e5e938dd3f4bb270db351bb194523d7192611784722a10a8d846290de3aa74c492f00915ef1e327c8 SHA512 7a4ab6bbb11e1ed3a13512f03626d21b6e97ea8e1f4e34647272fab24ea37c8e54b5471f9f20ad1fffacadb9825ec3b79e72fa9d27c426e01eac7bd3601e62c8
DIST ccl.html 962003 BLAKE2B fc95ec5abbea7c2f5f247293691a5c5a7eddaa049156c38766ec9df4d1920fdee902c89db976cc6687535aef5ddda3c672b62156bf0f61b6369ade548dcb0141 SHA512 0cb9ee8f7eb6007e08241a0797519ff3bfc3d3adc0b5ac86e6a2e9e8b2e316fc421bea3b04159decc0a2b37ff7098147e25266946cc3c1ac367b93e4821a8b64
DIST ccl-1.12.2-darwinx86.tar.gz 23942873 BLAKE2B 980403852c086c49ed467d391fbcf776b32c9c8cf3352ce71249ccd3cb0548904421ebd20512abef77b888de4a102a0fb19d1117c8a2dd14c3b618feea205f63 SHA512 96ac720ea1f210a89b17ad2a617f55bb04bece3c06bb2433191dab99886a2ad3529716e35624bd4b0d4c9eec2e9ccd80c0d894b75766ac1e361185cd7dfe3e92
DIST ccl-1.12.2-linuxx86.tar.gz 20997426 BLAKE2B 7bc9037b85964be6363f3082af6abf18d519e9a155edd34f4de495aedb5bfec8f43e4403b3b3bcece17c64bb7a381163bbaa03e1d2b9db9aee0a53deef537cf1 SHA512 4cf6960e41347ae980f8ea7366434a016e2a47a9ae090a77e52a2145233454cc97cd4812851d0368024548c46aa0997abb2791992125b5857a9f5f662890338b
DIST ccl.html 962023 BLAKE2B 6dcda62b4d18e83b3b73d554a4dd4255411944831e99464e20c9840f97bccd1bdf74b1d718620b2f6aa5e4f297e1925dbd3da6c48a5977b517caa194f62a37d4 SHA512 536ae7d858846b20bc9cee52292549ff3c2dd28565fcb3a7a1bf706d4f59799e83389d9ea0e73f943f815515c6bc3aa33222d8afde362bc503786b09eb784230
81 changes: 81 additions & 0 deletions dev-lisp/clozurecl/clozurecl-1.12.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs vcs-clean

MY_PN=ccl
MY_P=${MY_PN}-${PV}

DESCRIPTION="Common Lisp implementation, derived from Digitool's MCL product"
HOMEPAGE="https://ccl.clozure.com"
SRC_URI="
x86? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-linuxx86.tar.gz )
amd64? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-linuxx86.tar.gz )
x64-macos? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-darwinx86.tar.gz )
doc? ( https://ccl.clozure.com/docs/ccl.html )"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="doc"

RDEPEND=">=dev-lisp/asdf-2.33-r3:="
DEPEND="${RDEPEND}"

S="${WORKDIR}"/${MY_PN}
ENVD="${T}/50ccl"

src_prepare() {
default
cp "${EPREFIX}/usr/share/common-lisp/source/asdf/build/asdf.lisp" tools/ || die
}

src_configure() {
if use x64-macos; then
CCL_RUNTIME=dx86cl64; CCL_HEADERS=darwin-x86-headers64; CCL_KERNEL=darwinx8664
elif use x86; then
CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers; CCL_KERNEL=linuxx8632
elif use amd64; then
CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64; CCL_KERNEL=linuxx8664
fi
}

src_compile() {
emake -C lisp-kernel/${CCL_KERNEL} clean
emake -C lisp-kernel/${CCL_KERNEL} all CC="$(tc-getCC)"

unset CCL_DEFAULT_DIRECTORY
./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"

# remove non-owner write permissions on the full-image
chmod go-w ${CCL_RUNTIME}{,.image} || die

esvn_clean
}

src_install() {
local target_dir="/usr/$(get_libdir)/${PN}"
local prefix_dir="${EPREFIX}/${target_dir#/}"

mkdir -p "${D}/${prefix_dir#/}"

find . -type f -name '*fsl' -delete || die
rm -f lisp-kernel/${CCL_KERNEL}/*.o || die
cp -a compiler level-0 level-1 lib library lisp-kernel scripts \
tools xdump ${CCL_HEADERS} ${CCL_RUNTIME} ${CCL_RUNTIME}.image \
"${D}/${prefix_dir#/}" || die

echo "CCL_DEFAULT_DIRECTORY=${prefix_dir}" > "${ENVD}"
doenvd "${ENVD}"

dosym "${target_dir}/${CCL_RUNTIME}" /usr/bin/ccl
dodoc doc/release-notes.txt

if use doc ; then
dodoc "${DISTDIR}/ccl.html"
dodoc -r doc/manual
dodoc -r examples
fi
}

0 comments on commit da1753a

Please sign in to comment.