Skip to content

Commit

Permalink
dev-python/pynacl: Ensure that the bundled libsodium is never used
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
klausman committed Dec 6, 2016
1 parent cdbaffd commit da3ac2f
Showing 1 changed file with 37 additions and 0 deletions.
37 changes: 37 additions & 0 deletions dev-python/pynacl/pynacl-1.0.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5})

inherit distutils-r1

MY_PN="PyNaCl"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.python.org/pypi/PyNaCl/"
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

RDEPEND="dev-python/six[${PYTHON_USEDEP}]
>=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
dev-libs/libsodium:0/18
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}] )
"

S=${WORKDIR}/${MY_P}

src_prepare() {
# For not using the bundled libsodium
export SODIUM_INSTALL=system
distutils-r1_python_prepare_all
}

0 comments on commit da3ac2f

Please sign in to comment.