Skip to content

Commit

Permalink
dev-python/hypothesis: Bump to 5.23.12
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 10, 2020
1 parent 32755f0 commit da3dc03
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/hypothesis/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
DIST hypothesis-python-5.16.3.tar.gz 9011952 BLAKE2B d74a68c4ee1e5aacf4be1da5a4656011b0a15f990106c21298101d36e9a097c5dfd165987ad90a45f3a0b74375c4da609cd750f618242b94f34e03b6de0ee866 SHA512 912d984995d4ad8f06e98eb2cc327629328990fc1c072527ce261b637e16622acaf4d0d93928f9dd2d6601ab78f69aa6cf129d5cd7c1c00e50754ebc06957df0
DIST hypothesis-python-5.21.0.tar.gz 9025422 BLAKE2B acd6f3b0f945ae65656af2a718add06fe440e221fda7793e3557ab194ccee4c6327e7946a58ce51e9efe3c08274888a648d9021c49fdcf663a04c28b99a0f636 SHA512 1921e5ea8d0f2a6e55d80611004d35671f7a7a02cb8a8f101b45e64e4ef23f9c2c8a9c467fb6c9f33ae440622020e1ad504f51a7d725a6449ca715ad1f373e40
DIST hypothesis-python-5.23.12.tar.gz 9040323 BLAKE2B 2cef5fd59419ad7522693f543bfecb1a829158ee07a3d31ab023f08ccc10f97c5e24dc14daee2d0447c10bc9e44d784335edd667771e693e82e99a93c58bb11f SHA512 8a7c7df518a5cbb5ddd16793a742077adfef68244021487fd97efd6fb1b6c743760c01b4f5a7613c30308a38370d1ede5f7f77c2fcda4ae90f928d36c7bebc4f
DIST hypothesis-python-5.23.9.tar.gz 9041210 BLAKE2B e1f121a81cbdf14e1216e3c22eb3afd6997908efbe2ebedc14e3eeb2cbdfaf9efbbdd3d40c6ae4b644d37c13ba18e1aec39f945158d731a413d2933d6da204a8 SHA512 9093005589643c185dbea8c8ee5fd2e9c23c37fe6dc0798dfcbd2afe57d97f652fb1c10d7b482e3fb333499639de1796ac2d091e7e7f41e1c88ac14aed337a31
56 changes: 56 additions & 0 deletions dev-python/hypothesis/hypothesis-5.23.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="threads(+),sqlite"

inherit distutils-r1 eutils

DESCRIPTION="A library for property based testing"
HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
>=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
>=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
!!<dev-python/typing-3.7.4.1
)
"

src_prepare() {
# avoid pytest-xdist dep for one test
sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
tests/pytest/test_statistics.py || die
distutils-r1_src_prepare
}

python_test() {
pytest -vv tests/cover tests/pytest tests/quality ||
die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
optfeature "datetime support" dev-python/pytz
optfeature "dateutil support" dev-python/python-dateutil
optfeature "numpy support" dev-python/numpy
optfeature "django support" dev-python/django dev-python/pytz
optfeature "pandas support" dev-python/pandas
optfeature "pytest support" dev-python/pytest
}

0 comments on commit da3dc03

Please sign in to comment.