Skip to content

Commit

Permalink
dev-python/libtmux: add 0.18.2
Browse files Browse the repository at this point in the history
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
chutz committed Jan 5, 2023
1 parent 5c8c90e commit da44c27
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/libtmux/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libtmux-0.15.10.gh.tar.gz 240378 BLAKE2B 81841a25b01bb26d2c612a14cd4518c48b12162d4aafa280fe0d6de269d149bddaffe72f4ce2c735e41b00cd2bfec19773d7cd3b9fd927c892f11f0cdf8e8a88 SHA512 8ee870c94bd3e3a9fffc19854f978d4faad747ea395e53c3576adc9cc2dcdd3cbdedeeb589a2dc11b0ac836931ffbdcea06a4a850b2ead163235dda2334defb5
DIST libtmux-0.15.9.gh.tar.gz 239611 BLAKE2B 7a171c827fde0ddf3fa0191c00d4e22e5027d925781f7231497c09a038f16d3408ba894d4f8d71470a0d8dbb8f1fc387971d3c8ec94d9f03a3f0af0e2ac0c7c7 SHA512 e7599dece70188cd210de7a1e554d86ba12b8479757dd03903cf3e0608e8e9cf3d181e4c0afc7432d6977dece931707120399690932099ed7d07d847ac76655c
DIST libtmux-0.16.1.gh.tar.gz 246412 BLAKE2B ec95f3aab5b48b9d6a22698c9480e969aba2136225f4728ccbf57deabed105bc6f098e49d3072bf2e5edf8a436f9e36e04b39b8d8e87d206c0ed2703d63ceed2 SHA512 0eb739679a80def01b3810bfe93971eb6c272b4b694ce5e4b846bde8721d2d919f5f8a5e8b6332279a59abfea4bd1e0a510d2ba2ee2d35ff71271920e40cec60
DIST libtmux-0.18.2.gh.tar.gz 261333 BLAKE2B 51def99a71ec9197ff88755183b11ec5fbe15f5f0388603b97141c745af80b4d351163e1ea8d4bf69da543f24eda0c745160e4acd337111a664641758d52260f SHA512 7bdc1d0a356eb94f1717249d2752cd742213a17a5723b7a1e5d6cfa20c839416e31fd72524d8235266d68530f989013eba9d3a86790a456d09944ce9e77f63a4
56 changes: 56 additions & 0 deletions dev-python/libtmux/libtmux-0.18.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..11} pypy3 )

inherit distutils-r1

DESCRIPTION="Python API for tmux"
HOMEPAGE="
https://libtmux.git-pull.com/
https://github.com/tmux-python/libtmux/
https://pypi.org/project/libtmux/
"
SRC_URI="
https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"

RDEPEND="
>=app-misc/tmux-3.0a
"
BDEPEND="
test? (
dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/twine[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

EPYTEST_DESELECT=(
libtmux/pane.py::libtmux.pane.Pane.send_keys
)

python_prepare_all() {
local issues="https://github.com/tmux-python/libtmux/issues/"
sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
rm requirements/doc.txt || die

# increase timeouts for tests
sed -e 's/0.01/0.1/' -i tests/test_test.py || die

sed -e '/addopts/s:--doctest-docutils-modules::' \
-e '/README\.md/d' \
-i setup.cfg || die

distutils-r1_python_prepare_all
}

0 comments on commit da44c27

Please sign in to comment.