forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/apache-tools: Bump to version 2.4.47
Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Apr 29, 2021
1 parent
d014356
commit da5082c
Showing
2 changed files
with
106 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST httpd-2.4.46.tar.bz2 7187805 BLAKE2B 2cd8a40be0b7b60ae5b06a286aa6dd801b8615fd0483a4653ceea6f9832c9ebb111f67ba4f69827b01acd1e5552e70ac0441df49573c9da0ca26d4c2f589f0bc SHA512 5936784bb662e9d8a4f7fe38b70c043b468114d931cd10ea831bfe74461ea5856b64f88f42c567ab791fc8907640a99884ba4b6a600f86d661781812735b6f13 | ||
DIST httpd-2.4.47.tar.bz2 7187445 BLAKE2B ba5b6ebac73aaa6f2f0d7a34d5bf9d13bd4ac862ee9d04b105c315c3aad16401b842b6901424dba6a44a0b5d255c0356e0bf72b5d1898b4b091b12192c204c96 SHA512 ac05e878604037572b484c32c767e022bf027e5efa2a2ed28472939d9f536448f1536ede4d809f1e913a29a0247bdd27981bd00d3d8614f978573c14bce7c7af |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,105 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit flag-o-matic multilib toolchain-funcs | ||
|
||
DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm" | ||
HOMEPAGE="https://httpd.apache.org/" | ||
SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris ~x64-solaris" | ||
IUSE="libressl ssl" | ||
RESTRICT="test" | ||
|
||
RDEPEND=">=dev-libs/apr-1.5.0:1= | ||
dev-libs/apr-util:1= | ||
dev-libs/expat | ||
dev-libs/libpcre | ||
kernel_linux? ( sys-apps/util-linux ) | ||
ssl? ( | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
)" | ||
|
||
DEPEND="${RDEPEND} | ||
sys-devel/libtool" | ||
|
||
S="${WORKDIR}/httpd-${PV}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.4.7-Makefile.patch" #459446 | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# This package really should upgrade to using pcre's .pc file. | ||
cat <<-\EOF >"${T}"/pcre-config | ||
#!/bin/bash | ||
flags=() | ||
for flag; do | ||
if [[ ${flag} == "--version" ]]; then | ||
flags+=( --modversion ) | ||
else | ||
flags+=( "${flag}" ) | ||
fi | ||
done | ||
exec ${PKG_CONFIG} libpcre "${flags[@]}" | ||
EOF | ||
chmod a+x "${T}"/pcre-config || die | ||
} | ||
|
||
src_configure() { | ||
# Brain dead check. | ||
tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no" | ||
|
||
tc-export PKG_CONFIG | ||
|
||
local myeconfargs=( | ||
--libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules | ||
--sbindir="${EPREFIX}"/usr/sbin | ||
--with-perl="${EPREFIX}"/usr/bin/perl | ||
--with-expat="${EPREFIX}"/usr | ||
--with-z="${EPREFIX}"/usr | ||
--with-apr="${SYSROOT}${EPREFIX}"/usr | ||
--with-apr-util="${SYSROOT}${EPREFIX}"/usr | ||
--with-pcre="${T}"/pcre-config | ||
$(use_enable ssl) | ||
$(usex ssl '--with-ssl="${EPREFIX}"/usr' '') | ||
) | ||
# econf overwrites the stuff from config.layout. | ||
ac_cv_path_PKGCONFIG="${PKG_CONFIG}" \ | ||
econf "${myeconfargs[@]}" | ||
sed -i \ | ||
-e '/^LTFLAGS/s:--silent::' \ | ||
build/rules.mk build/config_vars.mk || die | ||
} | ||
|
||
src_compile() { | ||
emake -C support | ||
} | ||
|
||
src_install() { | ||
emake -C support DESTDIR="${D}" install | ||
dodoc CHANGES | ||
doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \ | ||
docs/man/{htcacheclean,rotatelogs}.8 | ||
|
||
# Providing compatiblity symlinks for #177697 (which we'll stop to install | ||
# at some point). | ||
pushd "${ED}"/usr/sbin >/dev/null || die | ||
local i | ||
for i in *; do | ||
dosym ${i} /usr/sbin/${i}2 | ||
done | ||
popd >/dev/null || die | ||
|
||
# Provide a symlink for ab-ssl | ||
if use ssl ; then | ||
dosym ab /usr/bin/ab-ssl | ||
dosym ab /usr/bin/ab2-ssl | ||
fi | ||
} |