Skip to content

Commit

Permalink
dev-python/sympy: Better doc building and update virtualx.eclas usage
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Jan 30, 2016
1 parent 1a4e5db commit da661fc
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 11 deletions.
18 changes: 12 additions & 6 deletions dev-python/sympy/sympy-0.7.6.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )
DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )

inherit distutils-r1 eutils virtualx

Expand All @@ -19,7 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet test texmacs theano"

REQUIRED_USE="${PYTHON_REQUIRED_USE}
doc? ( python_targets_python2_7 )"
doc? ( || ( $(python_gen_useflags 'python2*') ) )"

RDEPEND="
$(python_gen_cond_dep '>=dev-python/pexpect-2.0[${PYTHON_USEDEP}]' python2_7)
Expand All @@ -46,6 +45,10 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"

pkg_setup() {
use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
}

python_prepare_all() {
epatch "${FILESDIR}"/${PN}-0.7.6-doc-makefile.patch
epatch "${FILESDIR}"/${P}-sphinx-1.3.1.patch
Expand All @@ -67,7 +70,7 @@ python_compile_all() {
}

python_test() {
VIRTUALX_COMMAND="./setup.py" virtualmake test
virtx "${PYTHON}" setup.py test
}

python_install() {
Expand All @@ -77,8 +80,11 @@ python_install() {
python_install_all() {
local DOCS=( AUTHORS README.rst )
use doc &&\
DOCS=( ${DOCS[*]} doc/_build/cheatsheet/cheatsheet.pdf doc/_build/cheatsheet/combinatoric_cheatsheet.pdf ) &&\
local HTML_DOCS=( doc/_build/html/. ) &&\
DOCS+=(
doc/_build/cheatsheet/cheatsheet.pdf
doc/_build/cheatsheet/combinatoric_cheatsheet.pdf
) && \
local HTML_DOCS=( doc/_build/html/. ) && \
doinfo doc/_build/texinfo/${PN}.info
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
Expand Down
17 changes: 12 additions & 5 deletions dev-python/sympy/sympy-0.7.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet test texmacs theano"

REQUIRED_USE="${PYTHON_REQUIRED_USE}
doc? ( python_targets_python2_7 )"
doc? ( || ( $(python_gen_useflags 'python2*') ) )"

RDEPEND="
$(python_gen_cond_dep '>=dev-python/pexpect-2.0[${PYTHON_USEDEP}]' python2_7)
Expand All @@ -45,6 +45,10 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"

pkg_setup() {
use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
}

python_prepare_all() {
epatch "${FILESDIR}"/${PN}-0.7.6-doc-makefile.patch
epatch "${FILESDIR}"/${P}-sphinx-1.3.1.patch
Expand All @@ -65,7 +69,7 @@ python_compile_all() {
}

python_test() {
VIRTUALX_COMMAND="./setup.py" virtualmake test
virtx "${PYTHON}" setup.py test
}

python_install() {
Expand All @@ -75,8 +79,11 @@ python_install() {
python_install_all() {
local DOCS=( AUTHORS README.rst )
use doc &&\
DOCS=( ${DOCS[*]} doc/_build/cheatsheet/cheatsheet.pdf doc/_build/cheatsheet/combinatoric_cheatsheet.pdf ) &&\
local HTML_DOCS=( doc/_build/html/. ) &&\
DOCS+=(
doc/_build/cheatsheet/cheatsheet.pdf
doc/_build/cheatsheet/combinatoric_cheatsheet.pdf
) && \
local HTML_DOCS=( doc/_build/html/. ) && \
doinfo doc/_build/texinfo/${PN}.info
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
Expand Down

0 comments on commit da661fc

Please sign in to comment.