Skip to content

Commit

Permalink
games-engines/odamex: Version bump to 0.9.5
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/812503
Signed-off-by: William Breathitt Gray <[email protected]>
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
vilhelmgray authored and chewi committed Sep 11, 2021
1 parent 93e1192 commit da84a67
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-engines/odamex/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST odamex-0.9.3.tar.bz2 6658459 BLAKE2B 1afe34400d2875ac196d5c189a35eb402fce0de90ded496aafcc98d2847ac7cdb10f07261c977a69e2442876897c0931813ddaf1954de2a871af6ca9d9317895 SHA512 114afe22f5651c87cedd7677055286ef9d222de790d9578669fdb5a20b471b273bd427c0dd103a64bcf7c285477776b6fa608b4086f78b4cd8271c33c87afcc3
DIST odamex-0.9.4.tar.bz2 6659835 BLAKE2B df6602c05e911a979e9de168bc08be13ac154106ac6d11f3dbf1c50ce6ccdc10f099ff6caf024e45136e5f6be53eb7db7a7cda89d5b37c0507f37fdae033f2bd SHA512 5488c4245aaf02a6e82714cd137fb6b26da0de808c137506b2575d9bad8025f46ba4d2e063de93a78e86806bbf7950651ec19697dee9b41b11c3aa2963b44e50
DIST odamex-0.9.5.tar.bz2 6659528 BLAKE2B 6f6052aff5a1e0c9a54c417113b67a91044d05ebf13d8ab5fb01132f9bb90b1c97392e881b8bff8baee4621c8e53abbb360fc8c7e6de8ff53d45ee55f73c48ec SHA512 70a0deb5e5b5902620f8fe692dc8507f9f19d7d6afabb4e2efbc25dc6879d469aa250dc55bb165db83a4288af9d5adda72ce3823a3db6dd9ccb83f5c684d3ac8
78 changes: 78 additions & 0 deletions games-engines/odamex/odamex-0.9.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

WX_GTK_VER="3.0-gtk3"
inherit cmake desktop prefix wxwidgets xdg

DESCRIPTION="Online multiplayer free software engine for DOOM"
HOMEPAGE="https://odamex.net/"
SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${PN}-src-${PV}.tar.bz2 -> ${P}.tar.bz2"

LICENSE="GPL-2+ MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+client master +odalaunch portmidi server upnp X"
REQUIRED_USE="|| ( client master server )"

RDEPEND="
client? (
media-libs/libpng:0=
media-libs/libsdl2[joystick,sound,video]
media-libs/sdl2-mixer
net-misc/curl
odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
portmidi? ( media-libs/portmidi )
X? ( x11-libs/libX11 )
)
server? (
upnp? ( net-libs/miniupnpc:= )
)"
DEPEND="${RDEPEND}"
BDEPEND="games-util/deutex"

S="${WORKDIR}/${PN}-src-${PV}"

PATCHES=(
"${FILESDIR}/${PN}-0.9.0-Unbundle-miniupnpc.patch"
)

src_prepare() {
rm -r libraries/libminiupnpc || die
hprefixify common/d_main.cpp

use odalaunch && setup-wxwidgets

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X)
-DUSE_INTERNAL_LIBS=0
-DBUILD_CLIENT=$(usex client)
-DBUILD_LAUNCHER=$(usex odalaunch)
-DBUILD_MASTER=$(usex master)
-DBUILD_SERVER=$(usex server)
-DBUILD_OR_FAIL=1
-DENABLE_PORTMIDI=$(usex portmidi)
-DUSE_MINIUPNP=$(usex upnp)
)

cmake_src_configure
}

src_install() {
if use client ; then
newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
make_desktop_entry "${PN}" "Odamex"

if use odalaunch ; then
newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
make_desktop_entry odalaunch "Odamex Launcher" odalaunch
fi
fi

cmake_src_install
}

0 comments on commit da84a67

Please sign in to comment.