Skip to content

Commit

Permalink
dev-util/umockdev: Version bump to 0.17.18
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Jul 27, 2023
1 parent f0570d2 commit dab557c
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-util/umockdev/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST umockdev-0.17.16.tar.xz 491208 BLAKE2B d653e489285437e1111d8841b3628dc3734e799274e9d334b9200c425d8654a18050e9bab7e290dc12ab12f286a4f492219423d1905965a870d843a1809e9ceb SHA512 5d4a094481510f4466e49766512d0959a5a9d9f5a9b7cbd7719bc94e95d9800760482bf3ea2ee97d2138c89680adb4116964688ae13a07e3c1f0ba8e94230584
DIST umockdev-0.17.17.tar.xz 491504 BLAKE2B 0572b3538641009abdc854513b563eab517268e884896c9e0fec804c50c8397eb7acf011fba5fc5378fdd87db99f6b1eadc29825a0613c021efb29e875a265d1 SHA512 39537bcc56cf554773e8669508832bde6f3d4eb83d605c0e58bed3b2d206a6dc0bd0678bd39954825ee0cbed9f1ea9448f836d97ed3ea7e2aa7ce2875456e459
DIST umockdev-0.17.18.tar.xz 491668 BLAKE2B 106efc5674475383abb7618f087b3536441ae1fa30d6a92b689c1119ff62e06a20a6a529968f2b978f8ed410fc2033c95b86e214d4d4a576cdb9e68ee09a1853 SHA512 3d8d2487b4350e4ce28a5c163cbb1b92da9f5a5317e74da46ccaa62a6b8e938a6758e241d0dd2e9f50fdee4aef24d36585a24cfec1ad99fb4799a01008d9987b
59 changes: 59 additions & 0 deletions dev-util/umockdev/umockdev-0.17.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
PYTHON_COMPAT=( python3_{10..12} )

inherit meson-multilib python-any-r1 vala

if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/martinpitt/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/martinpitt/umockdev/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi

DESCRIPTION="Mock hardware devices for creating unit tests"
HOMEPAGE="https://github.com/martinpitt/umockdev/"

LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
net-libs/libpcap[${MULTILIB_USEDEP}]
virtual/libudev:=[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
>=dev-libs/gobject-introspection-1.32:=
"
DEPEND="${RDEPEND}
test? (
${PYTHON_DEPS}
dev-libs/libgudev:=[${MULTILIB_USEDEP}]
)
"
BDEPEND="
$(vala_depend)
app-arch/xz-utils
virtual/pkgconfig
"

pkg_setup() {
use test && python-any-r1_pkg_setup
}

src_prepare() {
default
vala_setup
}

multilib_src_configure() {
export VALAC="$(type -P valac-$(vala_best_api_version))"
meson_src_configure
}

multilib_src_test() {
meson_src_test --no-suite fails-valgrind
}
2 changes: 1 addition & 1 deletion dev-util/umockdev/umockdev-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2

EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_COMPAT=( python3_{10..12} )

inherit meson-multilib python-any-r1 vala

Expand Down

0 comments on commit dab557c

Please sign in to comment.